How can I permanently disable autocorrect?

Discuss setup / installation issues - Add a spell checker, Language pack?

How can I permanently disable autocorrect?

Postby lowpressure » Fri Nov 28, 2008 2:59 pm

I like to work in OO Writer without AutoCorrect, but although I can turn it off it is turned back on every time I reopen the application.

How can I turn this off permanently?
OOo 3.0.X on Mac OSx other
lowpressure
 
Posts: 4
Joined: Fri Nov 28, 2008 2:55 pm

Re: How can I permanently disable autocorrect?

Postby bobban » Fri Nov 28, 2008 4:00 pm

Remove the check mark from:

Format->AutoFormat->While Typing

When I close and reopen Writer is remembers this setting. It doesn't for you?
OOo 3.1.1 on Ms Windows XP
User avatar
bobban
Volunteer
 
Posts: 535
Joined: Sat Nov 01, 2008 3:12 pm
Location: Australia

Re: How can I permanently disable autocorrect?

Postby Villeroy » Fri Nov 28, 2008 4:08 pm

The settings of menu:Tools>AutoCorrect... are stored in your user profile in file
/Users/<user name>/Library/Application Support/OpenOffice.org/3/user/registry/data/org/openoffice/Office/Common.xcu
That file should be modified when you change the settings.
You may try to create a completely new user profile (reset all cusomizations). Shut down the office suite completely, move directory
/Users/<user name>/Library/Application Support/OpenOffice.org/3/user/
to somewhere else, restart the office, handle the first-start wizard and see if the problem still exists.
I have no idea what menu:Format>AutoFormat does in Writer. Auto correction changes data (what you type into the document). Formatting generally changes the appearance of your data without changing your textual or numeric content.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17305
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How can I permanently disable autocorrect?

Postby bobban » Fri Nov 28, 2008 4:22 pm

I have no idea what menu:Format>AutoFormat does in Writer.


It's the poorly named master switch for Autocorrect, and it looks like it will be reworked in v3.1.

See acknak's post at the bottom of this threadt.
OOo 3.1.1 on Ms Windows XP
User avatar
bobban
Volunteer
 
Posts: 535
Joined: Sat Nov 01, 2008 3:12 pm
Location: Australia

Re: How can I permanently disable autocorrect?

Postby Villeroy » Fri Nov 28, 2008 4:41 pm

Thank you for clarification. I remember that thread, but I did not digest acknak's reply properly since I avoid using word processors mainly because they are incomprehensible to me. This is just another example.
acknak wrote:Loot at Writer: the options set under Tools > AutoCorrect are governed by an overall setting under Format > AutoFormat.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17305
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: How can I permanently disable autocorrect?

Postby bobban » Fri Nov 28, 2008 4:46 pm

Yes, that is one thing that will be cleaned up in v3.1 according to that thread he posted.
OOo 3.1.1 on Ms Windows XP
User avatar
bobban
Volunteer
 
Posts: 535
Joined: Sat Nov 01, 2008 3:12 pm
Location: Australia

Re: How can I permanently disable autocorrect?

Postby lowpressure » Fri Nov 28, 2008 11:35 pm

Thanks for your suggestions.

I tried moving the settings directory and restarting but it doesn't help. AutoFormat is still turned on every time I reopen OO. Is there a config file somewhere in here that I can edit by hand?
OOo 3.0.X on Mac OSx other
lowpressure
 
Posts: 4
Joined: Fri Nov 28, 2008 2:55 pm

Re: How can I permanently disable autocorrect?

Postby acknak » Sat Nov 29, 2008 12:22 am

When you exit and re-start OOo, are you closing down the quickstarter in the system tray as well?
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How can I permanently disable autocorrect?

Postby lowpressure » Sat Nov 29, 2008 10:27 am

Yes, I generally shut down all processes that I'm not using (it clutters up the dock and the tool that I use to swap between applications otherwise).

I just tried leaving the OO quickstarter open, and it does seem to preserve the state of the autoformatting. That's only a partial workaround as I'm only an occasional OO user and I have to reboot my machine from time to time, but it's better than nothing. I just hope I can retrain my fingers not to shut down the whole thing every time!

Is it a bug that this isn't preserved across a restart? Do I need to report this?
OOo 3.0.X on Mac OSx other
lowpressure
 
Posts: 4
Joined: Fri Nov 28, 2008 2:55 pm

Re: How can I permanently disable autocorrect?

Postby bobban » Sat Nov 29, 2008 10:47 am

Is it a bug that this isn't preserved across a restart? Do I need to report this?


I would assume so. You can follow this guide if you want.
OOo 3.1.1 on Ms Windows XP
User avatar
bobban
Volunteer
 
Posts: 535
Joined: Sat Nov 01, 2008 3:12 pm
Location: Australia

Re: How can I permanently disable autocorrect?

Postby exegete77 » Sat Nov 29, 2008 6:55 pm

acknak wrote:When you exit and re-start OOo, are you closing down the quickstarter in the system tray as well?

Not sure, but since he is using OS X there is no "system tray." Are you referring to the Dock? The Dock only provides quick access to launching programs (and tells which programs are currently open), but doesn't affect closing programs.
Mac OS X 10.7.3 Lion
LibreOffice 3.5 / Symphony 3
Scrivener 2.2 / Tinderbox 5.10
exegete77
Volunteer
 
Posts: 230
Joined: Tue May 06, 2008 3:45 pm

Re: How can I permanently disable autocorrect?

Postby acknak » Sat Nov 29, 2008 8:28 pm

Oops--good point. I don't know if OOo on OSX even uses the quickstarter; hopefully, not. I think it causes more trouble than it's worth.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How can I permanently disable autocorrect?

Postby harveyab » Fri Dec 11, 2009 4:07 pm

How about Calc?
Format->AutoFormat... is grayed out. Why?
Harvey (harveyab)
OOo 3.3.0 on MS Windows XP --- Time drags so quickly.
harveyab
 
Posts: 93
Joined: Sat Sep 06, 2008 11:15 pm
Location: WA, USA

Re: How can I permanently disable autocorrect?

Postby acknak » Fri Dec 11, 2009 4:44 pm

They're different functions: AutoFormat applies formatting to tables (in Writer) or to a range of cells in Calc; Autocorrect makes changes to the text you type. In Calc, you have to select a range of cells before the AutoFormat menu is available.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How can I permanently disable autocorrect?

Postby harveyab » Sat Dec 12, 2009 12:22 am

So, the question remains:
How do I completely disable all AutoCorrect functions in Calc?
Harvey (harveyab)
OOo 3.3.0 on MS Windows XP --- Time drags so quickly.
harveyab
 
Posts: 93
Joined: Sat Sep 06, 2008 11:15 pm
Location: WA, USA

Re: How can I permanently disable autocorrect?

Postby acknak » Sat Dec 12, 2009 5:10 am

There is no "master switch" for automatic changes in Calc. There is also more and different kinds of changes than what is available in Writer.

As far as I can think of at the moment, you can use any/all of:
Tools > Cell Content > Autoinput: OFF
Tools > AutoCorrect Options > Options > ... (for specific actions--note: these settings are shared by the other OOo applications)
Tools > Options > OOo Calc > Sort Lists (Calc may use items from these lists to autocomplete what you type)
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How can I permanently disable autocorrect?

Postby cyape3 » Tue Oct 12, 2010 5:31 pm

Still unable to stop OO Calc from "correcting" me. I tried all the things listed, plus going to Options>Language Settings>Writing Aids and disabling everything I could.

I just don't want any kind of auto-correction, in any language, ever.

With MS Excel, at least they were incompetent enough to let me fool the auto-corrector by clicking on other cell without pressing space, tab or enter. When that didn't work, I could copy-paste a few cells and bypass the correction. But OO is too smart to let me get away with it :crazy:

HELP!... this is infuriating. I'm going to have to export to CSV and work with bloody JEdit.
OpenOffice 3.2.1 on Windows 7, Linux and Mac
cyape3
 
Posts: 1
Joined: Tue Oct 12, 2010 5:25 pm

Re: How can I permanently disable autocorrect?

Postby harveyab » Sun Dec 11, 2011 11:45 am

Any new help on this? A master switch would be really nice.
I am working on an interlinear translation, Hebrew to English and it is extremely annoying to not get what I type.
Harvey (harveyab)
OOo 3.3.0 on MS Windows XP --- Time drags so quickly.
harveyab
 
Posts: 93
Joined: Sat Sep 06, 2008 11:15 pm
Location: WA, USA

Re: How can I permanently disable autocorrect?

Postby floris v » Sun Dec 11, 2011 12:09 pm

You will have to ask the developers, we're just other users.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3029
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

[Solved] Re: How can I permanently disable autocorrect?

Postby harveyab » Sun Dec 11, 2011 8:56 pm

Well I found a way - I don't know at what version this showed up, but it has been working for me in version 3.3.

Menu pick: Format/AutoCorrect>
and uncheck While Typing

Then when you want it all just check it again.
Harvey (harveyab)
OOo 3.3.0 on MS Windows XP --- Time drags so quickly.
harveyab
 
Posts: 93
Joined: Sat Sep 06, 2008 11:15 pm
Location: WA, USA

Re: How can I permanently disable autocorrect?

Postby sef650 » Sat Jan 28, 2012 11:47 pm

Thanks. :D
OpenOffice 3.3.0, MacOS X 10.7.2,
sef650
 
Posts: 3
Joined: Wed Nov 09, 2011 9:07 pm


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 7 guests