Page 1 of 4

Forum header update

PostPosted: Sun Aug 11, 2013 9:46 pm
by Hagar Delest
The current header of the forum is a custom one, made years ago IIRC.
Now that 4.0 has been released, there is a little change in the branding. Currently, the 3 main areas users can visit are not consistent, see below:

Decor - AOO main site.png
Main site, not very sexy

Decor - Wiki.png
Wiki, wrong icon but nice background

Decor - Forum.png
Forum, custom branding

On the dev mailling list, Andrea Pescetti wrote:Remember, a consistent branding is a big strength for this project. There are countless scam or dubious sites around, and using the right branding on our sites can help users in recognizing the "official" sites, even though active community members do not need it.

I think that this is indeed a good point to have a consistent branding whatever the area is. I've made a quick proposal to have a nice background with the correct new AOO icon.
NB: wiki would be replaced by forum of course.
Decor - United.png
Proposal

Thoughts?

Edit: related report: Bug 122998 - Forum and wiki Header design.

Re: Forum header update

PostPosted: Sun Aug 11, 2013 10:09 pm
by RoryOF
+1

Re: Forum header update

PostPosted: Sun Aug 11, 2013 11:45 pm
by acknak
Good point, Hagar!

One potential issue: we're not exclusively an Apache Open Office (nee OpenOffice.org) site. We've purposely used slightly different branding to communicate that we are independent--at some level--from the hosting organization.

The branding issue could well be more important at this point. And, I wonder just how many visitors pick up on the subtle difference and connect that with forum governance. Maybe it's time to drop the attempt at visual distinction and just let the side text take care of it.

Re: Forum header update

PostPosted: Sun Aug 11, 2013 11:52 pm
by Hagar Delest
acknak wrote:The branding issue could well be more important at this point. And, I wonder just how many visitors pick up on the subtle difference and connect that with forum governance. Maybe it's time to drop the attempt at visual distinction and just let the side text take care of it.

Yes, I think that the text should be kept for that purpose.

Re: Forum header update

PostPosted: Mon Aug 12, 2013 1:34 am
by RGB
Hagar Delest wrote:The current header of the forum is a custom one, made years ago IIRC.

Just one year ago :mrgreen:

Hagar Delest wrote:Now that 4.0 has been released, there is a little change in the branding. Currently, the 3 main areas users can visit are not consistent, see below:

The attachment Decor - AOO main site.png is no longer available

The attachment Decor - Wiki.png is no longer available

The attachment Decor - Forum.png is no longer available

On the dev mailling list, Andrea Pescetti wrote:Remember, a consistent branding is a big strength for this project. There are countless scam or dubious sites around, and using the right branding on our sites can help users in recognizing the "official" sites, even though active community members do not need it.

I think that this is indeed a good point to have a consistent branding whatever the area is. I've made a quick proposal to have a nice background with the correct new AOO icon.
NB: wiki would be replaced by forum of course.
The attachment Decor - United.png is no longer available

Thoughts?


I agree on using the project logo here on the forum too. Another logo can can be updated is the download logo we have on the footer of each page.

On a related note, the text that shows on the browser title bar when browsing the EN forum is wrong:
EN-forum.png


"OpenOffice.org" should be updated ;)

That text can be changed on the ACP → General tab → Site configuration → Site name.

Re: Forum header update

PostPosted: Mon Aug 12, 2013 8:30 am
by Hagar Delest
Should have remembered this long discussion indeed!

I've fixed the browser tip, thanks.

Download icon is to be updated also. Will try to make a proposal to be implemented by someone having enough rights for the upload.

Re: Forum header update

PostPosted: Mon Aug 12, 2013 10:49 am
by floris v
RoryOF wrote:+1

+1

Re: Forum header update

PostPosted: Mon Aug 12, 2013 9:54 pm
by Hagar Delest
Here is my proposal for the new download icon:
AOO4_download_logo.png
AOO4_download_logo.png (7.5 KiB) Viewed 13310 times

Re: Forum header update

PostPosted: Mon Aug 12, 2013 11:14 pm
by floris v
I like it. And I love your avatar. As you are our most productive poster, maybe we should integrate that in the forum logo. ;)

Re: Forum header update

PostPosted: Tue Aug 13, 2013 1:40 am
by pescetti
From a technical point of view, the header is a bit tricky since we now have:

It is probably feasible to adapt Hagar's concept to follow this structure.

Also note that we have other proposals at https://issues.apache.org/ooo/show_bug.cgi?id=122998

Re: Forum header update

PostPosted: Wed Aug 14, 2013 10:46 pm
by jza
Hello I started the discussion on the ML, I just found the thread now. I have been working with imacat to update the logo and have created the bug to update the following headers.

As my message on the bug said: "There was a conversation about the lack of compatibility between the current forum logo and the current Apache OpenOffice Logo."

I know about acknak history as I was involved with drew on the building process of the forum. I also update the branding from the jittered version a few moons ago.

The initial proposal was incremental to switch only the typeset, Andrea suggested to also replace the gulls with the orb design. Currently you can see the attachments source and rasterized for it.

Imacat already have the images up on the forum server, we are just waiting a final consensus. :super:
forum-header.png
Proposal on server.
forum-header.png (11.63 KiB) Viewed 13246 times

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:00 pm
by Hagar Delest
Thanks (I remembered your bug report after raising the subject).
Your proposal with the forum background is indeed very nice if the standard one is not compatible with the forum background.
NB: rendering is strange in your post.

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:03 pm
by jza
Forum index is already updated as well:
forum.png
Forum index

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:14 pm
by jza
Hagar Delest wrote:NB: wiki would be replaced by forum of course.
The attachment Decor - United.png is no longer available

Thoughts?

Edit: related report: Bug 122998 - Forum and wiki Header design.


JanIV made a comment about having the same forum head bar, but this is difficult since it respond to a different html-css structure. this task is possible but major changes to the theme need to be applied. Not only that but the wiki theme is outdated as the www site no longer carry this theme (it was replaced with Oracle's take over in 2010).

In other words, wiki needs to catch up with www.

There is also a new theme being worked on the drupal sites (extensions and templates).

Anyway I did generate a banner for forum similar to the wiki, since that day.
forumheader.png
Forum header banner. ** Outdated theme ***


My proposal is for the wiki to adopt the Durpal theme, and re-design the header w/logo. At the moment mWiki already has the new logo.

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:16 pm
by Hagar Delest
Why not the standard logo for the forum landing page? It would give more consistency with the other areas.
I'm not sure the feather and the sub-line are really needed.

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:31 pm
by jza
Hagar Delest wrote:Why not the standard logo for the forum landing page? It would give more consistency with the other areas.
I'm not sure the feather and the sub-line are really needed.


The original image had them, i just update the actual typeset and globe, and put the logo instead.
forum-logoprev.png
forum-logoprev.png (19.38 KiB) Viewed 13234 times

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:33 pm
by Hagar Delest
I know but I find it a bit too "funny"!
I prefer more sober icons and if possible consistent with the main branding.

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:38 pm
by jza
Hagar Delest wrote:I know but I find it a bit too "funny"!
I prefer more sober icons and if possible consistent with the main branding.

In that case I dont see a need for duplication and just link from the www site.
http://www.openoffice.org/images/AOO_lo ... e_logo.png

Hopefully the canonical logo.png convention goes through and we can just have a unique url and get it updated as we go along.

Re: Forum header update

PostPosted: Wed Aug 14, 2013 11:52 pm
by Hagar Delest
That would be fine for me.

Re: Forum header update

PostPosted: Thu Aug 15, 2013 12:01 am
by jza
So do we have a go on this image?
Image

Re: Forum header update

PostPosted: Thu Aug 15, 2013 12:53 am
by acknak
Here's what I get with the logo image on the forum banner background. There seems to be some problem with colors in the "orb" no? They're so light it's difficult to see the design at all.

forum_banner_proposal_00.png
forum_banner_proposal_00.png (16.43 KiB) Viewed 13214 times


It also seems there is too much space between the orb and the text. It looks a bit "off" to me.

Re: Forum header update

PostPosted: Thu Aug 15, 2013 1:16 am
by jza
Seems the gulls had a contour around the SVG, and i agree on the space between. I put the original logo (with the natural separation).

AOO-Forumlogo.png
Fixed separation
AOO-Forumlogo.png (10.8 KiB) Viewed 13214 times
with background
forumwbg.png
with background.
forumwbg.png (15.46 KiB) Viewed 13214 times

Re: Forum header update

PostPosted: Thu Aug 15, 2013 10:03 pm
by jza
Logo is up and running.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 1:44 am
by RGB
Sorry but there is something utterly wrong going on here: you cannot pass from a proposal to a working implementation in just one day, specially considering that the concern expressed by acknak was not answered! We are a community, we do things by discussion and consensus, and that always needs time. The "lazy consensus" in use at Apache ask for at least 72 hours before doing something, an for a reason. What you did has nothing to do with implementing a new logo, you simply bypassed the opinion of everyone here!

Note that I'm not discussing the merit of your work on the new logo, I'm discussing the serious communication problem that arise from its sudden implementation. A big -1 from my side.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 1:54 am
by jza
AFAIK the proposal was done on the mailing list for a almost 4 days now, there was no real -1 (until now). Ackneck really never raised an issue as much of a historic reference, neither he mentioned an alternative route.

Like I mentioned on my post, the logo is not new, this logo has been implemented for a good 3 weeks, (yes the color is different because of background). Like I said, I was asking for consensus and there was IMO a consensus reached that having common branding was agreed upon.

I also checked other posts, and all discussions never seems to end in a "verbal conclusion". Again, even your -1 isn't really concerning the work at hand, nor are giving an alternative route to act upon (actually you are suggesting the opposite). The work is done, if you want to take it down, is up to you to propose a rollback and wait the 72hrs for agreement.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 2:28 am
by RGB
I'm not discussing the logo and in fact I agree on the need for an uniform branding. I'm discussing the process. I'm discussing the failure on the communication process. The proposal here is just one day old. Asking for an opinion and then acting without waiting for the answer is wrong independently of the fact that the action ended being good or bad.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 2:51 am
by jza
I am sorry but what you are suggesting is a 72hrs timeline on mailinglist then 72hrs on bugzilla then 72 on forums. The thread was started on Sunday EST we are on thursday. Its well beyond the period.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 8:33 am
by floris v
Well, many volunteers here don't regularly visit the mailing lists.

Re: Forum header update

PostPosted: Fri Aug 16, 2013 12:10 pm
by Hagar Delest
Anyway, I don't think we have much choice. Nobody has proposed any alternative. So I'm not against the already made change.

However, there is still the problem with the color of the orb logo that is not right.
Does it mean that we need to change the background of the banner so that we have the right set of colors?

Re: Forum header update

PostPosted: Sun Aug 18, 2013 10:18 pm
by RGB
Hagar Delest wrote:Anyway, I don't think we have much choice. Nobody has proposed any alternative.

This thread was started the 11th and the logo was checked in the 15th, no wonder there was no other proposals: as floris said, not all people here (I'll add: almost nobody here) follows the mailing lists, which is perfectly fine.

In fact, Friday there was a proposal on the ES forums by user SLV-es

Image

it needs a lot of work, but what it is clear from this example is the simple fact that if you give people a chance, people will respond. With enough time and good communication, two things that were completely missing here, everything is possible.