Page 1 of 1

[Solved] Problem accessing the forum

PostPosted: Thu Mar 21, 2013 2:12 pm
by Nocton
For the last week or so, when I try to access the form web site I get the meassge:
General Error
SQL ERROR [ mysqli ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Sometimes the site seems to be down for most of the day. Other times, as today, the problem had cleared when I retried after about an hour.

Regards, Nocton

Re: Problem accessing the forum

PostPosted: Thu Mar 21, 2013 2:53 pm
by crusader
Amen!

Re: Problem accessing the forum

PostPosted: Thu Mar 21, 2013 2:59 pm
by RoryOF
The response from Apache Infra to a query from the Fr forum was
Result of my dialog with #asfinfra
[11:15] <@pctony> fr__: this service is technically a community run service
[11:15] <fr__> i don't know what is mean
[11:16] <@pctony> basically it means, in plain english, this is not truly an infra issue.
[11:18] <fr__> well how can we fixed this issue?
[11:20] <@pctony> fr__: I can restart the webservice, but this wont fix the problem! The issue is that MySQL has not been tuned and needs to be. You should contact the OOO community.


We need someone with MYSQL config skills, which I haven't. Any volunteers?

Re: Problem accessing the forum

PostPosted: Thu Mar 21, 2013 3:18 pm
by Villeroy

Re: Problem accessing the forum

PostPosted: Thu Mar 21, 2013 7:46 pm
by Nocton
Thank you, Villeroy. So what we really need is to trap the error and give an informative message. Or permit more connections.

Re: Problem accessing the forum

PostPosted: Thu Mar 21, 2013 7:53 pm
by RoryOF
It may need more analysis than just giving it more connections. Note that the number of connected users reported has remained at 294 since 25 October 2012; on some Forum crash occasions I have noted perhaps 120 Users - a long way off the 294. Perhaps there is some form of slowloris or other denial of service attack taking place.

Other notes remark that the "too many connections error" can arise as a spurious message from from full system logs or insufficient disk space.

Re: Problem accessing the forum

PostPosted: Fri Mar 22, 2013 7:02 pm
by B Marcelly
Thinking about it, it looks like the connections to the server are never released, at least in some cases. That would explain the growing number of connections, until the limit is reached.

Re: Problem accessing the forum

PostPosted: Fri Mar 22, 2013 8:09 pm
by acknak
So the forum is "community managed" ... has anyone contacted our admin, imacat memberlist.php?mode=viewprofile&u=54688

I just assumed that the problem affected more than just us (the problem seems to be something new) and either the Apache folks were looking into it, or that imacat would learn of the problem "somehow".

I guess we should have previously worked out what to do when a problem comes up :oops:

Re: Problem accessing the forum

PostPosted: Fri Mar 22, 2013 8:21 pm
by RoryOF
Apparently the master Forum page works, but some, if not all, of the Forums may be intermittent.

Re: Problem accessing the forum

PostPosted: Fri Mar 22, 2013 8:54 pm
by RPG
Hello

There are also problems for the Dutch forum. The problems seems not always on the same time.

Romke

Re: Problem accessing the forum

PostPosted: Fri Mar 22, 2013 11:36 pm
by Hagar Delest
acknak wrote:So the forum is "community managed" ... has anyone contacted our admin, imacat memberlist.php?mode=viewprofile&u=54688

Yes, I did on Mar. 14th and she replied that she would have a look.

acknak wrote:I guess we should have previously worked out what to do when a problem comes up :oops:

That's why we had asked for an additional admin on the mailing list, which led to imacat as new admin.

Re: Problem accessing the forum

PostPosted: Sat Mar 23, 2013 3:41 am
by acknak
Hagar Delest wrote:...
acknak wrote:I guess we should have previously worked out what to do when a problem comes up :oops:

That's why we had asked for an additional admin on the mailing list, which led to imacat as new admin.

Sorry, I meant a protocol for a situation like this: who would take charge of contacting the admin, and how, since the forum could be off line.

This wasn't needed when Terry was the admin, as he was also using the forum. But now we need some defined way to make sure that the admin knows when there's a problem--and that we can know that it's being looked at.

Re: Problem accessing the forum

PostPosted: Sat Mar 23, 2013 1:05 pm
by Hagar Delest
When I see problems, I send a mail directly to imacat. I fear that Drew has other priorities for the moment. Since nor the dev mailing list nor infra team is of any real support, we are on our own. So imacat is the only one who can help quickly. But due to the different time zone and perhaps her own workload, reactivity is much less good than with Terry.

If someone has some skills with such technical field, we could appoint him admin too.