Spell Check and auto spellcheck does not work

Discuss the word processor

Spell Check and auto spellcheck does not work

Postby ccolombo » Wed Aug 27, 2008 3:12 pm

Welcome beginner. What is your question or comment?
Please try to briefly and clearly tell us: What you want, What you tried, and What happened.
-----------------------------------------------------------------------------------------------------------

Have downloaded OO2.4. No squiggle red line under bad words, try to manually check spelling and it simply passes over the document, asks to start at the beginning and then indicates nothing found.

Thanks
OOo 2.4.X on Ms Windows XP
ccolombo
 
Posts: 1
Joined: Wed Aug 27, 2008 3:08 pm

Re: Spell Check and auto spellcheck does not work

Postby foxcole » Wed Aug 27, 2008 7:53 pm

Hello, ccolombo.

Please have a look at the Survival Guide. If you search the forum you'll find many related threads.

But here's a good place to start: [Tutorial] Spell check and Language configuration in the Tutorials forum. If you have any problems or if this doesn't solve the problem, please post here and we'll get it sorted. If you are able to resolve the issue, please edit your first post and add [Solved] to the subject line.
Cheers!
---Fox

OOo 3.2.0 Portable, Windows 7 Home Premium 64-bit
User avatar
foxcole
Volunteer
 
Posts: 1507
Joined: Mon Oct 08, 2007 1:31 am
Location: Minneapolis, Minnesota

Re: Spell Check and auto spellcheck does not work

Postby Wynne » Wed Sep 17, 2008 8:30 am

I went to the Tutorial and nothing made any sense... I don't have an option to turn on or off the abc with the red line, I don't seem to have any option that says "paragraph style" (There's a "paragraph" under the Format tab but nothing about style there, etc...
I guess I need to start further back from where this tutorial starts or something. Reading other posts, I get the impression I might have to do further downloads of the dictionary I need or something.

I have OO 2.4.2 or 2.4.1. Windows Vista. If anybody could get me pushed into the right direction, I would appreciate your help. My kids' english marks are in grave peril!

Back again. I went to try the Wizard\Add a dictionary process and shut down the computer. (What does shut down the Quickstart mean??) Anyways. This made no difference.
Last edited by Wynne on Wed Sep 17, 2008 10:42 am, edited 1 time in total.
OOo 2.4.X on MS Windows Vista
Wynne
 
Posts: 3
Joined: Wed Sep 17, 2008 8:13 am

Re: Spell Check and auto spellcheck does not work

Postby Caracalla » Wed Sep 17, 2008 9:07 am

Wynne wrote:I went to the Tutorial and nothing made any sense... I don't have an option to turn on or off the abc with the red line, I don't seem to have any option that says "paragraph style" (There's a "paragraph" under the Format tab but nothing about style there, etc...

There is no button on you interface that shows "abc" with a little red line under it? If you right click on a piece of text, the contex menu does not show an entry called "paragraph style"? If you do not see these things i really have to wonder where you downloaded OOo.

Wynne wrote:I guess I need to start further back from where this tutorial starts or something. Reading other posts, I get the impression I might have to do further downloads of the dictionary I need or something.

Assuming you want to check US english, and you have the US version of OOo you should not have to download anything extra.

Wynne wrote:I have OO 2.4.2 or 2.4.1. Windows Vista. If anybody could get me pushed into the right direction, I would appreciate your help. My kids' english marks are in grave peril!

So sorry, but if your kid is depending on the spell checker for his grades he is going about it in the wrong way. Perhaps you should buy the kid a dictionary? Spell checkers (much less grammar checkers) will never be a substitue for actual language skills.

Wynne wrote:Back again. I went to try the Wizard\Add a dictionary process and shut down the computer. (What does shut down the Quickstart mean??) Anyways. This made no difference.Wynne

The quickstarter is the little OOo icon at the bottom right of your screen. It has to be turned off or you will not be able to install any dictionaries.
Has your question been answered? Then please add [solved] to the title of your thread.
My pet peeve, No support for international ordinal numbering
please vote

Er is nu ook een Nederlandstalig forum!
OOo 3.0.X on Ms Windows XP + Opensuse 11.1
Caracalla
Volunteer
 
Posts: 474
Joined: Thu Nov 22, 2007 2:35 pm
Location: Netherlands, EU

Re: Spell Check and auto spellcheck does not work

Postby Wynne » Wed Sep 17, 2008 10:21 am

Thanks so much for your kind reply, Caracalla.

Yes, I do have a button with abc and a red line under it. What I said is that I don't seem to have any option to turn it on or off. I click on it and it goes dark or not so dark. If dark or not so dark means "on" or "off", it does not seem to make any difference to the spell check option.

The tutorial says "Look at the paragraph style..." Nothing about right clicking, "context menus", blah, blah, blah. Anyways, after you so incredulously pointed out this little oh so obvious bit of info, I did this and the language showed English Canadian. This seems right. There's no ABC check mark in front of the language box in this window (Is this where it is supposed to be?) So maybe that's the problem...

Yes.. let's think of places I could have downloaded OOo... uhhh, cheapskates.com or... Ilikeabuse.org or... letswasteourtime.net or maybe even meetrudepeople.com? I'm beginning to wonder myself.

I understand that spell checkers are not a good "substitue" for English skills. Thanks ever so much for the parenting advice.

I'll try getting the dictionary again through the Wizard option and turn off the "quickstart" thing. Although I don't think this is the problem. An American English check would be fine and apparently I don't need to load anything for that. Doesn't make sense to me.

After that I am so outta here... er, make that "out of here". Heaven forbid, I don't want to be the brunt of more incredulity...
OOo 2.4.X on MS Windows Vista
Wynne
 
Posts: 3
Joined: Wed Sep 17, 2008 8:13 am

Re: Spell Check and auto spellcheck does not work

Postby Caracalla » Wed Sep 17, 2008 10:46 am

Wynne wrote:Yes, I do have a button with abc and a red line under it. What I said is that I don't seem to have any option to turn it on or off. I click on it and it goes dark or not so dark. If dark or not so dark means "on" or "off", it does not seem to make any difference to the spell check option.

Dark is "on", not so dark is "off" yes.

Wynne wrote:The tutorial says "Look at the paragraph style..." Nothing about right clicking, "context menus", blah, blah, blah. Anyways, after you so incredulously pointed out this little oh so obvious bit of info, I did this and the language showed English Canadian. This seems right. There's no ABC check mark in front of the language box in this window (Is this where it is supposed to be?) So maybe that's the problem...

Yup, that's where the checkmark is supposed to be. So if it's English-Canadian spell checking you want you will have to install that dictionary through the wizard (making sure that the quickstarter is turned off, this does make a difference). Is there a checkmark in front of US english?

Wynne wrote:Yes.. let's think of places I could have downloaded OOo... uhhh, cheapskates.com or... Ilikeabuse.org or... letswasteourtime.net or maybe even meetrudepeople.com? I'm beginning to wonder myself.

eh? now what is that supposed to mean. From your post i got the impression that things were not where they are suppsed to be. So i had to wonder didn't i? i certainly have no intention of being rude, i'm sorry if that's the impression you got.
Last edited by Caracalla on Wed Sep 17, 2008 11:06 am, edited 1 time in total.
Has your question been answered? Then please add [solved] to the title of your thread.
My pet peeve, No support for international ordinal numbering
please vote

Er is nu ook een Nederlandstalig forum!
OOo 3.0.X on Ms Windows XP + Opensuse 11.1
Caracalla
Volunteer
 
Posts: 474
Joined: Thu Nov 22, 2007 2:35 pm
Location: Netherlands, EU

Re: Spell Check and auto spellcheck does not work

Postby Wynne » Wed Sep 17, 2008 10:51 am

The Spell check is now working.

I guess the problem was that I had to download a dictionary and that I hadn't disabled the Quickstart.

Hurray! Now my flunkie kids will be able to cheat their way past the English teacher... or should I say:

Know may "flunkie" kids well bee able two cheat there whey passed the English tea chair know that they have Spell Check!
OOo 2.4.X on MS Windows Vista
Wynne
 
Posts: 3
Joined: Wed Sep 17, 2008 8:13 am

Re: Spell Check and auto spellcheck does not work

Postby Kroustein » Wed Sep 16, 2009 3:47 am

WOW. Is this how a father and a Dutch volunteer react to each other? Look at you two! It took me, an American, looking at your HISSY FIT, all of five seconds to be disgusted by how below both of you your actions are. Wow, I say again, wow! How is it that an American can reprimand a Canadian and a Netherlander (my apologies if this is not the phrase I was looking for)? Stop acting like children. Stop thinking anyone on the internet is sub-human.
Good day, gentlemen.
Kroustein
 

Re: Spell Check and auto spellcheck does not work

Postby TheGurkha » Wed Sep 16, 2009 11:42 am

You do realize that this thread is a year old?
Ubuntu 13.04 Raring ringtail, LibO 4.0.2.2 (Build ID 400m0 (Build:2))
Gurkha Welfare Trust
User avatar
TheGurkha
Moderator
 
Posts: 6426
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: Spell Check and auto spellcheck does not work

Postby MicJonMat » Sun Jun 26, 2011 1:59 am

This is a troubleshooting note on OpenOffice version 3.1 concerning auto spell check.

I'm constantly making up words and then adding them to the dictionary so they don't clutter the spellchecker. After adding many words to the dictionary OpenOffice ceased underlining misspelled words on all documents. I followed the entire tutorial for auto spell check, and did not resolve the issue.

I continued experimenting and resolved the problem as follows.
Tools > Options > Language Settings > Writing Aids
In the third panel labeled options, I unchecked the options, "Check spelling as you type," and, "Check grammar as you type," and then clicked the "OK" button.
Without exciting the program or restarting the computer I simply returned to the same screen, checked the boxes for both options and again clicked the "OK" button.
That fixed the problem, and now misspelled words are again underlined.

I noticed the same tendency in MS Word, after a certain amount of custom words were added to the dictionary the auto spell check ceased functioning. I don't know the details, but I'm guessing the process described above cleared out some residual issue developed during the course of adding custom words, but that's only a guess.

I'm submitting this because it might prove useful, and so it could be considered for the troubleshooting article on auto spell check, since it fixed my problem.
OpenOffice 3.1 on Windows Vista
MicJonMat
 
Posts: 1
Joined: Sun Jun 26, 2011 1:42 am

Re: Spell Check and auto spellcheck does not work

Postby Hagar Delest » Sun Jun 26, 2011 10:58 am

Thanks for the info.

Can you say how many words you have in your custom dictionary? You should be able to copy the whole content and paste it in a Calc spreadsheet to see how many rows you get.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: Grytpype and 35 guests