[Solved] ~Lock.[filename].odt# is saved on desktop

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] ~Lock.[filename].odt# is saved on desktop

Postby lightfoot500 » Thu Jul 27, 2017 5:31 am

Ok, very new to OO. but i notice that besides the saved file that i am working on which appears on the desktop when i save it. i get this other file show up which has a similar file name but it will not open. when i try to open it, i get a message that windows cant open it. Windows needs to know what program i want it to use. all i can think of is these ~lock files appear if windows is not turned off properly.

OO is a wonderful software, thank you all for developing it.
how to prevent it from putting the ~lock files up on my desktop ? or is it serving a purpose ?
Last edited by thomasjk on Sun Jul 30, 2017 4:35 am, edited 1 time in total.
Reason: Mark thread [Solved] and add green checkmark
OpenOffice 4.1.3
Windows 7
lightfoot500
 
Posts: 16
Joined: Thu Jul 27, 2017 5:21 am

Re: ~Lock.[filename].odt# is saved on desktop

Postby FJCC » Thu Jul 27, 2017 6:24 am

The ~lock file is there to show that the file is in use. It should disappear when you close the file. If it remains after the file is closed, then something isn't working properly. Do you have a bunch of ~lock files on the desktop?
AOO 3.4 or 4.1 on MS Windows XP ( before 2013-08-03) or Windows 7
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 6889
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: ~Lock.[filename].odt# is saved on desktop

Postby robleyd » Thu Jul 27, 2017 6:40 am

The Lock file does serve a purpose - see this topic for more information.

They are created in the same directory as your document when you save it, and are automatically deleted when you close the document cleanly. They are hidden files, so normally won't show up in Windows Explorer with default settings of don't show hidden files. It may be that the desktop doesn't have such a setting, or that settings have been changed to show hidden files.

There are apparently some good reasons not to save files to the desktop - see this article for instance.

As an alternative, consider saving the files somewhere in or under My Documents and simply create a shortcut on the desktop - which you can then delete when it is no longer needed.
Cheers
David
Apache OpenOffice 4.1.6 - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2251
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: ~Lock.[filename].odt# is saved on desktop

Postby RoryOF » Thu Jul 27, 2017 9:35 am

In addition to the remarks above, note that OpenOffice, if opened as a program, either from the Programs button or from the shortcut icon on the desktop (usually a blue globe with seagulls), will give you a list (and links) on the /File/Recent documents entry of the ten most recent documents edited.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27654
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: ~Lock.[filename].odt# is saved on desktop

Postby lightfoot500 » Sun Jul 30, 2017 1:29 am

ok thank you. yes i see that the files are deleted when i close the file
OpenOffice 4.1.3
Windows 7
lightfoot500
 
Posts: 16
Joined: Thu Jul 27, 2017 5:21 am


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 6 guests