4.0.1 Installation Hang up?

Issues with installing under all versions of MS Windows

4.0.1 Installation Hang up?

Postby wildbwest » Thu Apr 24, 2014 8:56 pm

When Trying to install Open office 4.0.1 on my new windows 8.1 pc , it reached 0% remaining on the Microsoft C++ 2008 pre installation setup then nothing happens on screen for 45 mins (although CPU and hard disk working hard).
Then windows message says program not responding and I eventually terminated setup.
How long should this stage take?
(Also now a problem trying to undo setup changes - clicking yes didn't seem to do anything)
Open office 4.0.1
Windows 8.1 64bit
wildbwest
 
Posts: 4
Joined: Thu Apr 24, 2014 8:41 pm

Re: 4.0.1 Installation Hang up?

Postby floris v » Thu Apr 24, 2014 9:20 pm

Where did you download that install file? It should not have anything to do with MS C++
MS Windows 10 - AOO 4.1.3 - LibreOffice 5.2.3.3
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4010
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: 4.0.1 Installation Hang up?

Postby Bill » Thu Apr 24, 2014 9:44 pm

The Microsoft Visual C++ 2008 Redistributable must be installed before AOO itself is installed. It is included in the AOO installation files folder.

Did you try restarting the computer and running the setup again? Did you check in Programs and Features to see if the Redistributable or OpenOffice was installed?
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6946
Joined: Sat Nov 24, 2007 6:48 am

Re: 4.0.1 Installation Hang up?

Postby wildbwest » Fri Apr 25, 2014 12:11 pm

Thanks for the response.
Microsoft Visual C++ 2008 Redistributable was installed at this time, but Openoffice was not.
I did restart the pc and tried the open office installation again. It downloads and tries the pre installation setup, but gives the error message
Error 1704. An installation for Microsoft Visual C++ 2008 Redistributable is currently suspended. You must undo the changes made by that installation to continue.. Undo changes?

Clicking Yes doesn't do anything and brings back the same error message, clicking No then starts the Openoffice installation, but it immediately fails saying problem with Microsoft Visual C++ 2008 Redistributable.
I'll probably try uninstalling Microsoft Visual C++ 2008 Redistributable, but would still like to know if the original installation is meant to take a long time.
Open office 4.0.1
Windows 8.1 64bit
wildbwest
 
Posts: 4
Joined: Thu Apr 24, 2014 8:41 pm

Re: 4.0.1 Installation Hang up?

Postby floris v » Fri Apr 25, 2014 12:24 pm

No, it should hurry through that stage.
MS Windows 10 - AOO 4.1.3 - LibreOffice 5.2.3.3
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4010
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: 4.0.1 Installation Hang up?

Postby Bill » Fri Apr 25, 2014 12:53 pm

wildbwest wrote:I did restart the pc and tried the open office installation again. It downloads...

Do you mean "It unpacks" instead of "It downloads"? There should be no downloads after you start the installation. The installation files should be unpacked. Everything needed to complete the installation is contained in the unpacked installation files. Did you download the installer and run it locally or run the installer without downloading? Download only from the official site: http://www.openoffice.org/download/

For me, installation of the Redistributable takes less than a minute, and the complete installation, including unpacking the installation files takes less than 5 minutes.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6946
Joined: Sat Nov 24, 2007 6:48 am

Re: 4.0.1 Installation Hang up?

Postby wildbwest » Fri Apr 25, 2014 5:26 pm

Bill wrote: Do you mean "It unpacks" instead of "It downloads"? There should be no downloads after you start the installation...


The first time I ran it straight from the web page on sourceforge.net which http://www.openoffice.org/download/ directed me to, the second time I downloaded it first then ran it immediately. The hang up occurs when unpacking the installation files ( I think)

Regarding length of time - could a copy of MS Office that came with the new PC (not enabled / registered, but on the installed programs list) affect it. Also could McAfee security software affect it that much?
Open office 4.0.1
Windows 8.1 64bit
wildbwest
 
Posts: 4
Joined: Thu Apr 24, 2014 8:41 pm

Re: 4.0.1 Installation Hang up?

Postby Bill » Fri Apr 25, 2014 8:59 pm

MS Office shouldn't affect the installation, but I have no way of knowing how McAffee might affect it.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6946
Joined: Sat Nov 24, 2007 6:48 am

Re: 4.0.1 Installation Hang up?

Postby mplaut » Sun May 11, 2014 2:20 am

Is there a solution for this problem? I have the same issue on a new computer with Win 8.0 (soon to upgrade to 8.1) I see that 2 versions of Visual c++ 2005 are installed and 6 of vc++ 2008 and also 2 of VC++ 2010
M Plaut
Openoffice 4.1.4 on Windows 10
mplaut
 
Posts: 23
Joined: Thu May 06, 2010 12:41 am

Re: 4.0.1 Installation Hang up?

Postby wildbwest » Sun May 11, 2014 4:25 pm

Sorry, no definite solution yet. I haven't tried again as I don't need to use open office yet, and so far nobody has indicated why my installation didn't work. Open Office 4.0.1 used visual c++ 2008 x64 ....6161 for installation on my pc, which I have since removed by using windows restore to get to where I was pre-installation.
Open office 4.0.1
Windows 8.1 64bit
wildbwest
 
Posts: 4
Joined: Thu Apr 24, 2014 8:41 pm

Re: 4.0.1 Installation Hang up?

Postby Garthfunkel » Thu Jun 19, 2014 8:46 am

Same problem, figured I'd bump this up if there hasn't been a solution yet:

The first error message that occurs as I try to install 4.1.0 on Windows 8 is:

"Error 1704.An installation for Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161 is currently suspended. You must undo the changes made by that installation to continue. Do you want to undo those changes?" - This message comes from the Microsoft Visual installation programme. This leads me to believe the problem lies there of course, and not OpenOffice, but nevertheless, it seems to only mess with my OpenOffice installation, as I've managed to install other programmes since.

Clicking "Yes" only opens the same error message within a millisecond, clicking "No" sends me to the next part of the installation, asking me to put in the name of the OpenOffice-user, asks to create a shortcut on the desktop etc. etc., and then..

"Error 1704.Installation of Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161 is currently suspened [...]" again!

This time when I click "No", it takes me to the final page of the installation, where it informs me that the installation has not been made.

I have tried to install OpenOffice at least five times, every time downloading from the Sourceforge-page as instructed, I have deleted the downloaded files and re-downloaded them, I have re-booted the computer, I have waited a few days and tried it all again. It's not working, this Microsoft Visual-programme is messing with me, and any help at all in solving this would be greatly appreciated.
Would-be OpenOffice 4.1.0 on Windows 8
Garthfunkel
 
Posts: 1
Joined: Thu Jun 19, 2014 8:32 am

Re: 4.0.1 Installation Hang up?

Postby RoryOF » Thu Jun 19, 2014 9:13 am

A quick search gives this answer
This error message will occur if the key "HKLM\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress" exists.

arising from an interrupted earlier install, or a failure to reboot when requested during course of an earlier install.

A cure is to delete this key from the registry. However, if at all unsure about editing the registry, don't do it and await another solution.

 Edit: Another solution is to reinstall the interrupted installation, in this case of
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
 
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27675
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: 4.0.1 Installation Hang up?

Postby cal_t » Tue Nov 25, 2014 1:56 pm

My installation on Windows had the same hang on c++ redis. install. Killing the task will result in unstable Windows.
You then can't uninstall, repair or reinstall C++ 2008.

I am going to try a System Restore. It's taking quite a while to do that. Will report back if it does restore.

Does anyone know if an official bug has been reported for this issue?
Open Office 4 on Windows 8.1
cal_t
 
Posts: 2
Joined: Tue Nov 25, 2014 1:53 pm

Re: 4.0.1 Installation Hang up?

Postby cal_t » Tue Nov 25, 2014 4:35 pm

System restore failed- had to reload windows
Open Office 4 on Windows 8.1
cal_t
 
Posts: 2
Joined: Tue Nov 25, 2014 1:53 pm

Re: 4.0.1 Installation Hang up?

Postby Bill » Tue Nov 25, 2014 4:59 pm

cal_t wrote:Does anyone know if an official bug has been reported for this issue?

I doubt that it's a bug in AOO. The Redistributable isn't an AOO product. It's a Microsoft product.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6946
Joined: Sat Nov 24, 2007 6:48 am

Re: 4.0.1 Installation Hang up?

Postby crazycat9 » Thu Dec 11, 2014 5:34 pm

Has anyone come up with a solution to this? I was able to install OpenOffice on my machine, but not the user's. The user gets the exact same message "Please wait while Windows configures Microsoft Visual C++ 2008" and it just hangs with it saying "Time remaining: 0 seconds." This is a show-stopper for us. We tried installing "Microsoft Visual C++ 2008 Redistributable" and THAT failed.

We are installing OpenOffice 4.1.1 on Windows 7.

Any help would be greatly appreciated. Thanks.

P.S. Tried this on another test device: We were able to successfully install "Microsoft Visual C++ 2008 Redistributable" but installing AOO 4.1.1 it still responds in the same manner i.e. hanging where it says "Time remaining: 0 seconds."
OpenOffice 4.1.1 on Windows 7
crazycat9
 
Posts: 1
Joined: Thu Dec 11, 2014 5:06 pm

Re: 4.0.1 Installation Hang up?

Postby anna182 » Tue May 12, 2015 5:51 pm

Yesterday, I had the same problem and wondered, if McAfee could be responsible for this. Today, I deinstalled McAfee and after that, I tried to install OpenOffice again, using the already unpacked setup.exe. Again, there was this error with the the Microsoft Visual C++ 2008..., I clicked No and after that, the Installation of OpenOffice worked.
I hope I could help anyone with this...
OpenOffice 4.1.1 on Windows 8.1
anna182
 
Posts: 1
Joined: Tue May 12, 2015 5:39 pm

Re: 4.0.1 Installation Hang up?

Postby jkd53 » Thu Apr 06, 2017 5:57 pm

I am getting the same message. Has anyone come up with a fix?
Open Office 3.1 Windows 8.
jkd53
 
Posts: 1
Joined: Thu Apr 06, 2017 5:42 pm

Re: 4.0.1 Installation Hang up?

Postby RusselB » Thu Apr 06, 2017 10:31 pm

Considering the last post before yours was nearly 2 years previous, if it is the same problem, then you need to get the Microsoft Visual C++ 2008 Redistributable Package (x86)
Also please note that the current version of OpenOffice is 4.1.3, so please ensure that you have the installation files for that version.

If the above does not work, can you upload a screenshot of the actual error message?
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4723
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 2 guests