[Solved] Typing in Cyrillic inside Writer

Issues with installing under all Linux Distributions

[Solved] Typing in Cyrillic inside Writer

Postby Vitriol_32 » Tue Apr 20, 2010 12:48 am

Thank you in advance for any assistance!

I am working in OpenOffice 3.1, on Ubuntu 9.10. I am looking to be able to type in Cyrillic inside a document, but want to leave all of the windows and menus in English. I may occasionally be switching back and forth inside the document from English to Russian, and I would like to know how to switch back and forth as well. I have indeed come across other threads mentioning keyboard arrangement switching, but am confused by the instructions. If anyone could help by providing the simplest explanation possible that would be very much appreciated. As I am relatively new to Linux as well I will not take offense to any instruction that may seem oversimplified. I do not see Cyrillic listed as a font option in the drop down menu.... should there be one? Would it be that simple?

Thanks again!
Last edited by Hagar Delest on Tue Apr 27, 2010 9:06 am, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 3.1 on Ubuntu 9.10 (Gnome)
Vitriol_32
 
Posts: 2
Joined: Tue Apr 20, 2010 12:38 am

Re: Typing in Cyrillic inside Writer

Postby Robert Tucker » Tue Apr 20, 2010 2:25 pm

The simplest way is to right-click in your Gnome desktop panel and select "Add to Panel". Select "Keyboard Indicator" and then click "Add". Right-click on the letters representing your current keyboard layout which have now appeared in your panel and select Keyboard Preferences>Layouts. Click on the "Add" button and select the keyboard you want, for example, select the "By Language" tab and then scroll down the "Language" drop-down list to Russian and then down the "Variants" drop-down list to Russia. Click the "Add" button. Then click the "Close" button on the Keyboard Preferences>Layouts GUI. You will find you can left-click the letter icon in your tray/panel to switch (or cycle) through your languages (you will find that a maximum of 4 is possible). If you re-open Keyboard Preferences>Layouts and click on "Layout Options..." and select "Key(s) to change layout" you can set keys to switch/cycle though your keyboard options.

Note that you can set a keyboard for each application you are using. So, for example, you can type in OpenOffice in Cyrillic and type in Firefox in English without changing anything.
OpenOffice 4.0.0 and LibreOffice 4.x.x on Fedora 20, Ubuntu 13.10, Windows 8.1 Preview (Triple Boot)
User avatar
Robert Tucker
Volunteer
 
Posts: 1230
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Re: Typing in Cyrillic inside Writer

Postby Vitriol_32 » Tue Apr 27, 2010 12:37 am

Awesome advice! While I was unable to right click on the desk top and proceed from the options you described you did give me a huge clue.... In Ubuntu I had to select System > Preferences > keyboard. Then, Layouts tab, then Add, then select the language.

Once added I found I could click on the bottom center portion of the Open Office window where it says English (USA) and change it to Russian. I can then type in Cyrillic font (assuming it was on here to begin with?) and then click back on English as needed. Awesome lead, thank you! :D
OpenOffice 3.1 on Ubuntu 9.10 (Gnome)
Vitriol_32
 
Posts: 2
Joined: Tue Apr 20, 2010 12:38 am

Re: Typing in Cyrillic inside Writer

Postby Robert Tucker » Tue Apr 27, 2010 11:18 am

Vitriol_32 wrote:... I was unable to right click on the desk top and proceed ...


Not the main desktop area but the panel at the bottom (or top or side) of your screen, the one with "Applications, Places, System on it.
OpenOffice 4.0.0 and LibreOffice 4.x.x on Fedora 20, Ubuntu 13.10, Windows 8.1 Preview (Triple Boot)
User avatar
Robert Tucker
Volunteer
 
Posts: 1230
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Re: Typing in Cyrillic inside Writer

Postby Robert Tucker » Tue Apr 27, 2010 11:22 am

Vitriol_32 wrote:Once added I found I could click on the bottom center portion of the Open Office window where it says English (USA) and change it to Russian.

This should only alter OpenOffice's recognition of the language you are using with regard to spellchecking etc. To change the input language you should be clicking the "Rus" or "USA" or whichever letters which have appeared in your panel as defined in my post just above.
OpenOffice 4.0.0 and LibreOffice 4.x.x on Fedora 20, Ubuntu 13.10, Windows 8.1 Preview (Triple Boot)
User avatar
Robert Tucker
Volunteer
 
Posts: 1230
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests