[Solved] Is Java necessary for OpenOffice?

Issues with installing under all versions of MS Windows

[Solved] Is Java necessary for OpenOffice?

Postby jdworl » Thu Apr 15, 2021 2:40 am

I downloaded your newest version of open office. It makes a point that open office needs java to operate well. My browser is firefox which no longer supports java.
When i run office it seems to work fine to me.
Is java necessary and if not why include the statement that java is necessary?

 Edit: Please don't write in all caps - it is considered as shouting [robleyd, mod] 
Last edited by Hagar Delest on Thu Apr 15, 2021 9:08 pm, edited 1 time in total.
Reason: tagged solved.
Open Office 4.1 on Windows 10(Home)
jdworl
 
Posts: 2
Joined: Thu Apr 15, 2021 2:31 am

Re: JAVA

Postby robleyd » Thu Apr 15, 2021 3:10 am

See Troubleshooting Open/LibreOffice and Java for information on what Java is used for in AOO and what to install if you need Java.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3863
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Is Java necessary for OpenOffice?

Postby Bill » Thu Apr 15, 2021 9:22 am

jdworl wrote:It makes a point that open office needs java to operate well.

I don't recall the words "operate well" in any message. The Readme included in the program files says "OpenOffice requires a recent version of JAVA for full functionality." That means that some functions will not work at all If the JRE is not installed. If you try to use such a function, you will see a "JRE Required" message which says "OpenOffice requires a Java runtime environment (JRE) to perform this task". If you never see this message, then you don't need JAVA.
AOO 4.1.10 on Ubuntu MATE 20.04
Bill
Volunteer
 
Posts: 8194
Joined: Sat Nov 24, 2007 6:48 am

Re: Is Java necessary for OpenOffice?

Postby Zizi64 » Thu Apr 15, 2021 10:18 am

The AOO is a 32 bit software. It requires 32 bit JRE even if it installed/run on a 64 bit operating system.

Try the LibreOffice. It has 32 and 64 bhit version too, and the Java dependency of the LO was decreased by the developers, when the licence of the Java has been changed. I am using the LO without JRE.
Tibor Kovacs, Hungary; LO6.1.6, 6.4.7 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-7.1.1;AOO4.1.9
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9810
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Is Java necessary for OpenOffice?

Postby jdworl » Thu Apr 15, 2021 7:23 pm

Very helpful. Thank you.
Open Office 4.1 on Windows 10(Home)
jdworl
 
Posts: 2
Joined: Thu Apr 15, 2021 2:31 am


Return to MS Windows

Who is online

Users browsing this forum: No registered users and 7 guests