Error Access2Base DLookup with Firebird

Discussions about using 3rd party extension with

Error Access2Base DLookup with Firebird

Postby inizul » Fri Sep 07, 2018 12:59 pm

I have migrated an embedded database from HSQLDB to Firebird.
In this database I used the DLookup function of Access2Base and with HSQLDB it worked correctly.
Now with Firebird I get an SQL error when I use the (Access2Base) DLookup function:
Code: Select all   Expand viewCollapse view
Sub IPF_ActualizarDenominacionComponente ()
  Dim sCodigo as string
  Dim sDenominacion as string
  sDenominacion=Application.DLookup("[Denominacion]", "[piezas]","[Codigo]='" & scodigo & "'")
  '  [Application.]DLookup(expression, domain[, criteria][, orderclause]))
  setValue("Forms!InformePreserieFicha!Componente.Value", sDenominacion)
End Sub


LibreOffice Version: (x64)
Firebird embedded
Windows 10
ErrorDlookup.png (7.17 KiB) Viewed 987 times
LibOffice on Windows 7
Posts: 8
Joined: Sat Aug 20, 2016 5:46 pm

Re: Error Access2Base DLookup with Firebird

Postby Villeroy » Fri Sep 07, 2018 1:14 pm

Embedded Firebird is a mistake. Use anything else as a better database backend. Above all, you should not use embedded databases.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Posts: 26866
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Error Access2Base DLookup with Firebird

Postby JPL » Thu Sep 20, 2018 7:06 pm


Access2Base is not yet ready to fully support Firebird 3.0.

However the issue that you mentioned was corrected in july. The correction will be included in LO 6.2: see patch ... f44126b2a0

Sorry for the (temporary) inconvenience.

Windows 7 / LibO 6.0 / AOO 4.1
Ubuntu 18.04 / LibO 6.1
Access2Base extension (AOO) or standard (LibO).
BaseDocumenter extension (LibO)
Documentation on and
Posts: 103
Joined: Fri Mar 30, 2012 3:14 pm

Return to Extensions

Who is online

Users browsing this forum: No registered users and 2 guests