Page 1 of 1

[Issue] Extension Update Issue

PostPosted: Fri Apr 06, 2018 9:14 pm
by DOBRESCUMihai19
Dear Members of the "OpenOffice" Community Forum,

I am able to update the whole "OpenOffice" Software Application. The Update Process exits with the "OpenOffice 4.1.5 is up to date." Success String.

However, whenever I am attempting to update the Extensions, the "Extension Manager" Software Application bails out with the following Error String:

"OpenOffice 4.1.5: Error reading data from the internet. Server error message: ."

So far, I have only tried only to apply that famous workaround that restarts the whole User Profile. I am not very happy to apply that workaround over and over again, as every time I restart my User Profile, the Dictionaries are also reset and I have to reinsert all of my peculiar words all over again. Anyway, this workaround does not solve this Issue.

Please advise.

Best Regards,

Re: Extension Update Issue

PostPosted: Fri Apr 06, 2018 10:03 pm
by RusselB
The error message you report states (in slightly different terms) that the problem is with the internet connection to the server that is hosting the extension.
The user profile is stored locally on your computer, and has nothing to do with the connection to the server.
For future reference, regarding the dictionaries in your user profile, if you do a rename, rather than a deletion, of the user profile, you can copy the dictionaries from the renamed user profile into the new user profile.
As long as the problem that caused the user profile to become corrupted isn't related to one (or more) of the dictionaries, then this will save you from having to re-add words manually.

Regretfully we have no control over the internet or the connection/response from the host server. We are end users that share our experiences and knowledge with others that are having difficulties.

Re: Extension Update Issue

PostPosted: Sat Apr 07, 2018 9:51 am
by robleyd
@RusselB: in your environment, what result do you get if you go to Tools | Extension Manager and click Check for Updates - assuming you have extension(s) ?

Re: Extension Update Issue

PostPosted: Sat Apr 07, 2018 10:00 am
by RoryOF
I was able (about 12 hours ago, after reading your post) to verify updates without problem and download one that needed updating. I think you should look up how to ping and traceroute to the extension site ad check tht your connection is being maintained - if one of the sites on the route times out, that may drop your connection and give the error message.

Re: Extension Update Issue

PostPosted: Sat Apr 07, 2018 10:53 am
by DOBRESCUMihai19
Dear Members of the "Apache" "OpenOffice" Community Forums,

Thank you for your fine pieces of quick and profound support.

Somehow, I am getting the impression that these kinds of issues are more and more influenced by a particular Build of a particular Operating System in conjunction with particular Third-Party Software Applications.

I do not think that there is anything wrong with the "Apache" Software Applications. These kinds of weird errors might appear from the following triad:

1. The "Microsoft" "Windows" 10 "Fall Creators' Update" Version 1709 Operating System Build 16299.309.
2. The "Symantec" "Norton Security Online" Software Application.
3. The "Symantec" "Norton Utilities" Software Application.

Unfortunately, as things are getting weirder and weirder, I shall probably purchase soon a subscription for the "Microsoft" "Office" Software Application and let them knock themselves out. :ouch:

You can have great fun witnessing how it is to chase these kinds of weird errors at the following links:



Best Regards,

Re: Extension Update Issue

PostPosted: Sun Apr 08, 2018 3:55 am
by RusselB
@robleyd: Sorry for the delay in responding. I just checked my system, and I got a message saying "Unknown Error"
The only extension that I have is the English - US dictionary.

Re: Extension Update Issue

PostPosted: Sun Apr 08, 2018 9:31 am
by robleyd
Hmm. I have a number of extensions and get varying results when I select individual extensions and choose to update individually:

    Alternative searching 1.4.2 - successfully checks and finds no update
    English dictionary - same error as OP
    MRI tool - same error as OP
    PDF import extension - different error, see first image below (I think it is now hosted in a different site)
    Test of missing fonts - successfully checks and finds no update
    Timestamped backup - same error as OP

The error message seen by OP and me isn't very helpful. I had a dig around in the source for MRI and found description.xml which contains

Code: Select all   Expand viewCollapse view
<src xlink:href=""/>

and following that link I get
Code: Select all   Expand viewCollapse view
<?xml version="1.0" encoding="UTF-8"?>
<description xmlns=""
<identifier value="mytools.mri" />
<version value="1.3.3" />
< value="3.4" d:name=" 3.4" />
<src xlink:href=""/>

which gives me a link to a valid download URL. So there is a logical trail to the download, but something, somewhere in the update process is returning an error message consisting of a period.


[SOLVED] Re: Extension Update Issue

PostPosted: Sun Apr 08, 2018 10:29 am
by DOBRESCUMihai19
Dear Members of the "OpenOffice" Community Forum,

Millions of thanks for troubleshooting this Issue.

I would like to jot down the following pieces of information:

1. During the recent years, I have used the "Apache" "OpenOffice" Software Application only under the "Microsoft" "Windows" Operating System. I understand that this Issue is also manifesting under "*N.I.X." Operating Systems.

2. I am currently running the "Microsoft" "Windows" 10 "Fall Creators' Update" Version 1709 Operating System Build 16299.309. Prior to this Current Version, the "Apache" "OpenOffice" Software Application has been manifesting perfectly.

3. The whole "Apache" "OpenOffice" Software Application does update itself eventually, but sometimes it reports some errors. However, it is able to recover from those errors and to check its 4.1.5 Version.

4. The "Extension Manager" Software Application used to work perfectly during the latest few years. Since it is now behaving strangely also under the "*N.I.X." Operating Systems, I understand that it is less probable that the "Symantec" "Norton Security Online" Software Application and the "Symantec" "Norton Utilities" Software Application are affecting it. Also, other Firewall Settings and General Network Settings that might be causing Issues in my own weird setup might not be found also in other setups.

For the moment, I am very happy to understand that there is still hope with the "Microsoft" "Windows" Operating System. It could not be the one that is causing this Issue.

Best Regards,

UPDATE: Wednesday, 18-April-2018, 21:42 E.E.S.T.

Dear Members of the "OpenOffice" Community Forum,

I am happy to report another weird improvement regarding this Issue. It is actually getting worse, as now the whole "Apache" "OpenOffice" Software Application does not want to update itself anymore, bailing out with the "Error reading data from the Internet. Server error message: ." Error Message.

Before attempting to trace the Internet Traffic that goes towards the Extensions Web-Sites, I have attempted to see whether the "Norton Security Online" "Smart Firewall" does not block the "Extension Manager" Software Application. I see that it allows the whole "Apache" "OpenOffice" Software Application to go through it.

"Norton Security Online" "Smart Firewall" Settings
2018-04-18_21-16-33_-_Norton_Security_Online_-_Smart_Firewall_-_Settings.PNG (3.02 KiB) Viewed 4589 times

Now, I would like to boldly go and create a "Smart Firewall" Rule that allows the "Extension Manager" Software Application to go through. For that, I have to see which Executable Binary Image it uses. Unfortunately, I can not see that running.

The Process Images
2018-04-18_21-30-55_-_Process_Explorer_-_Sysinternals_www.sysinternals.com_[KUBERA_DOBRE].PNG (5.19 KiB) Viewed 4589 times

Maybe the "Extension Manager" Software Application is just a part of the whole "Apache" "OpenOffice" Software Application and therefore I shall not see a separate Executable Binary Image for it. Am I right?

Best Regards,

UPDATE: Monday, 30-April-2018, 15:24 E.E.S.T.

Dear Members of the "OpenOffice" Community Forum,

I am happy to report that this Issue has finally been solved somehow.

I have noticed that during the recent years things have been going weirder and weirder in the Computer Science world. Funny Issues have been surfacing and they never got solved.

I have had a Very Strange Experience while attempting to use the "Microsoft" "OneDrive" Cloud Provider Service. Nothing has been working out. The Forum where the Users have been depicting their "Area 51" Experiences has eventually been frozen and it will subsequently be archived. A Complete Failure. The Solution at that time has been to subscribe to a Paid One-TeraByte-Subscription to the "MEGA" Cloud Provider Service. It happens. Sometimes.

A similar Strange Experience I have recently had with the "Facebook" Social Network. An Issue that has been reported Four Years ago, during the Year of 2,014, is still resurfacing and it is still annoying its Proud Users by printing its Ugly HeadLine that states that it "Can not connect. Tap to retry.". No WorkAround known by the Human Race has been able to prevent this Issue from manifesting. The Solution has been to simply ignore the "Facebook" Social Network. It is simply evil.

In the case of this Issue, the Solution has been to subscribe to a Paid Subscription to the "Microsoft" "Office" Desktop-Software-Suite-as-a-Service. It is working out alright. Of course, it looks a little bit different than the Version that I was used to, for instance, Twenty Years ago, during the Year of 1,998, when it was running on the "Microsoft" "Windows" "98" Operating System. But - hey! - Twenty Years have passed since then. Let us simply be thankful that the thing is still working. Somehow.

Anyway, I would like to thank everybody for watching this Thread. I have learned a lot while attempting to fix this Issue. I wish everyone at the "Apache" "Software Foundation" "Good Luck!".

Best Regards,

Re: [Solved] Extension Update Issue

PostPosted: Mon Jul 16, 2018 7:16 am
by robleyd
For information, this issue has been reported as a bug

Re: [Issue] Extension Update Issue

PostPosted: Tue Jul 17, 2018 3:33 pm
by DOBRESCUMihai19
Dear Members of the "OpenOffice" Community Forum,

At the end of the day, it all comes to a matter of choice.

Somehow, I have had the Fated Idea to buy the "Microsoft" "Windows" 8.1 Operating System almost Four Years Ago. It has turned out to be a Very Bad Choice, as, even after its Upgrade to the Latest Version of the "Microsoft" "Windows" 10 Operating System, nothing has been working out smoother as it used to work and as it should be working.

I wonder why I have not decided to choose a "Linux" Distribution instead.

The things have been getting worse as the "Microsoft" Corporation has decided to introduce the Stealth Idea of maintaining a "Microsoft" Account where most of the Personal Data is stored. This way, even after Physically Deleting all of the Primary Partitions that were residing on the Internal Winchester Hard Disk Drive, the Next Clean Install has somehow retrieved some of the Settings that should have been lost otherwise.

Nobody really knows exactly what is kept out there, "in the cloud", but - for instance - most of the Desktop Layout has been set up exactly as it was before the Clean Install, without having to manually intervene for its Diligent Setup. For instance, the Green Color of the Desktop Background has been set again without requiring any further action from the Proud User. So, I presume that everything is safely kept somewhere without my knowledge.

As I have noted before, at the Uniform Resource Locator I have described a Failed Saga of updating the "Microsoft" "Windows" 10 Operating System. I have eventually decided to disable the "Microsoft" "Windows" Update System, which is not an easy thing to do. I have even noticed a "tracker" Command-Line Software Application that must have been changing some things around beyond my control.

Choosing to opt into a Paid Subscription to the "Microsoft" "Office" Desktop Suite and its "Microsoft" "OneDrive" Cloud Providing Service has been Quite a Bad Idea as well.

Attempting to synchronize only around 372 Giga-Bytes of Useful Data (I mean, come on, they are not 16 Tera-Bytes of Data) on the "Microsoft" "OneDrive" Cloud Providing Service has been a Never-Ending Task. I have jotted down a little bit of what was happening there at the Uniform Resource Locator. I have eventually given up on using the "Microsoft" "OneDrive" Cloud Providing Service.

Using the "Microsoft" "Office" Desktop Suite has been an Even Worse Experience. The built-in "Microsoft" "Windows" "Mail" Desktop Software Application is taking ages to load and sometimes it is disappearing without any explanation. The "Microsoft" "Office" "OutLook" Desktop Software Application is also taking ages to load and it is constantly changing its Graphical User Interface. The moment when a User is proudly getting used to a Certain Sequence of Buttons, then they are rapidly changing it, so that nothing is really clear at any given point in time.

The Notion of Updating is also getting to an Extreme these days. Instead of having a simple "Send and Receive" Button as they used to have, now there are a few "Update" Buttons for each and every possible thing out there.

Generally, I have noticed that most of the Software Applications, both Static and Mobile, are tending to have for Every Little Tiny Thing an "Update" System, a "Backup" System and a "Cloud" Providing Service, as these are the Trendy Words these days. They are getting to an Extreme without being based on any Solid Reason.

The "Microsoft" "Office" "Word" Desktop Software Application has been behaving quite nicely. I have been quite satisfied with it. There have been no crashes. Nothing appears to be evil around there. Or at least not in an Obvious Way.

Instead of going through these Weird Experiences, I would recommend to a Simple and Plain User to choose from the start a "Linux" Distribution. I think that they must be including some of the "OpenOffice" or "LibreOffice" Desktop Suites even in some Standard Distributions.

I have installed again a Full Software Installation of the "CygWin" Environment, which X-Server unfortunately does not work well on only 4 Giga-Bytes of Random Access Memory. It is still providing a lot of useful Command-Line Software Applications. Its Full Software Installation Kit is taking around 19 Giga-Bytes of Data, while its Full Software Installation is taking around 93 Giga-Bytes of Data. But it is still not the Real Thing.

I still cannot conceive a Sound Reason to choose the "Microsoft" "Windows" Operating System over a "Linux" Distribution.

Best Regards,
"United_D.M.! - Software for the Future".

Re: [Issue] Extension Update Issue

PostPosted: Thu Jul 19, 2018 2:20 am
by robleyd
Locked - please continue in [Issue] Check for Updates feature fails