[Solved] Access2Base bug in DoCmd.SendObject?

Discussions about using 3rd party extension with OpenOffice.org

[Solved] Access2Base bug in DoCmd.SendObject?

Postby inizul » Sat Aug 20, 2016 6:53 pm

It seems that the function does not recognize the parameter 'MessageText'

Code: Select all   Expand viewCollapse view
Sub IRP_EnviarPDF
  Const acSendForm = 2
  Const acFormatPDF = "writer_pdf_Export"
  Dim sPara as string
  Dim sCc as String
  Dim sBcc as String
  Dim sMensaje as string
  Dim sAsunto as string
  'msgbox "Se enviará el informe por correo"
  sPara="nadie@gmail.com"
  sCc="nada@gmail.com"
  sBcc="tampoco@gmail.com"
  sAsunto= "Empresa: Informe de rechazo a proveedor"
  sMensaje= "Estimado proveedor." & chr(13) & "En su envío hemos encontrado un problema que nos obliga a rechazar el material"

  DoCmd.SendObject(acSendForm,"InformeRechazoProveedor",acFormatPDF,sPara,sCc,sBcc,sAsunto,sMensaje,True)
'DoCmd.SendObject (ObjectType,         ObjectName,        OutputFormat, To, Cc,  Bcc,Subject,MessageText,EditMessage, TemplateFile)
End sub


This code work well: It open Thunderbird correctly but the MessageText is missing (see atached image: email.png)
Attachments
email.png
Last edited by inizul on Mon Aug 22, 2016 5:45 pm, edited 1 time in total.
LibOffice 5.1.4.2 on Windows 7
inizul
 
Posts: 8
Joined: Sat Aug 20, 2016 5:46 pm

Re: Access2Base bug in DoCmd.SendObject?

Postby JPL » Mon Aug 22, 2016 1:03 pm

Hi Inizul,

it is not a bug in Access2Base but a limitation of LibreOffice.

Have a look at the remarks in http://www.access2base.com/access2base.html#SendObject.
The by LO proposed interfaces do not provide the simultaneous sending of a body and an attachment ... :(

I can nevertheless understand your frustration.

Have a nice day.
JPL
Windows 7 / LibO 6.0 / AOO 4.1
Ubuntu 18.04 / LibO 6.1
Access2Base extension (AOO) or standard (LibO).
BaseDocumenter extension (LibO)
Documentation on http://www.access2base.com and http://www.access2base.com/basedocumenter
JPL
Volunteer
 
Posts: 98
Joined: Fri Mar 30, 2012 3:14 pm

Re: Access2Base bug in DoCmd.SendObject?

Postby inizul » Mon Aug 22, 2016 5:44 pm

Ups!!

Sorry for not correctly read the documentation :oops:

Thanks for the clarification.
LibOffice 5.1.4.2 on Windows 7
inizul
 
Posts: 8
Joined: Sat Aug 20, 2016 5:46 pm


Return to Extensions

Who is online

Users browsing this forum: No registered users and 1 guest