Page 1 of 1

PDF Importer requires OO reference version 4

PostPosted: Wed Jun 10, 2015 3:56 pm
by jhogarth
I'm trying to install the OO PDF Import utility and get this error from the Extension Manager:

Extension requires at least OpenOffice.org reference version 4.0

I'm running OO 4.1.1 on CentOS 7, 64-bit.

The extension was downloaded from here: http://extensions.openoffice.org/en/pro ... openoffice

Is the extension not ready for 4.1?

Thanks

Re: PDF Importer requires OO reference version 4

PostPosted: Wed Jun 10, 2015 4:49 pm
by RoryOF

Re: PDF Importer requires OO reference version 4

PostPosted: Wed Jun 10, 2015 6:58 pm
by jhogarth
I get the same error message with this version.

Thanks

Re: PDF Importer requires OO reference version 4

PostPosted: Thu Jun 11, 2015 5:13 am
by RusselB
If you look and read the information given, it is stated that the extension is compatible with 4.0
User voting regarding compatibility with other 4.x versions is almost 2:1 indicating it is not compatible.
Additionally, since the last post was almost 2 years ago, I wouldn't hold my breath that a 4.1+ compatible version will be coming out.

Re: PDF Importer requires OO reference version 4

PostPosted: Thu Jun 11, 2015 9:01 am
by B Marcelly
Reading AOO 4.1 Release Notes, section Known Issues I notice this:
For the MacOSX version only, any extensions that are written in C++ will no longer work and be marked as disabled in the AOO extensions manager. This is because of the change of AOO from a 32-bit to a 64-bit application on MacOSX. Please report the problem to the developer of the extension.

Since you are using CentOS 7, 64-bit, this may be an explanation.

Re: PDF Importer requires OO reference version 4

PostPosted: Thu Jun 11, 2015 9:20 am
by Zizi64
Or you can try the LibreOffice. It have PDF import feature as a built-in function.

Re: PDF Importer requires OO reference version 4

PostPosted: Sun Jun 21, 2015 9:17 am
by DamVan
i get the same question! thanks you! :D

Re: PDF Importer requires OO reference version 4

PostPosted: Sun Jun 21, 2015 7:05 pm
by Zizi64
DamVan:
OpenOffice 2.4 on Ubuntu 9.04


Do you use the OpenOffice.org 2.4, really???? It is a very, very old version.
Please upgrade your software and/or update your signature in this Forum.

Re: PDF Importer requires OO reference version 4

PostPosted: Sun Jun 21, 2015 7:17 pm
by RoryOF
DamVan wrote:i get the same question! thanks you! :D


Ubuntu 9.04 is an extremely old version and long out of support. The OO PDFImporter certainly works on OO 4.1.1 on Xubuntu 14.10 and 15.04; I am certain that it (or the earlier version) worked correctly on older versions of Xubuntu, but I cannot recollect with certainty just which version of PDFImporter worked on which earlier version of Xubuntu.

PDFImporter is not designed to permit editing to the level of reconstruction/re-layout of a PDF file using OpenOffice; it is capable of minor changes. Major changes to the structure of a PDF file require a specialised editor.

Re: PDF Importer requires OO reference version 4

PostPosted: Thu Sep 17, 2015 10:38 pm
by sergey113
2015-09-17 - ubuntu 14.04 - openoffice 4.1.1 - PDF Import for Apache OpenOffice
install and works