[Solved] Writer2Latex install fails

Discussions about using 3rd party extension with OpenOffice.org

[Solved] Writer2Latex install fails

Postby lostbits » Sat Jan 24, 2015 7:21 pm

There are some issues, I don't know if they are related (and I don't know if this is the correct forum to present them):
1: When clicking on update I get: "http://ooop.sourceforge.net/update/extensions.xml does not exist."
2: Writer2Latex fails to update with a "Could not create Java implementation loader" message.
3: File > Wizard > Letter doesn't work with the message "OpenOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice - Java.".

http://ooop.sourceforge.net/update/ becomes http://sourceforge.net/projects/ooop/. Extensions.xml apparently does not exist.

Java seems to be installed correctly: Tools > Options > OpenOffice > Java "Java runtime environments (JRE) already installed:" with jre1.8.0_25.

Other extensions seem to install just fine. Any idea how to fix the fool thing? (I've deleted all earlier jre's).
art
Last edited by lostbits on Sun Aug 02, 2015 6:02 pm, edited 1 time in total.
Win 7 64-bit
Open Office 4.1.1
AOO411m6(Build:9775) - Rev. 1617669
2014-08-13 09:06:54 (Mi, 13 Aug 2014
lostbits
 
Posts: 74
Joined: Thu May 29, 2014 7:06 pm

Re: Writer2Latex install fails

Postby lostbits » Sat Jan 24, 2015 7:57 pm

win7 x64


I've just installed the latest version of the Java JRE, jre1.8.0_31 (x64). I have verified that it is installed (Control Panel > uninstall shows that it is installed). And then (and then you might ask) Tools > Options > Java shows that a JRE is installed - but doesn't show what it is - and File > Wizard > Letters fails.

What version of the Java JRE is required?

art
Win 7 64-bit
Open Office 4.1.1
AOO411m6(Build:9775) - Rev. 1617669
2014-08-13 09:06:54 (Mi, 13 Aug 2014
lostbits
 
Posts: 74
Joined: Thu May 29, 2014 7:06 pm

Re: Writer2Latex install fails

Postby RoryOF » Sat Jan 24, 2015 8:01 pm

For all Windows versions of OpenOffice, one needs 32 bit Java installed and select in OpenOffice under /Tools /Options /OpenOffice : Java
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28785
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Writer2Latex install fails

Postby lostbits » Sun Jan 25, 2015 2:11 am

Thanks. Too bad tho'. I have a 64-bit OS et alia.

art
Win 7 64-bit
Open Office 4.1.1
AOO411m6(Build:9775) - Rev. 1617669
2014-08-13 09:06:54 (Mi, 13 Aug 2014
lostbits
 
Posts: 74
Joined: Thu May 29, 2014 7:06 pm

Re: Writer2Latex install fails

Postby RoryOF » Sun Jan 25, 2015 7:50 am

You can install 32and 64 bit java side by side. OpenOffice must be specifically told to use the 32 bit version.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28785
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Extensions

Who is online

Users browsing this forum: No registered users and 1 guest