[Base] Access2Base - Last version: 6.3

Discussions about using 3rd party extension with OpenOffice.org

Re: [Base] Access2Base - Last version: 6.3

Postby JPL » Wed Nov 20, 2019 10:47 am

@gelinp

I never experienced myself the need of coordinating the events in a form or in controls with semaphors or similar.

If your own experience is different, you should file a bug in https://bugs.documentfoundation.org/ with a good example of misbehaviour of the events queues.

Regards.
JPL
Windows 7 / LibO 6.0 / AOO 4.1
Ubuntu 18.04 / LibO 6.1
Access2Base extension (AOO) or standard (LibO).
BaseDocumenter extension (LibO)
Documentation on http://www.access2base.com and http://www.access2base.com/basedocumenter
JPL
Volunteer
 
Posts: 105
Joined: Fri Mar 30, 2012 3:14 pm

Re: [Base] Access2Base - Last version: 6.3

Postby Villeroy » Wed Nov 20, 2019 11:12 pm

My mouse events are triggered twice with LibreOffice 6.3 but not with LibreOffice 6.2.
My routine starts like this:
Code: Select all   Expand viewCollapse view
Sub onMouseRelease(e)
If e.Buttons = 1 and e.ClickCount = 2 and e.Modifiers = 0 and e.PopupTrigger = False then
msgbox "Yep"

This is called twice with every double-click on a table control. The actual code in place of the msgbox inserts a value from the table control into another table so the table control behaves like a multi-column list box.

Now I try this:
Code: Select all   Expand viewCollapse view
Sub onMouseRelease(e)
Static X As Integer
If X=0 and e.Buttons = 1 and e.ClickCount = 2 and e.Modifiers = 0 and e.PopupTrigger = False then
X=X+1
msgbox X

The msgbox is called only once but if the actual code performs a record insertion, the X variable is reset and 2 records are inserted instead of one.
Then I tried the same trick with a global X which raised very irritating errors about form objects that could not be found anymore. I changed nothing else, just replaced the static X with a global integer X.
I downgraded my database clients to LO 6.2. When I find some hour or two I'll set up a simple test case with embedded HSQL for a detailed bug report.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27373
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Base] Access2Base - Last version: 6.3

Postby Villeroy » Sat Nov 23, 2019 11:20 pm

Possibly I'm off topic here but the bug is real: https://bugs.documentfoundation.org/sho ... ?id=128988
Please move to the Base forum.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27373
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Previous

Return to Extensions

Who is online

Users browsing this forum: No registered users and 1 guest