Fatal Error when starting OpenOffice 4.1.7 from Java

Java, C++, C#, Delphi, ??? - Using the UNO bridges

Fatal Error when starting OpenOffice 4.1.7 from Java

Postby heiko33 » Fri Sep 27, 2019 3:47 pm

Hi,

When I try to start OpenOffice 4.1.7 from Java with folowing source code:

Code: Select all   Expand viewCollapse view
String oooExeFolder = "C:\\Program Files (x86)\\OpenOffice 4\\program\\";
XComponentContext xContext = BootstrapSocketConnector.bootstrap(oooExeFolder);


then I receive following error:
"Fatal Error" "Application cannot be started. Internal error occurs".
in line with bootstrap(...)

I tried the same with OpenOffice 4.1.6 and received the same error.

I linked the correct jars from OO 4.1.7 (juh, unoil, java_uno, jurt, ridl, unoloader) into my project.
I tried different versions of bootstrap.jar (didn't help).
I've uninstalled old LibreOffice version but it didn't helped.

I'm using eclipse 2019-03 as IDE and I'm working under Windows 10.
Normal start of OO from Windows works fine.

I have used this code since many years and it worked with older versions of OO and it is working also with LibreOffice. But it is not working with OO 4.1.7 and 4.1.6

Can anybody help?

Greetings
Heiko
OpenOffice 4.1.7, Windows 10
heiko33
 
Posts: 1
Joined: Fri Sep 27, 2019 3:00 pm

Return to External Programs

Who is online

Users browsing this forum: No registered users and 2 guests