Date loaded from table into header is 1 day short

Getting your data onto paper - or the web - Discussing the reports features of Base

Date loaded from table into header is 1 day short

Postby rwzelnick » Wed Oct 19, 2011 6:05 pm

I have a query that picks up a date from a field in a table, and a report that displays the date in the report Header. When I run the report, the date shows correctly when the report first appears in Writer, then a couple seconds later the date sets back one day. Another field that has TODAY() as the variable was doing the same thing until I changed it to int(TODAY()); now it stays at the proper date. But I couldn't use the INT( ) function with a field out of a table. This setback does not occur if I put the same field in the Detail section of the report; the date stays correct. What is wrong with the header date field?
Open Office 3.0 on Win XP Pro
rwzelnick
 
Posts: 2
Joined: Wed Oct 19, 2011 5:18 pm

Re: Date loaded from table into header is 1 day short

Postby rwzelnick » Wed Oct 19, 2011 6:44 pm

further note - I had a page counter displayed in the page footer, "Page # of #". When I don't have the "of #", that is the PAGECOUNT() function involved, the date in the header does NOT change. Any explanation, or is this a bug?
Open Office 3.0 on Win XP Pro
rwzelnick
 
Posts: 2
Joined: Wed Oct 19, 2011 5:18 pm

Re: Date loaded from table into header is 1 day short

Postby r4zoli » Wed Oct 19, 2011 7:25 pm

What version of OOo you uses?
I assume that you use SRB/ORB, which version? The similar error happened in earlier version of SRB, which was fixed.
Use OOo 3.3 with ORB 1.2.1-rev2.
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary


Return to Reporting

Who is online

Users browsing this forum: No registered users and 1 guest