Base can't display utf8 text from from postgresql

dBase, Calc, CSV, MS ACCESS, MySQL, PostgrSQL, OTHER

Base can't display utf8 text from from postgresql

Postby intmail » Mon Jun 29, 2015 1:22 pm

Hello,

I use linux system as desktop and another one for server which runs postgresql 9.3
When connecting with openoffice 4.1.1 Base, select syntax returns text separated by a strange square character.
It seems to be a decoding problem. My data are encoded with utf8 and all works fine with pgadminIII (sql editor provided by postgres)
I have already set the properties of OpenOffice Base to support UTF8 and the driver is the one which support wide character.

One things strange is that "tables" panel do not show the list of the tables. The panel is just blank.

Please tell me how to get the right text without squarre characters

Thank you
Last edited by intmail on Mon Jun 29, 2015 1:48 pm, edited 2 times in total.
OpenOffice 4.1.1 Slackware 14.1
intmail
 
Posts: 8
Joined: Wed Jun 10, 2015 11:01 am

Re: Base can't display utf8 text from from postgresql

Postby Villeroy » Mon Jun 29, 2015 1:30 pm

May be Windows line feeds with char(13) :?:
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24668
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Base can't display utf8 text from from postgresql

Postby intmail » Mon Jun 29, 2015 1:37 pm

It is not a line feed because data is just a plain text. All caracter are separated with the square symbol like this: w.o.r.d.s
OpenOffice 4.1.1 Slackware 14.1
intmail
 
Posts: 8
Joined: Wed Jun 10, 2015 11:01 am

Re: Base can't display utf8 text from from postgresql

Postby acknak » Mon Jun 29, 2015 1:49 pm

intmail wrote:... All caracter are separated with the square symbol like this: w.o.r.d.s

That looks like UTF-16, not UTF-8. The squares are zero bytes.

If you have a choice when you import into OO, set the encoding to "Unicode" or UTF-16.

If you don't see a place to choose the encoding, tell us what steps you're following to import the text.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22694
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Base can't display utf8 text from from postgresql

Postby intmail » Mon Jun 29, 2015 4:08 pm

The problem is not from importing data because I switch entirely my desktop computer to ms windows then open office base display text correctly without square.
This mean that server and its data are ok.
something goes wrong with oo for linux, odbc driver for linux, configuration of the driver, ...
OpenOffice 4.1.1 Slackware 14.1
intmail
 
Posts: 8
Joined: Wed Jun 10, 2015 11:01 am


Return to External Data Sources

Who is online

Users browsing this forum: No registered users and 3 guests