Page 1 of 1

[Solved] Installed Java 1.8.0_45, cannot connect to MySql

PostPosted: Sun May 17, 2015 2:44 am
by doncell6
Running Libreoffice version 4.0.4.2 on Windows 7 Pro

Installed newest version of Java (version 1.8.0_45)

The problem: I have a existing BASE file which connects to MySql. I am using the native MySql connector version 1.02 Mysql connector.

When I opened a BASE file, the message “LibreOffice requires a Java runtime environment...” message appeared.

What I did: So I click on Tools > Options > Libreoffice > Advanced and made sure the “use Java environment" was checked and the circle next to “Oracle Corp 1.8.0_45” was filled (not empty).

The question: I opened an existing BASE file. Usually I click on Edit > Database and see 3 options “Properties, Connection type and Advanced settings” The only available setting was “advanced options” (the rest were greyed out).

What is the solution to this? I must connect to MySql .

Re: Installed Java 1.8.0_45 , cannot connect to MySql

PostPosted: Sun May 17, 2015 6:24 am
by RoryOF
Is the Java you installed of the correct number of bits LibO expects?

Re: Installed Java 1.8.0_45 , cannot connect to MySql

PostPosted: Sun May 17, 2015 6:55 pm
by Villeroy
The extension driver is not written in Java.
Deactivate Java under Tools>Options>Advanced... and restart the office.
File>New>Database...
Connect to existing database
Type: MySQL
Connect directly (not ODBC, not JDBC).

Re: Installed Java 1.8.0_45 , cannot connect to MySql

PostPosted: Sun May 17, 2015 8:28 pm
by Villeroy
If your existing Base document is connected to MySQL via JDBC, this connection has nothing to do with the extension driver. It might be possible to change the driver via menu:Edit>Database>Connection... from JDBC to native MySQL. This should remove any dependencies on Java except for any reports that had been created using the report builder extension.

Re: Installed Java 1.8.0_45 , cannot connect to MySql

PostPosted: Tue May 19, 2015 3:39 am
by doncell6
Villeroy wrote:The extension driver is not written in Java.
Deactivate Java under Tools>Options>Advanced... and restart the office.
File>New>Database...
Connect to existing database
Type: MySQL
Connect directly (not ODBC, bot JDBC).



Thank you, Villeroy. Appreciate your help. Your suggestion works.