[Solved] Installed Java 1.8.0_45, cannot connect to MySql

dBase, Calc, CSV, MS ACCESS, MySQL, PostgrSQL, OTHER

[Solved] Installed Java 1.8.0_45, cannot connect to MySql

Postby doncell6 » Sun May 17, 2015 2:44 am

Running Libreoffice version 4.0.4.2 on Windows 7 Pro

Installed newest version of Java (version 1.8.0_45)

The problem: I have a existing BASE file which connects to MySql. I am using the native MySql connector version 1.02 Mysql connector.

When I opened a BASE file, the message “LibreOffice requires a Java runtime environment...” message appeared.

What I did: So I click on Tools > Options > Libreoffice > Advanced and made sure the “use Java environment" was checked and the circle next to “Oracle Corp 1.8.0_45” was filled (not empty).

The question: I opened an existing BASE file. Usually I click on Edit > Database and see 3 options “Properties, Connection type and Advanced settings” The only available setting was “advanced options” (the rest were greyed out).

What is the solution to this? I must connect to MySql .
Last edited by doncell6 on Tue May 19, 2015 3:39 am, edited 1 time in total.
Version 4.3.7.2 on Windows 7 Pro
doncell6
 
Posts: 73
Joined: Wed Jul 24, 2013 6:26 am

Re: Installed Java 1.8.0_45 , cannot connect to MySql

Postby RoryOF » Sun May 17, 2015 6:24 am

Is the Java you installed of the correct number of bits LibO expects?
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27665
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Installed Java 1.8.0_45 , cannot connect to MySql

Postby Villeroy » Sun May 17, 2015 6:55 pm

The extension driver is not written in Java.
Deactivate Java under Tools>Options>Advanced... and restart the office.
File>New>Database...
Connect to existing database
Type: MySQL
Connect directly (not ODBC, not JDBC).
Last edited by Villeroy on Tue May 19, 2015 12:20 pm, edited 1 time in total.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 25961
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Installed Java 1.8.0_45 , cannot connect to MySql

Postby Villeroy » Sun May 17, 2015 8:28 pm

If your existing Base document is connected to MySQL via JDBC, this connection has nothing to do with the extension driver. It might be possible to change the driver via menu:Edit>Database>Connection... from JDBC to native MySQL. This should remove any dependencies on Java except for any reports that had been created using the report builder extension.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 25961
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Installed Java 1.8.0_45 , cannot connect to MySql

Postby doncell6 » Tue May 19, 2015 3:39 am

Villeroy wrote:The extension driver is not written in Java.
Deactivate Java under Tools>Options>Advanced... and restart the office.
File>New>Database...
Connect to existing database
Type: MySQL
Connect directly (not ODBC, bot JDBC).



Thank you, Villeroy. Appreciate your help. Your suggestion works.
Version 4.3.7.2 on Windows 7 Pro
doncell6
 
Posts: 73
Joined: Wed Jul 24, 2013 6:26 am


Return to External Data Sources

Who is online

Users browsing this forum: No registered users and 4 guests