Page 1 of 1

Why form is not cleared after deleting a record from a form.

PostPosted: Mon Jan 14, 2019 6:11 pm
by mpkelly1
I am using OpenOffice 4.1.6 on Windows 10. I have create a database and a form for data entry and viewing the data in my table. I have 12 fields. If I choose to delete one record using the form Navigation icon "Delete Record". The record is deleted however if the next record I look at does not have an entry for three of my field these fields are not wiped an persist from the deleted record. My question is how do I get the form to clear all fields once a record is deleted so the next record I look at or add does not have these leftover values in the fields. I assume all 12 of my field might actually need to be cleared. If I look at an existing record most of the 12 fields will have a value and replace the deleted records values. I have 3 fields that might have null values for most records but if I enter a value in the field and then decided to delete the record they persist. Hope I have explained this well enough if please ask questions.

Re: Why form is not cleared after deleting a record from a f

PostPosted: Tue Jan 15, 2019 7:27 am
by UnklDonald418
Welcome to the forum.
Base forms use the Model-View paradigm. The Model is data aware, but doesn't know how data is displayed, and the View knows how display information passsed to it, but it not data aware. If they lose synchronization you might see odd things. To force them to synchronize try adding a Push Button to your form and set the Action property to Refresh form.
If that doesn't solve the problem please upload a sample database with your misbehaving form.
[Forum] How to attach a document here