[Solved] Subform not displaying data

Creating and using forms

[Solved] Subform not displaying data

Postby ironstone » Sun Nov 27, 2016 1:59 am

Screenshot.png
Hi all

I am building a database (using the native database engine) in LO 5.0.3.2 on Linux Mint. The database is trying to make sense of multiple suppliers of multiple components.

It has 3 tables: Products, Suppliers and ProductSuppliers, linked (I hope) with one-to-many relationships from the former two to the last one (not real sure how to tell the nature of the relationship).

The Products table lists the products we require, with the names and our detailed specifications. Each is unique, and it is usually our own specification - sometimes our own design.

The Suppliers table lists the suppliers who have quoted: most quote on only one product, but some quote on multiple - enough to make entering the data multiple times not particularly smart.

The ProductsSuppliers lists the quotations, and uses two subforms - what product is being quoted on (from the Product table), and who is quoting (from the Suppliers table), then the main form details the quotation, such as minimum order quantities, pricing, the supplier's specification for the product, and a record of the clarification conversations with the supplier, and finally a judgement of whether the quotation conforms to our requirements.

But I've stuffed it up somehow; when entering a new item in the ProductSuppliers form selecting the relevant entry from the Product drop-down list and clicking in the sub-form text box displays the description of the product - which is what I want. But then selecting the relevant entry from the Supplier drop-down list does not display the data in the supplier subform - until I save the entry, then return to it.

I've checked the controls for the combo-box and the subform and subform text boxes, and everything looks fine (but then what do I know?).

I've attached a screenshot of the ProductSuppliers form.
Last edited by ironstone on Tue Nov 29, 2016 12:34 am, edited 1 time in total.
OOo 3.0.X on Ms Windows XP + CentOS Linux
ironstone
 
Posts: 15
Joined: Fri Jan 23, 2009 3:37 am

Re: Subform not displaying data

Postby UnklDonald418 » Mon Nov 28, 2016 5:33 pm

You could try adding a push Button to the subform that doesn't update.
Then on the Button Control Properties, General tab set the Action to Refresh form.
Pressing the button will force the form to reload with the updated data.
Beyond that you would need to upload a sample database for someone to look for another solution.
If your problem has been solved, please edit this topic's initial post and add "[Solved]" to the beginning of the subject line
Apache OpenOffice 4.1.6 & LibreOffice 6.1.5.2 - Windows 10 Professional
UnklDonald418
Volunteer
 
Posts: 1326
Joined: Wed Jun 24, 2015 12:56 am
Location: Colorado, USA

Re: Subform not displaying data

Postby ironstone » Tue Nov 29, 2016 12:34 am

UnkiDonald,
Thanks, that solved it.
OOo 3.0.X on Ms Windows XP + CentOS Linux
ironstone
 
Posts: 15
Joined: Fri Jan 23, 2009 3:37 am


Return to Forms

Who is online

Users browsing this forum: No registered users and 2 guests