Page 1 of 1

[Solved] After update spelling correction not working.

PostPosted: Sat Aug 04, 2018 7:28 pm
by Sea Skimmer
I have been using Open Office 4.1.3 for ages now and the little icon in the top right has been popping up bugging me to update and so today i did. Wish i hadn't bothered. Now the spell checker will not work no matter what i try. Uninstalled and re-installed. Removed user file and created new one. Been on the forums and tried a few different things which worked for other people but not me.

Now here's the strange thing. When i removed the user folder and created a new one the spell correction worked BUT only if I started typing on a fresh new page as it were. But if i copy and pasted my writing from a previous ODT file it does not recognise any spelling mistakes,see pick below.

Image

What the hell am i doing wrong here,apart from spelling mistakes :P

Re: After update spelling correction not working.

PostPosted: Sat Aug 04, 2018 7:31 pm
by RoryOF
That suggests that the language set in your older files differs from that set in your current version of OpenOffice. On your example page the language used is English (UK) - see middle of status bar . Perhaps in the newer version, English (US) (or similar) is set.

Re: After update spelling correction not working.

PostPosted: Sun Aug 05, 2018 8:57 am
by Bill
None of the misspelled words have been selected in the screen shot, so it's impossible to determine from the screen shot what the language setting is for those misspelled words. We only know that English (UK) is the setting for the point where the vertical bar appears below the text. Presumably, that vertical bar is in a new paragraph. In that case, the language setting for the misspelled words may or may not be English (UK), but I'd guess that it is not English (UK).

Re: After update spelling correction not working.

PostPosted: Sun Aug 05, 2018 12:08 pm
by Sea Skimmer
Thank you RoryOF. I did not notice that when i copied the old ODT file to the newly installed version of open office it said in the status bar 'unknown' for the language even though the i had gone through and made sure everything was set to English UK. All i had to do was left click unknown and then click English UK and start typing for the spelling correction to work again.
Thanks for the info. :D

Re: [Solved] After update spelling correction not working.

PostPosted: Mon Aug 06, 2018 12:24 pm
by Hagar Delest
That's a direct formatting. I think that you should check the styles used, see: [Troubleshooting] Spell check in OpenOffice.