AutoCorrect Superscript

Writing a book, Automating Document Production - Discuss your special needs here

AutoCorrect Superscript

Postby geowonders » Wed Aug 23, 2017 10:17 pm

In times past, using Writer, when I entered the fractions 1/2 or 3/4, they automatically formatted as superscript. I know the shortcut for superscript is CTRL+SHIFT+P but I want it to appear as superscript by default. I have followed the path:

Format
AutoCorrect
AutoCorrect Options
Replace
3/4 with 3/4 (superscript appearance)
OK

Nothing changes. Reinstalling the latest version did not make any difference. Any suggestions?
OpenOffice 4.1.2 on Windows 10
geowonders
 
Posts: 5
Joined: Mon Jul 24, 2017 7:16 pm

Re: AutoCorrect Superscript

Postby Zizi64 » Wed Aug 23, 2017 10:36 pm

In times past, using Writer, when I entered the fractions 1/2 or 3/4, they automatically formatted as superscript.

I suppose the "formatted" (substituted) ½ (and the ¾) characters is/are not three SUPERSCRIPT formatted characters, but those are UNICODE characters. You need put one Unicode character instead of the three formatted characters into the Replace window .
Tibor Kovacs, Hungary; LO4.4.7, LO5.4.7 on Win7x64Prof.
PortableApps, winPenPack: LO3.3.0-LO6.0.5 and AOO4.1.5
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 6878
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: AutoCorrect Superscript

Postby geowonders » Wed Aug 23, 2017 11:04 pm

The path for making the substitute does not mention UNICODE. It has in the "Replace" column the fractions 1/2, 1/4, and 3/4 and their respective replacements in the "With" column are superscript. But I discovered the problem: The path to fix this was: Tools > AutoCorrect Options > Use replacement table. By placing checks in both boxes, my superscript now appears as expected. At some long time in the past, I had unchecked those boxes in trying to make it stop certain corrections I did not want.
OpenOffice 4.1.2 on Windows 10
geowonders
 
Posts: 5
Joined: Mon Jul 24, 2017 7:16 pm

Re: AutoCorrect Superscript

Postby Bill » Thu Aug 24, 2017 1:27 am

Is the text set to the correct language? The options don't apply to all languages. The AutoCorrect option will also fail if the language is set to [None}.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6723
Joined: Sat Nov 24, 2007 6:48 am

Re: AutoCorrect Superscript

Postby geowonders » Thu Aug 24, 2017 2:31 am

That's good to know. However, the problem was found - as I've described above. I had not instructed the writer to use the table of replacements.
OpenOffice 4.1.2 on Windows 10
geowonders
 
Posts: 5
Joined: Mon Jul 24, 2017 7:16 pm


Return to Advanced Uses

Who is online

Users browsing this forum: No registered users and 3 guests