Page 1 of 1

[Solved] Master Documents - Page Breaks before Subdocuments

PostPosted: Thu Feb 04, 2010 12:17 pm
by Barry Say
Hi All,

I am typsetting a series of publications which have been scanned and OCRed. I want to store individual articles separately so they can be mounted individually on the web. I thought it would be a good idea to set it up as a master document with each article in a sub-document. Most articles start at the top of a page so I reckoned that including a page break before each article in the general case would be useful and remove the page break where it was not wanted.

Once I started down this road I found I couldn't get rid of the page break. Examining the content.XML file for a subdocument I found an autostyles section which had paragraph style named P2 which had the page break style, but I can find no way of deleting this except by using a text editor on the content.XML file.

Is this a known issue? Have I missed some documentation?

Barry

I am sorry to leap into the advanced group, but this looks like an advanced topic

Re: Master Documents - Page Breaks before Subdocuments

PostPosted: Thu Feb 04, 2010 12:24 pm
by RoryOF
This is not an answer to your question, but ancilliary information:
You might find it of interest to look at
http://www.scribd.com/doc/18188542/Creating-large-documents-with-OpenOfficeorg-Writer
which can be quite helpful on the use of Master Documents.

Re: Master Documents - Page Breaks before Subdocuments

PostPosted: Sun Feb 07, 2010 2:22 am
by samanarayan
I am using Master document facility for a while now, and this is what I have learned- All the sub-documents of a master document are automatically rendered in a new page. You do not have to insert a manual page break ever. When i want two such sub-documents on the same page, then i make them into one sub-document before creating a master- this may sound a bit silly, but i guess this is a tweak that works.

Re: Master Documents - Page Breaks before Subdocuments

PostPosted: Sun Feb 07, 2010 10:47 pm
by Hagar Delest
samanarayan wrote:this is what I have learned- All the sub-documents of a master document are automatically rendered in a new page.

:shock:
Never seen that. I just made a quick experiment with 3.2 (RC2) on xubuntu 9.10 and the subdocs flow without page break.

Re: Master Documents - Page Breaks before Subdocuments

PostPosted: Mon May 24, 2010 9:45 pm
by wbk
Sorry for getting this old thread all the way to the top again. I think samanarayan is refering to "print pages", while hagar is referring to "OOo pages".

In my experience, a newly inserted section in a master document starts at the top of a new "print page", while continuing the page style from the previous page.

Rereading the opening post, I can't clearly state whether the issue is with "print pages" or "OOo pages". There's not been a follow up anymore, so maybe the issue is solved or, anyway, not an issue anymore.

Re: Master Documents - Page Breaks before Subdocuments

PostPosted: Wed Jan 18, 2012 11:30 am
by Barry Say
Apologies to all for not posting sooner on this one. I found the fix for the problem.

When one sets up a master document to have each sub-document on a separate page, a "custom-style" is introduced into the subdocuments. If one then reverts to documents flowing irrespective of page breaks, this "custom-style" remains in the document but does not appear in any menus that I can find. The problem can be cured by a hand-edit of the content.xml.

This is a poisonous problem. If a sub-document with this feature is used as a template for a subsequent document this custom-style appears in the new document. If this article starts off naturally at the top of a page, no problem. If, as the master document develops, it is required that the article starts half-way down the page, it obstinately appears at the top of the next page.

I now have a work-around but if time allows I will set up a demonstration and register it as a bug.

B

Re: [Solved] Master Documents - Page Breaks before Subdocume

PostPosted: Fri Jul 24, 2015 2:19 pm
by ningappak
Even I faced the same problem while creating master document.

For section break between sub-documents to be continuous, but in one place it is showing section break (Next page). It solved by following below steps

- Place your mouse point on heading of the master page
- go to page layout
- In layout it is showing next page/ continuous
- below it showing "This Section"
- Change "This Section" option to "whole document".

I think my comment will help you to solve your problem.