Unstable links

Using them, Making them , Finding them

Unstable links

Postby henrytow » Fri Dec 04, 2015 6:56 am

Two questions:

1. Sometimes I open a document containing links and they are active, click and the underlying address opens. Sometimes when I open green spots appear around them and I can change their position and length. Why and how do I go from one to the other? The "edit links" help is either wrong or unintelligible.

2. Having moved green spotted links about, then saved my file, when reopened their positions had changed all over the place, How do I make their position stable?
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby Bill » Fri Dec 04, 2015 7:43 am

Can you post a sample file showing these links?
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6846
Joined: Sat Nov 24, 2007 6:48 am

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 3:41 pm

When I try to cut and paste a paragraph containing a link in its middle, and by in its middle I mean superimposed on the middle sentence, the links disappear. I could send you a ten page file of the whole thing.

Another problem: When I View Toolbars Hyperlink, nothing happens the first time. Then I repeat the command and the boxes for the button and the link appear.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby acknak » Fri Dec 04, 2015 4:08 pm

My guess is that the "green spotted" links are graphic elements, not regular text. Text (or links) in a graphic behave differently than the regular document text. I don't see any direct way to edit a hyperlink in a graphic. The Insert > Hyperlink ... in the main menu works, with some extra effort.

There are several reasons that the positions may not be stable. It's hard to guess what's going on exactly, but I would at least check that you're saving the file in OO's native ODF document format (.odt for text).
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Unstable links

Postby RoryOF » Fri Dec 04, 2015 4:10 pm

That was my thought also, acknak. I've just tried a regular hyperlink in OO; I could find no way to make it show the green handles.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unstable links

Postby acknak » Fri Dec 04, 2015 4:11 pm

It could also be an image with a hyperlink on it; images have green handles.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 5:44 pm

The unstable buttons all reference pages on WikiCommons
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 6:16 pm

To reply to acknak, my file is in OO Writer and no graphic elements, and is indeed wholly text.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby RoryOF » Fri Dec 04, 2015 6:29 pm

If you upload a page of your document (as an attachment, not as a screenshot), we can sort out what is happening.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 6:33 pm

TO what address do I send the email with its attachment?

I'll test the page, and if it does not contain the troubling links, I'll upload the whole thing.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby RoryOF » Fri Dec 04, 2015 6:35 pm

The Upload tab is below the Submit button on PostReply and FullEditor screens (not on QuickReply screen).
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unstable links

Postby Bill » Fri Dec 04, 2015 6:37 pm

henrytow wrote:To reply to acknak, my file is in OO Writer and no graphic elements, and is indeed wholly text.

That's why we need to see a document with some of these links. I don't ever recall seeing a green spotted link that was text. That sound like a graphic element, a picture of text and not real text. You earlier stated that you could change the length of a green spotted link. Again, that sounds like a graphic element.

Don't try to copy and paste a link to a new document. Make a copy of a document which has the links and delete most of the content but leave a link. Post that copy.
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6846
Joined: Sat Nov 24, 2007 6:48 am

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 6:42 pm

My message contain too few characters, so I hope these suffice.
Attachments
Troubling page.odt
Links work fine but look where they wandered !
(31.18 KiB) Downloaded 148 times
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby RoryOF » Fri Dec 04, 2015 6:53 pm

Aha! Hyperlinked buttons, not native hyperlinks. I cannot see where the buttons are anchored, and also cannot get them to resize, but I'm tired.
Going offline.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 6:55 pm

The problem does seem to be in their anchoring, or lack thereof.

I am deleting each wanderer and replacing it where I want it rather than moving it about.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby RoryOF » Fri Dec 04, 2015 7:07 pm

What anchor are you choosing? I suspect it should be "Anchor to character" rather than "as character". Personally, when I (rarely) use hyperlinks, I prefer the text form, where the reference (such as San Pancrazio Polyptyych) is blue and underlined - one can change that styling, say to a light gray, rather than have the text cluttered with buttons.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 27308
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unstable links

Postby acknak » Fri Dec 04, 2015 8:14 pm

I'm not sure I understand what the intent is here. Using form controls for hyperlinks is quite unusual--is there some reason to avoid the usual link within in the text?

I suspect the instability is coming from the default anchoring ("to paragraph") along with positioning the buttons by dragging them. In this combination, Writer will automatically move the anchor to the nearest paragraph. When the text changes (with screen size, web/print layout, margins, etc.), the position of the button will change also. You may have better results with "Anchor to character" but I can't say for sure.

If you change to "anchor as character" then the buttons will take space from the text.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Unstable links

Postby henrytow » Fri Dec 04, 2015 11:45 pm

Barely understand your reply.
form controls for hyperlinks ???
anchoring ("to paragraph") ????
"anchor as character" ????

I am redoing all the links and then not moving them. Not "reanchoring" them ?
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby Bill » Sat Dec 05, 2015 1:10 am

Basically, the "links" in your document aren't standard links. They do not appear in the Navigator as links and the "edit links" Help will not apply to them. They are not text. They are "objects". Objects must be anchored to something, usually text or a page. They are also form controls. When working with form controls, design mode can be turned on or off. When design mode is off, your "links" are active. When design mode is on, the green spots will appear on the "links".
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6846
Joined: Sat Nov 24, 2007 6:48 am

Re: Unstable links

Postby henrytow » Sat Dec 05, 2015 1:33 am

Thank you.
Putting in the links anew and not moving seems to make them stable.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby henrytow » Sat Dec 05, 2015 1:38 am

Just one question: What is the Navigator? People keep referring to it.

Asking Help is non-informative.
OpenOffice 3.3 on Windows 7
henrytow
 
Posts: 25
Joined: Sat Feb 26, 2011 12:25 am

Re: Unstable links

Postby Bill » Sat Dec 05, 2015 2:03 am

View > Navigator
AOO 4.1.5 and LO 6.0.3.2 on Manjaro MATE
Bill
Volunteer
 
Posts: 6846
Joined: Sat Nov 24, 2007 6:48 am


Return to Templates

Who is online

Users browsing this forum: No registered users and 1 guest