Template name becomes document title

Using them, Making them , Finding them

Template name becomes document title

Postby valgemeri » Thu Jan 15, 2009 9:47 am

Hi!
Does anybody have suggestion how to go around OO3s strange feature -- template name becomes document title. Amongst the Document properties there are Title. Usually is is not needed. But creating PDF the OO uses it. And later reader of PDF may be confused by titles like "2009 documentation template A2" or "Page number and bottom line in header" or "Official paper with logo and address". One work-around is immediately after creating new document from template just go and change document properties. But I always forgot it :)
May-be I'm wrong using template name (ott title) as description? But how to solve several problem at same time:
a) understanding my templates to choose the best start to new document
b) do not attach wrong information to my PDF-s

Or may-be it is possible somehow automatically open document properties window if starting new document from template (actually blank document uses template as well - so solution may be that I can define to force asking properties inside template?, otherwise it would be annoying other way)
valgemeri
 
Posts: 1
Joined: Thu Jan 15, 2009 9:19 am

Re: Template name becomes document title

Postby Hagar Delest » Thu Jan 15, 2009 2:04 pm

Either remove the title from the template or in File>Export as PDF options, go to the User Interface tab and uncheck the Display document title entry. Note that the setting remains when you hit the direct PDF export button in toolbar afterwards.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28589
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Template name becomes document title

Postby 2CV67oo » Sat Nov 27, 2010 11:33 pm

Hagar de l'Est wrote:Either remove the title from the template or in File>Export as PDF options, go to the User Interface tab and uncheck the Display document title entry.


I am having this issue when exporting as pdf from OOo Draw v3.2.0 in Ubuntu 10.04.
I unchecked the Display document title entry & that stays unchecked, but my pdf exports are still headed DrawBlank.

The other alternative offered is
remove the title from the template
.
Does that mean - remove the name from the template?
That does not appeal!

Thanks for any help!
LibreOffice4.4.2.2 on Ubuntu 15.04.1 & LibreOffice ??? on W8.1 & LibreOffice 3.3.4 on Win7
2CV67oo
 
Posts: 55
Joined: Sat Nov 27, 2010 11:12 pm
Location: Alsace

Re: Template name becomes document title

Postby Hagar Delest » Sat Nov 27, 2010 11:57 pm

I mean the title in the properties of the file (File>Properties>Description).
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28589
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Template name becomes document title

Postby StephenW » Tue Nov 30, 2010 6:37 am

One thing that I've learned in life is to "change what you can, but then live with what is". If you can find an answer to this situation, then fine (and please tell us if you find a solution). But if you can't find a solution, then learn to live with it. What I mean by that, is change your habits. For instance, as soon as you create a new document from a template, immediately change the name in "File>Properties>Description>Title". Sometimes changing how we do something is our only or best choice.
Best Wishes,
Stephen
Stephen
OOo 3.2.X on MS Windows Vista + Windows XP
StephenW
 
Posts: 7
Joined: Sun May 17, 2009 4:08 pm

Re: Template name becomes document title

Postby Arconix » Sat Dec 01, 2018 5:03 am

Eight years later, I've found a solution through a combination of your efforts.
This problem has been annoying me ever since I thought it would be nice to set up my own default template.

Once you make a template, it adds the template name in (File>Properties...>Description>Title) as found out above.

To fix this, open the template document (File>Templates>Organise...>[Choose template]>Edit). This opens the .ott file.

In your .ott file, delete the template name in (File>Properties...>Description>Title), then save the template file.

Thats it!
Now when you export to PDF, it will be the default (filename.pdf) in the title bar.

I hope someone else will still find this useful.
Apache OpenOffice 4.1.2 on Windows 7
Arconix
 
Posts: 1
Joined: Sat Dec 01, 2018 4:48 am


Return to Templates

Who is online

Users browsing this forum: No registered users and 1 guest