[Solved] Envelopes > Printing > No "Mail Merge" and other

Using them, Making them , Finding them

[Solved] Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Thu Sep 25, 2008 10:08 pm

Hi, sorry for the post.,..but this is NUTS...<laugh> as so far, many hours into this.

1) Able to connect to outside DB Server for tables etc.

2) Followed this

http://wiki.services.openoffice.org/wik ... a_database

Many times, Click newdoc...etc...but I never get Mail Merge box,

Been here > http://wiki.services.openoffice.org/wik ... Mail_Merge

then here>> http://documentation.openoffice.org/man ... oauthors2/

Open now...and just a note...<lol> Searchable HTML page for this, would be easier...as I think... 37 pages...to learn how to print 18 envelopes...<laugh> is nuts...

I am just venting...as I have been on this stuff since yesterday, had DB connect issues...resolved an hour ago...

I don't think I need mail merge?... I just want to print just envelopes? Sorry for venting, but my dog was stolen...I am trying to get up to speed with OO to do envelopes....My MS stuff is stured in Montana, 1,700 miles away...and time is of the essence to contact Vets', Kennels & Shelters with a letter w/his picture...

Any expidited help, would be great...Any one in the US I may call? to walk me thru this program.... I have been programming since late 1970's paper tape, MS DOS 2.0 and up, but this thing....even though I really like it so far...is getting to me...<sigh> w/a BIG LAUGH.

Thx in advance, to all..

Jim
Last edited by trochia on Tue Sep 30, 2008 1:39 pm, edited 2 times in total.
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby Villeroy » Thu Sep 25, 2008 11:33 pm

OK, I did it for the first time too.
First I created a query in my datasource which includes only the fields and the records I need. As you see in the screenshot, the text file is imported with the wrong encoding and one record is a header line actually. Doesn't matter yet.
I created a new text document, call the stylist (F11), pick "page styles", choose envelope. I could adjust the page style (right-click>Modify...).
menu:Insert>Frame... [OK]. Frames are draggable boxes you can freely move and expand on the envelope. I kept the frame's border which I would remove normally.
F4 shows the registered datasources. I browse to my query, grab the grey field-headers and drag them into the frame, insert some spaces and paragraph breaks between the inserted fields. I do the same with my sender fields (Ctrl+F2, tab:Document, type:Sender) and add some margin to the page style. Surprisingly, it asks me if I want to print a form letter which I confirm. I have to choose the query once again (well, it could be another one every time I print the same serial letter) and specify the printer (I print to a single document).
The generated document includes 7 envelopes with my address and the 7 addressees from my database query.
envelope.png
my first mail merge in Writer

To be honest, I'm positively surprised.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26753
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 1:23 am

It seems Like I am getting closer...Attached is screenshot, for some reason...did not pull from Addresses2 the database?

It printed ( with frame)

<Name>
<Address>
<City>, <State>, <ZIP>

Surprisingly


:shock:

I am suprised it is this difficult...smile, as what happenes if the database is very large?

If I could get it to pull data, I think I can get this.

Thank-you so far for help...but still unable to, but I will keep trying

I think I need to re-start and do "Field Assignment? first?

Also, I had much more typing...but when I clicked on your attacment, and went back...it lost all my text here in forum I typed.. :o

I kept the frame's border which I would remove normally.


In this, I do not know what NORMAL is, so how are frames removed? And why Have a frame?

I understand for placement, but this seems like difficult way to print simple address on envelope, and is not in Instructions...

I am trying to do, and thank-you for your effort..
Attachments
ODBC01 Sep. 25 18.17 DPE1.gif
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby acknak » Fri Sep 26, 2008 2:32 am

I'm sure you guys aren't posting real people's actual addresses, right?

Probably harmless, but I wouldn't take a chance on that.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 2:34 am

OK, now without doing all the dropping and dragging, I have this...

It looks like I had to DEFAULT the Enevlope FIRST !! As all I did was then click Insert Envelope, select db etc...

I will "try' to pull print now....
Attachments
ODBC03 Sep. 25 19.28 DPE1.gif
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 2:40 am

Thx for the concern and at this point I don't give a rats behind...about my address, as all I have been trying to do...is get this to do simple printing of multiple addresses for 2 days now...( in which I could do in Office 2k) But, that PC crashed...my disks are 1,700 miles away in storage..

Here is why!! I am in a hurry.

http://janesville.craigslist.org/laf/853160323.html

Sorry if my real address offends anyone, I am trying to mail a letter and picture to every vetinarian, kennel and shelter for a 200 mile radius...as soon as possible.

As anyone can take off his rabies tags, and re-liscense him...

Jim
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 2:58 am

Here is a screenshot of where I am, I F4'd...Man, it takes a long time to load stuff...anyway, then I did a drop and drag...

Tried print...but all it did was print 1 page, and only my return address..
It seems now, where where DOC's say about asking my to mail merge??.. Heck, I've opend so much doc's on this...I forget where everything is...lol

I am reading > page 19 and on from there...following the steps.

http://documentation.openoffice.org/man ... lMerge.pdf

But I never get a MAIL MERGE dialog box?? (figure 25)

Ahh, contol F9, does show me....so I click print, and said "show field names"..I click NO.., but still not printing more than one...or anything .

I clicked no on Print Form Letter also...

OK, I found an ICON that opened Mail Merge wizard, but it says letter...etc.. I select Street Address List, (and the db etc)

I am now creating a "New Address Block" I guess...

OK, Headway? At Preview of Merged Document Have 16 items...so far, so good.(ODBC05 image)

I click edit, have 3 boxes..??

Well, I hit next..it takes 1 second each to load? WHOA...Anyway, for as "addresses" it says Page 1 29/31?

I will end this now, as I need to see what "Villeroy" posted, as I need to "move" the block..

So far? For me being 50 years old, programming since the late 1970's...versed in quite a bit...this is the hardest thing to do, for one of the easiest processes "word processors" were invented for, prior to computers...and after the electric typewriter..

Even an Address-o-Graph is faster than this program learning curve.

http://en.wikipedia.org/wiki/Addressograph

http://www.addressingmachines.com/1900.htm ( I have tun one of these...many hours creating metal plates, etc...for mailing...lol

If it feels like I am knocking it?...Please consdier this "constructive critisizm" on the project...please.



BUT?? The smilies work fine here laugh...This world is out of control, and spinning backwards anymore.... And I as a young man applauded "new technology"...that was in Machining, where parts ( doucments are just parts...compiled) were mass produced...easily.
Attachments
ODBC05 Sep. 25 20.54 DPE1.gif
ODBC04 Sep. 25 19.58 DPE1.gif
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby acknak » Fri Sep 26, 2008 5:14 am

Trying to attack this by "slash and burn" has a low probability of success and makes it harder for others to help you. I'm sorry, but I can't really follow what you've done so far, so I have no idea what may be causing the problem.

Also, do you have to print envelopes? OOo is not terribly adept at printing envelopes--it can be done, but it usually takes some extra fiddling. Most people find it a lot easier to print stick-on labels with the addresses, but I understand you're in a hurry and may not want to wait to get labels.

In any case, forget the envelopes for a minute and try this simpler test run:
1) File > New > Text Document
2) View > Data Sources
3) Select the "Bibliography" data source (just for a test: it comes built in to OOo) > Tables > "biblio"
4) Select the first column: "Identifier"
5) Click the column header and drag it into the document. This will insert a field.
6) File > Print

You should now get a prompt asking if you want to do a mail merge. If you don't then something basic is wrong. Hopefully it works as it should; answer 'yes'.

You should get a window where you see the biblio data again. Under "Records" on the left, select "From" and "1 to 3"

Under "Output" on the right, leave it on "Printer", or if you don't want to use three pieces of paper, select "File" and leave the other options as the defaults. Click OK.

You should now have either three pieces of paper with the first three Identifiers from the biblio table printed on them (or a new text document with the same).

If this test is not working, then you have a basic problem and your envelopes aren't going to work either.

If this test does work, then you've now seen the whole process from beginning to end. It will be the same process to do a set of envelopes or labels, except you use Insert > Envelope to create a properly laid out envelope page instead of a full-size paper page. Forget trying to add the database fields from the envelope dialog window: just leave them blank in the dialog and add the fields later by dragging them from the data grid as I described above.

You may want to start by simply typing some address information into the envelope document page (no fields at first) and try a print, just to make sure that you can actually print an envelope correctly. Getting the ink on the envelope in the right places usually requires some adjustment and can lead to another adventure. You won't be prompted to do a merge if you just type the address yourself.

Once you are sure that you can print an envelope, you can go back and replace your typing with the database fields, and then File > Print should take you to the mail merge dialog window and you're home free at that point.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 2:34 pm

I thank-you very much for this "step-by-step" and am presently in the process of doing it.

Due to the fact of the mess created so far, I went and deleted the (4) files that had been created during yesterday from my drive.

Address.odb
Address1.odb
Address2.odb
Address3.odb

?? ( if this was the extension...I forget...but I left my env1.odt & env2.odt which I hope were my proper templates..

Back to starting fresh, my first step was to open WRITER, and:
>> File > New > Text Document, I then proceeded to your step 2
and error of (attached) that the Addresse3.odb does not exist, which
is a true statement...as I deleted them.

My first thought is why they still show? I would understand, this is due to the fact that were "registered" within this suite.

My next step of common sence is to hit the help file(WRITER), Search term > "remove odb" gives (2) results.

a: General Glossary ( results nothing related to *.odb removal from view )
b: Query Design ( results in Removing tables, which was helpful in doing so )

Again, I thank-you for this step by step, and am proceeding...but I am commenting "out loud" here, as to keep track of my experiences of this, as instead of the pop with just an "OK" of the error, the logic behind it could also implement 2 things.

1) It does not exist any longer at this location, would you like to search your disk? ( as it could have been moved) w a Y/N..

2) A simple YES would then delete it, and then parse thru and also take note-correct any others that are "MIA" also...

As mentioned...mental notes...here, just to help in the name of "open source"...as I (when my time permits again) be more than happy to write the proper doc for envelopes "only"

Now, back to business :-)

Thx again,

Jim

Thx again, Jim
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby Villeroy » Fri Sep 26, 2008 3:26 pm

trochia wrote:I am suprised it is this difficult...smile, as what happenes if the database is very large?

To answer this one at least:
Print the document [Ctrl+P]
Message Box wrote: "Your document contains address database fields. Do you want to print a form letter? [Yes|No|Cancel]

By the way, when are database fields considered as "address database fields". Could it be that this makes a difference?

If confirmed with [Yes], you get another dialog which allows filtering, sorting as well as individual selections records [Ctrl+Click]
dialog_merge.png
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 26753
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 4:04 pm

You should now get a prompt asking if you want to do a mail merge. If you don't then something basic is wrong. Hopefully it works as it should; answer 'yes'.


No at this point, I get that attached ( sorry about not attaching the other mentioned above, as it was not needed)

"Your document contains address database fields. Would you like to print a form letter"

The "Mail Merge" did not show up, so I will press "yes" anyway, even though I was 'trained" in NO for doing envelopes.. ;-)

Clicking "Yes" then does bring me to the "Mail Merge" as described. Upon finishing up you instructions did produce (3) sheets... Thank-you.

I am also attaching a s/s of my template created yesterday, and all looks properly filled out already. I would suspect that, once the template has been created this is how it may be done.

Now, from a developer ( and also new end user standpoint ) I would (once going to File > Open ) would expect to have a sub-cat of my templates....instead I did see it located in recent documents, and grabbed it from there. But this would be an ever increasing number, and over time I would suspect "drop from view" I do not know the number of "recents" it holds, as I show 10 at this point.

Now, back to my env2.odt open, I will just press F4 to open the DB view...etc., but first I must go back and re-register my DB ( in which I am seeing, downloads it locally )

File > Wizard > Address a Data Source (other) > Settings > select "type" > (next - browse) SELECT ( this process must originally be set up prior...etc ) [again, mental notes] as I am also skipping "Field Assignments" at this stage.

> Name the Data Source ( which will be registered and stored locally ) and this seems to take quite some time for only a few records. ( I feel this could be improved, if no actuall elimated as connection to a live server is/has been established ) It has been at least 5 minutes, and I see nothing "loaded or registered" (updated) in the F4 window, so I will now File > Recent Documents, same one...hoping to REFRESH, but it's in the same state.

A Standard Windows F5 (refresh open windwo) does not do this, but pops up a "Navigator"

Now, File>New>Text (F4) and it does pull the DB into view, hence we must now close the "pre-opened" Template, that "must be a fresh item" or hard to find possibly, ( Which I would consider to be held hostage undr File>Open>Template )

Close F5 NAvigator, Now, for the heck of it, I "right clicked" the only showing "Biliography, and "Addresses" DOES show, under "Registered DB's", so I select it...but it still does not repopulate into my "present view > open env2.odt, so now it looks like I must close it completely. (redundantcy)

Then, File, Recent doc's...etc....Template pulls, F4 now shows....Select Addresses > Tables > proper table then selected..

WOW....this process takes some killer time also... (at least 3 minutes)

Now I erased present fileds that were pulled prior, did a drop/drag of new fields...did a File/Print, options for printer came up...the defaulted Letter # 10 was fine, clicked OK...but didn't get a "Mail Merge" option.

Will now try: Insert > Envelope (whoa, another time consuming I/O operation for amount of data)

The envelope window is popping up fine, everything in "Envelope tab" looks proper, and leaving DropDown "Database Filed" null.

Format tab is fine, and also DC'd (double checked printer)

I am now clicking "New Doc" if I remember correctly from yesterday....Nope, NEW DOC didn't do that, it opened a new one...nope... I hit cancel instead...as it says it has been MODIFIED... Screenshot shows Page 1 / 1 Enevlope, English, 100% , INSRT, STD so I think?? This should work?

OK, File > Print = Select NO to Form Letter , Still don't understand this, as I prior had selected "ENVELOPE"... I would change to > Have this only in Doing form letters, asking would you also like to do an envelope? Actually, thinking about it...would you not have to have set up (2) printers? or you would be switching back and forth?

Clicking now, once again brought up Printer box, I will check properties one more time...all stayed static....Show Fields box shows (again) Selecting NO.... HHmm,

Just prints 1, and FROM only, nothing yanked from DB...

OK, close...restarrt> regarding =

You should now get a prompt asking if you want to do a mail merge. If you don't then something basic is wrong. Hopefully it works as it should; answer 'yes'.


I am using my odt from yesterday, and not GETTING Mail Merge...

Could this be a problem? As I dropped dragged...all looked fine, yet just prints my return addy...

And I never get to
You should get a window where you see the biblio data again. Under "Records" on the left, select "From" and "1 to 3"

Under "Output" on the right, leave it on "Printer",


Is the using of the yesterdays 'envelope.odt' screwing things up?

PS... Now, 9:03am, and on this since a tad after 6am :-)

But, thx again...there has to some simple thing causing this.

JIm
Attachments
ODBC07 Sep. 26 07.42 DPE1.gif
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Fri Sep 26, 2008 10:08 pm

Hello Villeroy, and thx also for the effort here.

If confirmed with [Yes], you get another dialog which allows filtering, sorting as well as individual selections records [Ctrl+Click]


When saying "yes"... you saying you also want a form letter...is when it brings up this box... This "does not" allow envelopes only,

and if "no" is selected, the MAIL MERGE never shows at all...it goes direct to printer...then prints only one.

And, for the overall "use labels".. This is were I just don't believe what is going on here, as:

In 1845, Edwin Hill and Warren De La Rue were granted a British patent for the first envelope-making machine


and even though I can't locate a "patent" on it easily, a self adhesive mailing label came long after the envelope did...so it just puzzles & baffles me, that this just won't "simply" print envelopes?

Somehow, I feel we'll get to the bottom of this...lol

Jim
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby trochia » Tue Sep 30, 2008 1:53 am

Acknack & Villeroy !!

Again, I thank-you both for the time spent on this issue, and I "fianally" got it to work..

You wouldn't believe how many times I repeated this process, and then unistalled OO and reinstalled...and then went to Bugtracker...and read unresolved issues from 2005 and said THWI (to heck with it), but today...while manually entering into and printing...when I was done with the orignal 16 I had ( for days now), I decided to try it one more time...

Acknack re:

Under "Output" on the right, leave it on "Printer", or if you don't want to use three pieces of paper, select "File" and leave the other options as the defaults. Click OK.


OK, Open Writer ( after doing the register DB stuff in Base )

Insert Env > Up comes the jazz, I pull my fields...etc... Do a NEw Doc thing..
Press the F4, but I don't need to drop/drag...as they are alredy there (from prior step) etc.

CTRL-P ( to print, ) say YES...(even though it says PRINT A FORM LETTER....then eventually pops up MailMerge..

Now ?? This time, I select "Single Print Jobs"...and that wasn't discussed...nor ever had been selected in the past...but I did it... selected a a few records...and BINGO...

You should now have either three pieces of paper with the first three Identifiers from the biblio table printed on them (or a new text document with the same).


Whcih brings me to this, I have no idea why...it "pulled" biblio fields and printed, without me having to "CHECK" the above mentioned tick box...in Mail Merge...

Again, thx to all...for your help....and I will mark this thread as resolved....an hope this "chit chat" of mine, (and your replies) helps another NEwbie in the future.

Jim

PS.. How do I report as solved please?
OOo 2.4.X on Ms Windows W2k
trochia
 
Posts: 14
Joined: Wed Sep 24, 2008 6:01 pm

Re: Envelopes > Printing > No "Mail Merge" and other

Postby Hagar Delest » Tue Sep 30, 2008 1:11 pm

trochia wrote:PS.. How do I report as solved please?

Add '[Solved]' at beginning of your first post title (edit button).
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28480
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Templates

Who is online

Users browsing this forum: No registered users and 1 guest