[Solved] Copy and Paste Problems

Creating a macro - Writing a Script - Using the API

[Solved] Copy and Paste Problems

Postby rtellshow » Thu Sep 19, 2019 8:38 pm

I don't know if this is the right place for this.

I had problem with copy and paste working from within a macro. Pasting while recording a macro would work but when I ran the macro nothing would paste. Also using the method: oPasteRange.setDataArray(oCopyRange.getDataArray()) would not work either.

After much research I found the cause and solution. I had uninstalled and reinstalled different version of LO. The link below instructed me to close LO completely, and rename my user folder to user-old. A new one is automatically created on start-up and that solved it! It might solve other issues too.

Folder Location:
C:\Users\Me\AppData\Roaming\LibreOffice\4\user

LibreOffice User Profile Corruption
https://wiki.documentfoundation.org/UserProfile

Hope this help someone as I have gotten a lot of help here.
Last edited by MrProgrammer on Tue Nov 19, 2019 11:34 pm, edited 1 time in total.
Reason: Tagged ✓ [Solved]
OpenOffice 4.1.3 on Windows 10
rtellshow
 
Posts: 10
Joined: Tue Apr 13, 2010 8:46 am

Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 6 guests