Using OpenOffice UNO API on Linux server

Creating a macro - Writing a Script - Using the API

Using OpenOffice UNO API on Linux server

Postby Tim Grantham » Tue Nov 27, 2018 6:08 pm

I have a UNO API Java application I created that runs great with OpenOffice on every OS except a Linux server. Linux desktop, yes; Linux server, no.

The obvious difference between the Linux desktop and the Linux server is the latter has no X windows. But I was able to get my UNO API application to work on a Linux server (CentOS) by installing libSM, along with LibreOffice.

Unfortunately, LibreOffice is failing badly when processing tables in Writer documents. OpenOffice Writer, on the other hand, has no problems processing tables. So I really need OpenOffice to run on a Linux server.

I have installed libSM and OpenOffice 4.1.5 on a Linux server and I can run OpenOffice from a command line. But when I run my UNO API Java application, the bootstrap method in com.sun.star.comp.helper.Bootstrap always fails with a noConnectException.

Has anyone else been able to get a UNO API application working with OpenOffice on a Linux server?

Thanks,
Tim.
OpenOffice 4.1
Windows 7 Professional
Tim Grantham
 
Posts: 31
Joined: Thu Jan 06, 2011 12:03 am

Re: Using OpenOffice UNO API on Linux server

Postby arunkumar7h » Mon Feb 11, 2019 11:27 am

Hi..

Even I'm facing similar issue. Did you find any solutions for this?
OpenOffice 5.2 on Windows 10
arunkumar7h
 
Posts: 3
Joined: Mon Feb 11, 2019 11:13 am

Re: Using OpenOffice UNO API on Linux server

Postby Tim Grantham » Tue Feb 12, 2019 6:34 pm

No, unfortunately.
OpenOffice 4.1
Windows 7 Professional
Tim Grantham
 
Posts: 31
Joined: Thu Jan 06, 2011 12:03 am


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 7 guests