[Solved] Macro Dialog Not Responding

Creating a macro - Writing a Script - Using the API

[Solved] Macro Dialog Not Responding

Postby bartjeman » Wed Feb 21, 2018 7:56 pm

I think I know the answer to this, but here goes...

Today I tried to edit one of my macros (attached to a .ods document), however the Macros dialog is unresponsive.

When I click the "+" sign beside the document name, rather than displaying the macro hiearchy, the "+" sign simply disappears. Screen shot attached.
Attachments
Clipboard01.jpg
Last edited by Hagar Delest on Fri Feb 23, 2018 12:10 am, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 4.0.1 on Windows 7
User avatar
bartjeman
 
Posts: 139
Joined: Sun Jan 03, 2010 6:23 am
Location: Toronto

Re: Macro Dialog Not Responding

Postby Zizi64 » Wed Feb 21, 2018 8:14 pm

Today I tried to edit one of my macros (attached to a .ods document), however the Macros dialog is unresponsive.

Please upload your ODF type sample file here with the embeded macro.
Tibor Kovacs, Hungary; LO4.4.7, LO6.1.1 on Win7x64Prof.
PortableApps, winPenPack: LO3.3.0-LO6.1.2 and AOO4.1.5
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 7312
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Macro Dialog Not Responding

Postby UnklDonald418 » Thu Feb 22, 2018 7:02 am

When I click the "+" sign beside the document name, rather than displaying the macro hiearchy, the "+" sign simply disappears.

That indicates that there has never been a macro stored with that document. If there had been a macro that was deleted it would still have a Standard folder with no modules.
Maybe your macro code is stored in My Macros.
If your problem has been solved, please edit this topic's initial post and add "[Solved]" to the beginning of the subject line
Apache OpenOffice 4.1.5 & LibreOffice 6.0.4.2 - Windows 10 Professional
UnklDonald418
Volunteer
 
Posts: 965
Joined: Wed Jun 24, 2015 12:56 am
Location: Colorado, USA

Re: Macro Dialog Not Responding

Postby bartjeman » Thu Feb 22, 2018 7:29 pm

Nah
I had a hunch it was the profile
I blew out the old profile and everything was good to go
...except of course all my oo settings and tool bars were gone :-(
OpenOffice 4.0.1 on Windows 7
User avatar
bartjeman
 
Posts: 139
Joined: Sun Jan 03, 2010 6:23 am
Location: Toronto

Re: [Solved] Macro Dialog Not Responding

Postby robleyd » Fri Feb 23, 2018 1:14 am

If you renamed the profile when you reset it, you can recover settings - see [Tutorial]The OpenOffice User Profile for more detail on what is where.
Cheers
David
Apache OpenOffice 4.1.4 - Windows 7
Apache OpenOffice 4.1.5 - Slackware 14.2 - 64 bit
User avatar
robleyd
Moderator
 
Posts: 2080
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: [Solved] Macro Dialog Not Responding

Postby bartjeman » Fri Feb 23, 2018 7:37 pm

Thanks I'll check it out
OpenOffice 4.0.1 on Windows 7
User avatar
bartjeman
 
Posts: 139
Joined: Sun Jan 03, 2010 6:23 am
Location: Toronto


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 4 guests