[Solved] Macro not working on Mac

Creating a macro - Writing a Script - Using the API

[Solved] Macro not working on Mac

Postby det » Wed Nov 08, 2017 2:03 am

My OO macros work fine on Windows Vista. Just bought a Mac sierra 10.12.6.
If I try to run the macro on it, the following message shows:
" A scripting Framework error occurred while running the Basic script Standard.NWCopy.FindFilledRow

Message wrong number of parameters!"

Now, if I open the OO Basic Window and click the run button, he macro works fine.

What am I doing wrong. Can somebody help? ThanK you. Det
Last edited by det on Wed Nov 08, 2017 7:57 pm, edited 1 time in total.
OpenOffice 4.1.5 on Mac Sierra 10.13.1
det
 
Posts: 51
Joined: Fri Mar 31, 2017 8:24 pm

Re: Macro not working on Mac

Postby RusselB » Wed Nov 08, 2017 2:43 am

While I'm by no means a "Master of Macros", nor do I own a Mac, I suspect anyone that might be able to help will need to see your macro code.
Thus I have to recommend that you upload/attach your macro code. Preferably in a document that it can be tested on.
OpenOffice 4.1.4 and LibreOffice 5.2.7.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4157
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 5 guests