CPU Utilization 100%

Creating a macro - Writing a Script - Using the API

CPU Utilization 100%

Postby akataria » Fri Jun 30, 2017 3:45 pm

Hi,
I'm trying to convert documents(.docx/.xlsx/.pptx) to PDF using JOD Converter. I'm using OpenOffice 4.1.2 on Centos 7. MY problem is I'm getting constant usage of 100% while i'm converting file and this is impacting the performance of overall machine. I have tried every possible option in the command line options, but ,unfortunately, haven't been able to mitigate this issue. I have searched on a lot of forums, and found that lot of other people are also facing the same problem, however, there is no solution out there. Through my readings, I realize this could be because memory leak problem in OpenOffice. Can someone please help me resolve or at-least mitigate this?

Below is the command that I use to spawn the OpenOffice instance.

/opt/openoffice4/program/soffice.bin -accept=socket,host=127.0.0.1,port=8016;urp; -env:UserInstallation=file:///tmp/.jodconverter_socket_host-127.0.0.1_port-8016 -headless -nocrashreport -nodefault -nofirststartwizard -nolockcheck -nologo -norestore
OpenOffice 1.4.3 and CentoS 7
akataria
 
Posts: 2
Joined: Fri Jun 30, 2017 3:34 pm

Re: CPU Utilization 100%

Postby akataria » Fri Jul 07, 2017 2:27 pm

Moderators,
anything here?
OpenOffice 1.4.3 and CentoS 7
akataria
 
Posts: 2
Joined: Fri Jun 30, 2017 3:34 pm


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 15 guests