AOO crashing when trying to edit macro

Creating a macro - Writing a Script - Using the API

AOO crashing when trying to edit macro

Postby ptoye » Mon Feb 23, 2015 6:27 pm

AOO crashes when I try to edit a macro in Calc. Simple to get it to happen: load the workbook, go to Tools|Macros| Organise| OOBasic . In Standard|Module1 select a macro and try to edit. It crashes, at least on my machine. Interestingly, after recovery, I can edit OK, but at the next load and edit it crashes again, This is behaviour very similar to that noted in https://forum.openoffice.org/en/forum/v ... 8&start=90 which seens to be very system=-dependent. I've not tried it out on other AOO docs with macros.

Can someone try it out on their system please?

It runs OK on Libre Office.
Attachments
MacroCrash.ods
Crashing workbook.
(25.53 KiB) Downloaded 67 times
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: AOO crashing when trying to edit macro

Postby F3K Total » Mon Feb 23, 2015 7:40 pm

Hi,
no problems, W7, AOO 411.
Neither when editing in the spreadsheets Library, nor when editing Tools|Macros| Organise| OOBasic . In Standard|Module1
R
    MMove 1.0.6
  • Extension for easy, exact positioning of shapes, pictures, controls, frames ...
    my current system
  • Windows 7 OOo, AOO, LOLinux Mint OOo, AOO, LO
F3K Total
Volunteer
 
Posts: 935
Joined: Fri Dec 16, 2011 8:20 pm

Re: AOO crashing when trying to edit macro

Postby ptoye » Mon Feb 23, 2015 9:08 pm

Thanks for trying. It might be my machine, but I'm not sure quite how. I'll try a safe reboot tomorrow.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: AOO crashing when trying to edit macro

Postby F3K Total » Mon Feb 23, 2015 9:12 pm

I don't think that's the machine, i think it's your macro library, try to rename your user profile.
R
    MMove 1.0.6
  • Extension for easy, exact positioning of shapes, pictures, controls, frames ...
    my current system
  • Windows 7 OOo, AOO, LOLinux Mint OOo, AOO, LO
F3K Total
Volunteer
 
Posts: 935
Joined: Fri Dec 16, 2011 8:20 pm

Re: AOO crashing when trying to edit macro

Postby ptoye » Mon Feb 23, 2015 9:32 pm

Tomorrow! I'm logging off now. But I tried that for the other crash and it did nothing at all.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: AOO crashing when trying to edit macro

Postby gsd4me » Fri May 29, 2015 1:11 pm

Don't know if this thread is still active or valid but this has started happening to my machine as well - a new Windows 8.1 installation using OO 4.1.1, trying to access my macros via Calc, when everything was fine on my old machine.
Anyone had any ideas? There was a suggestion (via Google search) to turn off "update notification" which I did, and that worked ONCE, so not really any further forward after that.
gsd4me
 
Posts: 18
Joined: Thu Sep 08, 2011 3:01 pm

Re: AOO crashing when trying to edit macro

Postby tmarkjames » Thu Aug 13, 2015 6:30 pm

I've had this happen while editing a macro in Writer. I can enter, save, and execute the macro, and make minor edits; but if I try to delete one or more whole lines of code, OpenOffice crashes. It doesn't matter whether I delete or cut, or select a line and try to paste something over it, and it doesn't matter whether I edit using the keyboard, the toolbar buttons or the Edit menu -- any edit that involves removing an end-of-line character will crash OpenOffice. The only way I can remove lines from my code is to comment them out. I'm using 4.1.1 under Windows 8.1 on a Lenovo Yoga 2 tablet.

Any ideas appreciated. -- Mark
OpenOffice 4.1.1, Windows 8.1
tmarkjames
 
Posts: 1
Joined: Thu Aug 13, 2015 6:10 pm

Re: AOO crashing when trying to edit macro

Postby gsd4me » Thu Aug 13, 2015 11:24 pm

I must admit that this has not happened again for a while now on my W8.1 machine.
Can't remember if I did anything 'special' beyond downloading the latest version of OO after uninstalling the earlier version, and I don't think that I changed user profiles etc as suggested in other areas. Sorry that I can't be more specific as it now seems to be behaving itself.
gsd4me
 
Posts: 18
Joined: Thu Sep 08, 2011 3:01 pm

Re: AOO crashing when trying to edit macro

Postby ptoye » Fri Aug 14, 2015 10:32 am

Have you tried LibreOffice? Worked for me.
Peter
OO 4.1.1 on MS Windows 7 64-bit
ptoye
 
Posts: 225
Joined: Mon Apr 21, 2008 11:07 am
Location: Reading, England

Re: AOO crashing when trying to edit macro

Postby JerryO » Sun Dec 30, 2018 11:39 pm

Old topic, but I just encountered the same problem using OpenOffice 4.1.5 on Windows 10. The moment I hit the "delete" key to edit a macro, OO vanished like a soap bubble. When I re-launched, all but two of my macros were gone (and they weren't the first ones I'd recorded; they seemed to have been picked at random). I had updated Windows earlier in the day (version 1803 for x64-based systems, KB4483234), but this was the first time I tried editing a macro so I don't know if the problem existed before or not. From the existence of this forum topic, and a couple of others I found, it sounds like this problem has been around for a while and was either never fixed or was fixed and it's now broken again.

My workaround has been to simply re-record any macro I want to edit. That has been working okay.

Has anyone figured out what's actually going on to cause this particular crash?
OpenOffice 4.1.5 on Windows 10
JerryO
 
Posts: 12
Joined: Sat Dec 29, 2018 5:16 am

Re: AOO crashing when trying to edit macro

Postby JeJe » Tue Jan 01, 2019 2:28 pm

JerryO:
We've had a recent thread discussing the same problem - a Windows 10 update may fix it for you.

viewtopic.php?f=20&t=96298
Openoffice 4.1.2
Windows 8
JeJe
Volunteer
 
Posts: 612
Joined: Wed Mar 09, 2016 2:40 pm

Re: AOO crashing when trying to edit macro

Postby JerryO » Tue Jan 01, 2019 9:28 pm

JeJe wrote:JerryO:
We've had a recent thread discussing the same problem - a Windows 10 update may fix it for you.

viewtopic.php?f=20&t=96298


Hmm. I had just updated Windows an hour or so before the crash, and that was on the 30th, well after people were reporting that the update had fixed the problem. So either there was an update that fixed it and another update that broke it again, or that was never the fix in the first place.

No worries; I've got all my macros loaded now, and backed up. If I have more data later, I'll post in the other more recent topic.

Thanks,
Jerry
OpenOffice 4.1.5 on Windows 10
JerryO
 
Posts: 12
Joined: Sat Dec 29, 2018 5:16 am


Return to Macros and UNO API

Who is online

Users browsing this forum: No registered users and 12 guests