Page 1 of 1

Patch of Xray 5.2 for OOo 2.4.0

PostPosted: Sun Mar 30, 2008 4:15 pm
by B Marcelly
Version 2.4.0 of OpenOffice.org has a regression (Issue 87596) which renders unusable the buttons to increase and reduce the panel width.

This Basic file makes it work again until the bug is corrected.
1 - download and save the file, it has a .bas extension.
2 - with the IDE open library XrayTool, module _Main
3 - select all the code of the module (on MS-Windows : Ctrl-A)
4 - click button at right "Insert Basic source text" and select the patch file. All the code is replaced.
5 - click button Save (floppy icon)

For your information, routine changeDialogWidth is modified. The new handling is not compatible with OpenOffice.org version 1.1.x and maybe not with oldest 2.x versions. So you should only patch if you have the bugged version of OpenOffice.

Later, to get back the normal handling, the simplest way is to reinstall Xray.

______
Bernard

Re: Patch of Xray 5.2 for OOo 2.4.0

PostPosted: Thu May 15, 2008 9:49 am
by ashok_
Hello there:

I am still having the "squashed window" window problem with XRay even after applying the patch.

I am running OpenOffice.org 2.4 on Ubuntu 8.4 (Hardy Heron).

Note: I am not running the OpenOffice.org 2.4 installation packaged with Ubuntu, I have removed that, and installed via the debian package downloaded from the openofffice.org website.

thanks

Ashok

Re: Patch of Xray 5.2 for OOo 2.4.0

PostPosted: Thu May 15, 2008 11:41 am
by B Marcelly

Re: Patch of Xray 5.2 for OOo 2.4.0

PostPosted: Fri May 16, 2008 8:54 am
by ashok_
Bernard,

thanks ! Compiz was indeed the culprit, I disabled graphical acceleration in Ubuntu and now it seems to be fine.

Ashok