[Workaround] Can't disable blinking cursors in MacOS/WINE?

Issues installing under the Mac OSX - X11 - Aqua

[Workaround] Can't disable blinking cursors in MacOS/WINE?

Postby MarjaE » Mon Oct 28, 2019 4:19 am

Hi,

I have a strobe sensitivity and visual motion sensitivity. And I can't see near binking/flashing/blinding cursors, and can get migraines and nausea from them. Same for blinking edges around text objects.

I cannot disable the blinking cursors in MacOS. I have used the fixes listed here: http://www.macissues.com/2014/12/08/how ... link-rate/ i.e. defaults write -g NSTextInsertionPointBlinkPeriod -float 10000, and similarly for ...On -float 10000 and ...Off float 10000. They fail in OpenOffice. They also fail in LibreOffice, which used to be my preferred office software. They work in NeoOffice for text cursors, but not the blinking edges around selected text objects.

I cannot disable them in WINE either. I used Wineskin Winery, with the following added to win.ini: CursorBlinkRate=-1 I was able to set up OpenOffice 4.1.7 for Windows using an older machine, but it ignores the win.ini setting and keeps blinking/flashing.

I haven't found any alternative drawing software which can open and work with odg files without the blinking. I don't know about dual-booting Linux on a Mac, but it might be another option.
Last edited by MarjaE on Tue Oct 29, 2019 9:16 am, edited 2 times in total.
NeoOffice 2015.11 on MacOS 10.12
MarjaE
 
Posts: 5
Joined: Fri Jan 06, 2017 5:29 am

Re: Can't disable blinding cursors in MacOS or WINE?

Postby MrProgrammer » Tue Oct 29, 2019 1:04 am

MarjaE wrote:Can't disable blinding cursors in MacOS or WINE?
Your post will be hard for others to find. The generally used term is "blinking cursor" and people will search for that, not "blinding cursor". You can edit your post's title (Edit button) if this was a typographical error. The term "blinding cursor" may be humorous, but it makes the post obscure and useless for anyone else. You would want to help others, wouldn't you?

MarjaE at OpenOffice wrote:I am photosensitive and need to blok flashing, blinking, and several other types of animation. In NeoOffice, I have been able to block cursor blinking with a terminal hack, but haven't been able to block selection flashing and marching migraine ants. In LibreOffice, I have been able to block selection flashing and marching migraine ants, but not cursor blinking, and have had trouble with crashes on startup. In OpenOffice, as of my last installation, I hadn't been able to block either, and had trouble with crashes on startup. I can use Escape to defeat the flashing in Calc, but that loses focus in Draw. I literally can't see what I'm doing in Draw, because of the flashing-- I can't see near flashing objects.
MarjaE at LibreOffice wrote:I know there didn't used to be. I have visual processing issues and cannot see near any kind of flashing or blinking, and can get awful migraines and nausea from it. I can't see any text I'm typing in Draw, Writer, or Calc, or any objects I'm moving in LibreOffice Draw. I mostly stopped using LibreOffice because of the blinding cursors, but I haven't found any drawing software that lets me see the screen while working, and it's important to be able to see the screen. I use related writing software which doesn't have this bug. There is no system-wide setting for cursor rates in MacOS. (P.S. The defaults write fix only works for some cursors in some applications.)
You asked the same question three years ago here, and recently in the LibreOffice forum. It's considered rude to multi-post and not notify the forum volunteers that you've done so.

MarjaE wrote:I haven't found any alternative drawing software which can open and work with odg files without the blinking.
The current version of NeoOffice on MacOS might respect the settings you make with the defaults command. Please let us know if that helps with the blinking cursor.

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3868
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Can't disable blinking cursors in MacOS or WINE?

Postby MarjaE » Tue Oct 29, 2019 9:15 am

NeoOffice respects the defaults write fix, but *only* for the text cursors. I have one other workaround, which is to use a rectangle, add text to the rectangle, make the fill transparent, and make the lines invisible.

P.S. I wouldn't consider this entirely solved, and the title doesn't have enough room for [Worked Around].
NeoOffice 2015.11 on MacOS 10.12
MarjaE
 
Posts: 5
Joined: Fri Jan 06, 2017 5:29 am


Return to Mac OSX

Who is online

Users browsing this forum: Google [Bot] and 2 guests