[Solved] Old Java required but unusable on Catalina

Issues installing under the Mac OSX - X11 - Aqua

[Solved] Old Java required but unusable on Catalina

Postby BratcheGeige » Thu Oct 10, 2019 6:32 pm

MacOS 10.15 Catalina. Preferences show the latest Java with an option button clicked which I think means it is properly installed. Trying Tools>Macros>Run Macro ... causes crash. Same thing trying to assign a macro to a push button. Message says I need to install legacy Java SE 6 runtime. I did that before and it worked fine until this week. The new Catalina OS doesn't allow installing the old 32 bit Java. Will this bug be fixed soon?
Last edited by MrProgrammer on Thu Oct 10, 2019 10:07 pm, edited 2 times in total.
Reason: Replaced vague term "new MacOS" with "Catalina" to improve searchability; Tagged [Solved]
OpenOffice 4.1.7
MacOS 10.15 Catalina
User avatar
BratcheGeige
 
Posts: 11
Joined: Thu Oct 10, 2019 6:02 pm

Re: Old Java version required but unusable on new MacOS

Postby MrProgrammer » Thu Oct 10, 2019 6:46 pm

BratcheGeige wrote:Will this bug be fixed soon?
Have you read our Survival Guide for the forum? There are no developers here. We are users, just like you. No one on the forum knows what plans are being made for bug fixes. Read the Survival Guide to learn how to contact the developers. Or perhaps you can find a solution more quickly by performing a web search for "Catalina" and "Java", or similar search terms.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3961
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Old Java version required but unusable on Catalina

Postby John_Ha » Thu Oct 10, 2019 7:10 pm

BratcheGeige wrote:The new Catalina OS doesn't allow installing the old 32 bit Java.

Try a 64 bit Java. AOO for MacOS is 64 bit so presumably uses 64 bit Java????

AOO for Windows uses 32 bit Java as AOO for Windows is 32 bit.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7794
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Old Java version required but unusable on Catalina

Postby BratcheGeige » Thu Oct 10, 2019 7:54 pm

Sorry for the trouble. I thought I might try to find a version of Java that would solve the problem. So I went to Oracle. They had only one choice> the latest update. So I downloaded that and everything is fine! The funny thing is that Apple System preferences had said that my Java was up to date!
OpenOffice 4.1.7
MacOS 10.15 Catalina
User avatar
BratcheGeige
 
Posts: 11
Joined: Thu Oct 10, 2019 6:02 pm

Re: Old Java version required but unusable on Catalina

Postby RusselB » Thu Oct 10, 2019 9:24 pm

Always trust the update information from the application provider over that of the system check.
It's possible that an application can have an update, but the update search mechanism hasn't been updated to include the latest application update (ps: I realize hgw confusing that sounds).
OpenOffice 4.1.7 and LibreOffice 6.3.3.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 6108
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 3 guests