Can't Open Old or New Drawings - OO Just Crashes

Issues installing under the Mac OSX - X11 - Aqua

Can't Open Old or New Drawings - OO Just Crashes

Postby martinwinlow » Sun Oct 15, 2017 3:53 pm

SInce this morning I cannot access old drawing files or open new ones. WHen I try to do so, the app crashes and I get the "OpenOffice quit unexpectedly", Openoffice Document Recovery, all docs are recovered successfully, and clicking on Next immediately opens one of the files and immediately it crashes again and back to "OpenOffice quit unexpectedly". Writer still appears OK.

I have tried deleting my user profile. I have tried Safe Mode. Neither makes any difference.

Anyone got any thoughts? I note the similarity between my issues and 'OO keeps crashing on start up High Sierra'...

MW
OpenOffice 4.1.2 MacOS10.11.6
martinwinlow
 
Posts: 10
Joined: Sun Aug 23, 2015 5:15 pm

Re: Can't Open Old or New Drawings - OO Just Crashes

Postby MrProgrammer » Mon Oct 16, 2017 8:41 pm

martinwinlow wrote:SInce this morning I cannot access old drawing files or open new ones
Any advice I have for you is in [Tutorial] Mac FAQ. Perhaps try Q15/A15 or Q28/A28? Reboot your Mac if you haven't since the difficulty began. It would help others to know how you resolved the problem, if you do, so please post that.

Screen Shot 2017-10-16 at 13.13.19 .png
Fix your forum signature in User Control Panel → Profile → Edit Signature if you want any future help from me. Knowing your OS and OpenOffice release is important for otherwise you may receive incorrect advice or we may think that certain situations (like Q15/A15) do not apply to you and not mention them.

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
OpenOffice 3.2.0 Build 9483 on Mac OS X 10.9.5.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Volunteer
 
Posts: 3123
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Can't Open Old or New Drawings - OO Just Crashes

Postby martinwinlow » Thu Oct 19, 2017 4:38 pm

So I have fixed my signature... and the problem has not gone away. So again... anyone got any ideas? I have tried reverting to OOV3 and it is slightly better but inevitably just crashes eventually.

I have tried safe mode - no difference. Beginning to get very annoying.
OpenOffice 4.1.2 MacOS10.11.6
martinwinlow
 
Posts: 10
Joined: Sun Aug 23, 2015 5:15 pm

Re: Can't Open Old or New Drawings - OO Just Crashes

Postby martinwinlow » Fri Oct 20, 2017 7:41 am

I tried the 'switch to Guest' (Q/A28) and can access the drawing without any issues. I had already tried 'resetting my (normal user) profile' using the instructions in the Mac Tutorial (Q02) several times to no effect.

When I use Q/A 02 to arrange a new profile and Go to Folder ~/Library/Application Support/OpenOffice.org, I only find '3'. However, at ~/Library/Application Support there is one folder called 'OpenOffice.org' and another called 'OpenOffice' (amongst many other non-OO-related folders, of course) which has only one sub-folder called '4'. I have tried trashing the User subfolder from both... but could the legacy OO folder be causing issues? Should I delete it?
OpenOffice 4.1.2 MacOS10.11.6
martinwinlow
 
Posts: 10
Joined: Sun Aug 23, 2015 5:15 pm

Re: Can't Open Old or New Drawings - OO Just Crashes

Postby MrProgrammer » Fri Oct 20, 2017 9:47 pm

martinwinlow wrote:However, at ~/Library/Application Support there is one folder called 'OpenOffice.org' and another called 'OpenOffice' (amongst many other non-OO-related folders, of course) which has only one sub-folder called '4'.
Thank you!! I do not use OpenOffice 4 and did not realize the folder name had changed from OpenOffice.org to OpenOffice (without .org). I've updated the Q02/A02 section of the tutorial.

martinwinlow wrote:I have tried reverting to OOV3 … Should I delete it?
The important task when resetting your profile is to ensure that you're deleting the user folder for the version of OpenOffice that you're using. You can only do that if you know what version you're using as now explained in Q02/A02. You must also ensure OpenOffice is not running when you delete the user profile. When you restart OpenOffice after deleting the folder, it will ask you for your initials. If it doesn't, you were unsuccessful in deleting the correct user folder. If you don't want version 3 installed, read Q04/A04. But installing version 3 may have reset the default application for your OpenOffice files to version 3, so if you delete it you may need to review Q33/A33 (or reinstall version 4).

martinwinlow wrote:I tried the 'switch to Guest' (Q/A28) and can access the drawing without any issues
So, OpenOffice works fine and the problem is localized to the other account you use. This could be due to dozens of complications and I doubt If I can help you further. Perhaps it is due to some strange preferences in Finder, or unusual file permissions, or fonts you've installed, or backup software you're running, or file-sync software you're running. That the problem occurs in Safe Mode would seem to rule out the latter two, but who knows? If you create a new account, perhaps it will work fine too. Then you could migrate your files to the new account and remove the old one. That's a bunch of work but if it solves the problem you'd be happy.
Mr. Programmer
OpenOffice 3.2.0 Build 9483 on Mac OS X 10.9.5.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Volunteer
 
Posts: 3123
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 5 guests