Page 1 of 1

Error saving doc with password on Mac OS X

PostPosted: Mon Mar 03, 2014 11:17 pm
by DesignMinded
Hello there. I have searched the forums extensively to find a solution. I have several documents saved in Writer native format (ODT) using password protection on my Mac OS 10.9.2. For a long time I never had any issues with these when opening, editing and saving them. Recently, all of the sudden, the documents no longer open with the password I set up. The error said after trying to enter the password is: "The password is incorrect. The file cannot be opened." I have remembered the exact password but they won't open at all. I haven't updated or changed my password for these each time I use them. I have renamed the folder under Library > Application Support > OpenOffice > 4 > User to User.old and then created a new user profile to no avail. So I have tested using a total blank document and then tried to save it with password, I received this error that said: "Error saving the document XXX: General error. General input/output error." I tried to save it without a password, it was fine. It was the most strangest thing that ever happened to me after several years of no problems. They have important information and I did save them on another external hard drive but faced the same error unable to enter the password I set up due to the errors I mentioned above. I even tried to download OO 3.4.1 but still encounter the same errors. Is there a way to recover those corrupt files?

Error.png

Re: Error saving doc with password on Mac OS X

PostPosted: Sat Apr 05, 2014 4:28 am
by Sea Mac
4 days ago ALL of my odt files were readable. All of a sudden EVERY ONE of them is Corrupted and says the password is incorrect! Even the ones I backed up online now are somehow unreadable after I download them.

Opening one of these files in Text Edit gets this message: "The document “text and pictures.odt” could not be opened. The file isn’t in the correct format. The file might be corrupted, truncated, or in an unexpected format."

I'm running Mac OS X 10.9.2 and AOO 4.0.1 and 4 days ago everything was fine. Now I cannot open ANY of my Writer Documents and my business is ruined. WHY did EVERY password Protected Writer document suddenly become the wrong format?!? And taking the Files to another Mac with a different OS didn't help.

Correction: the Mac Book Laptop Running 10.6.8 and OO 3.4.1 WAS able to Open the Documents with the proper password! Hurray!!! I quickly Saved the Data in files with NO passwords ... all of which open OK on 10.9.2. I got ALL my data Back!!!! :super:

So it it either 10.9.2 or AOO 4.0.1 that has the problem with password protected files!

Re: Error saving doc with password on Mac OS X

PostPosted: Wed Jul 09, 2014 1:16 pm
by Soaraway87
I have the same issue: text and spreadsheet files that worked perfectly in the past now won't open on my main macbook ("The password is incorrect. The file cannot be opened."). I can save new files without password protection but when I try to put a password on I get the "General input/output error" message mentioned in the previous posts. As with Sea Mac I can still open the protected files on my other macbook (OSX 10.7.5, OO 4.0.0).

So far I have:

- uninstalled OpenOffice by dragging it to the Trash and reinstalled from a new download
- deleted OpenOffice User Profile as per the instructions here https://forum.openoffice.org/en/forum/v ... 74&t=12426 and re-started OpenOffice to build a new profile
- uninstalled OpenOffice following the method given here http://www.ehow.com/how_8303209_remove- ... 3-mac.html and reinstalled from a new download
- reinstalled OSX 10.9.4 using the cmd-r option at startup
- uninstalled and reinstalled OpenOffice again

The problem is still there. I can't use my main macbook for any work involving files with password protection.

Has anyone any suggestions?

Re: Error saving doc with password on Mac OS X

PostPosted: Thu Jul 10, 2014 5:01 am
by MrProgrammer
If I were going to upgrade Open Office, or if I were going to upgrade OS X, I would first save all Open-Office-password-protected files without passwords. Then I would do the upgrade. Finally I would reapply Open-Office-passwords to them. Since I currently run OOo 3.2 and OS X 10.6.8, I will have to go through that process one of these days. I've seen too many reports of difficulties to risk leaving passwords applied through an upgrade. This suggestion may seem impractical to you. It won't be for me.

If this answered your question please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.

Re: Error saving doc with password on Mac OS X

PostPosted: Mon Jul 28, 2014 3:45 pm
by sbgraphic
Hello,

Just had this same issue on all OpenOffice documents with password. It just appears without further notice after a week-end… (without any install)
At first it looks like a java issue but I tried to resin tall an older java version without any success. :crazy:

The only way I found was to boot using old osx install and open those files with an old NeoOffice version to resave those files without any password. But the problem remains even if those files have no password anymore. Could not open them. So it look likes something was corrupted...

Has anyone solved this issue and if yes how ?
Thanks,

Re: Error saving doc with password on Mac OS X

PostPosted: Sat Nov 15, 2014 10:26 pm
by jchwcpa
I upgraded all my Macs and one is showing exactly the problem you describe. I can open files without password protection. But I cannot add password protection or open a file with password protection, copied from another computer. What gives????

Re: Error saving doc with password on Mac OS X

PostPosted: Wed Nov 19, 2014 12:36 pm
by sbgraphic
Nerver find out the reason neither the answer, I'm using LibreOffice since.

Re: Error saving doc with password on Mac OS X

PostPosted: Wed Nov 19, 2014 4:45 pm
by jchwcpa
I fixed the issue on my MacBook.

History: upgrade to OX X 10.10.1, upgrade to OpenOffice 4.1.1
Result: Could not open password secured files any more, even though they opened on other computer, could not save files with a password
Fix: Completey delete OpenOffice from MacBook: delete OpenOffice application in Applications directory, delete OpenOffice folder in ~/Library/Application Support/; re-download and re-install OpenOffice; done
Reason: Access rights to safety libraries in ApplicationSupport incorrect after upgrades. Complete deletion and re-install fixed access rights to security data and keys.

Re: Error saving doc with password on Mac OS X

PostPosted: Mon Feb 09, 2015 12:46 pm
by uweiss_efkon
Hello.
Same issue here, but not Mac, but Linux. (Fedora 20, OpenOffice 4.1.1)

Error Msg is:
Error saving the document Untitled1:
General Error.
General input/output error.

I can not save _any_ file with pw-protection. I even can not open such files (leads to "wrong password", reinstalled OpenOffice 3.3 -> works).
Obviously there is some terrible wrong...

Re: Error saving doc with password on Mac OS X

PostPosted: Mon Feb 09, 2015 12:55 pm
by RoryOF
I suggest you delete or rename your OpenOffice User Profile. Details are in
https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=12426

I have just saved a file on OO 4.1.1 on Xubuntu 14.10 and reopened it, with no problems.

Remember that passwords are case sensitive.