Page 1 of 1

Regular Arial Font in Italics on Mac OpenOffice.org

PostPosted: Tue May 03, 2011 2:04 pm
by JamesPrest0n
Hi there,

I'm wondering if anyone can help... I recently installed a whole bunch of new fonts, and had no problem in Photoshop and OpenOffice, but hadn't worked in iWork Pages for a while. When I went to use Pages recently, a number of the fonts were all in weird Unicode. So I googled it, and "resolved duplicate fonts" in Fontbook, restarted, and Pages was perfect.

But now! In my OpenOffice my regular Arial font is in italics! There is no way of making it normal, even though it is the regular default font. This is really frustrating because it is my default font.

Can anyone please help?

Thanks.

Flame icon removed. That icon means 'Tagged to a known issue' (TheGurkha, Moderator)

Re: Regular Arial Font in Italics on Mac OpenOffice

PostPosted: Tue May 03, 2011 6:46 pm
by RoryOF
Search for files Arial*.ttf and see if there is both an Arial.ttf and Arial_Italic.ttf, with different sizes. If they are the same size it is possible that Arial_Italic.ttf has been copied over to or renamed Arial.ttf. File names may not be identical on Mac, but a search should give you a clue.

Re: Regular Arial Font in Italics on Mac OpenOffice

PostPosted: Tue May 03, 2011 7:25 pm
by MrProgrammer
If the previous advice doesn't help, you should search for "font" in this forum since others have reported and then solved OOo font-related problems on Macs, and you may recognize a topic that matches your situation. You may need to purge the font cache after using FontBook as described in Text invisible in Help panel which I realize is not your symptom but still could be your solution. I'd purge the cache by booting your Mac in Safe Mode since that does cleanup that's good to perform every so often, though others have had success by running atsutil.

Re: Regular Arial Font in Italics on Mac OpenOffice

PostPosted: Tue May 03, 2011 8:33 pm
by lgusaas
JamesPrest0n wrote:... and "resolved duplicate fonts" in Fontbook, restarted, and Pages was perfect.
But now! In my OpenOffice my regular Arial font is in italics! There is no way of making it normal, ...

Open Font Book.app and check if "Arial - Regular" is turned off. If so, right click on Regular and then click on 'Enable "Arial" '.

Font Book.jpg