Change the default email client

Issues installing under the Mac OSX - X11 - Aqua

Change the default email client

Postby rcosby » Sat Jan 29, 2011 2:11 am

I have both Openoffice and Neooffice for my MBP. In Neo, if I click to email the current document Outlook (my default) opens and the document is properly attached. In OO, Apple Mail launches. I know that Outlook is set as my default mail program and nothing I do seems to change it with OO. The newer versions of OO seem to respond a little quicker than Neo but I need everything to use the same mail program.
OOo 3.3.X on Mac OSx Leopard
rcosby
 
Posts: 2
Joined: Sat Oct 18, 2008 3:14 pm

Re: Change the default email client

Postby lgusaas » Sat Jan 29, 2011 2:30 am

Did you set your email client in OOo preferences?
On the Menu bar go to: "OpenOffice.org/Preferences/Internet/Email" and set your email client.
Larry I. Gusaas
Moose Jaw, SK Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." Edgard Varese
Apache OpenOffice 4.1.6 — MacBook Pro(Retina)—macOS Ver.10.14.5 Mojave
lgusaas
Volunteer
 
Posts: 1551
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Change the default email client

Postby rcosby » Sat Jan 29, 2011 3:27 am

Yes, I tried that. The default is to leave it empty. I can browse and select another email client in /Applications but then it complains that the system has no properly configured email client. I read through the documentation and it looks like that was put there to select the client in linux. Windows defaults to the default client and there is a way to change that by modifying a help application NOT using the menu choice. The documentation that I was reading probably predated the mac version of OO and it did not mention it.

Again, Neo correctly picks the system default so it seems like this should not be hard to find.
OOo 3.3.X on Mac OSx Leopard
rcosby
 
Posts: 2
Joined: Sat Oct 18, 2008 3:14 pm

Re: Change the default email client

Postby robglass » Wed May 22, 2019 10:09 pm

Dear Igusaas,

No problem navigating OO/Preferences/Internet/Email. But on "Sending documents as email attachments" panel, I have no idea what to enter in the "Email program" rectangle. I would like to use Comcast mail, but my iMac defaults to Apple Mail which I do not like. How do I select Comcast mail as my default email ?

OSX 10.14.5 AOO 4.1.6
OpenOffice 4.1.5 and FireFox 60.0.1 on MacOS 10.13.4
robglass
 
Posts: 20
Joined: Fri May 25, 2012 5:04 am

Re: Change the default email client

Postby RusselB » Thu May 23, 2019 12:18 am

Quite simply you can't. This is a limitation of OpenOffice, and I believe, LibreOffice.
They do not have the protocols encoded in order to use an online e-mail client.
If you want to use that option, then you have to have an e-mail client installed on your computer (eg: Thunderbird).
The only alternative, staying with Open/LibreOffice, that I know of, is:
1) Save your file to your hard drive (saving to a USB drive is not recommended)
2) Open your online e-mail client.
3) Start to compose a new e-mail in the client
4) Attach the file you saved to the new e-mail
5) Send the e-mail with the attachment,
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5299
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 5 guests