[Solved] Java (JRE) issues using Database

Issues installing under the Mac OSX - X11 - Aqua

[Solved] Java (JRE) issues using Database

Postby vivianarend » Sat Oct 09, 2010 10:22 pm

I'm trying to use the Database in OpenOffice and get an error message. Requires Java runtime environment. The selected JRE is defective. Select/ install a new version.

I just updated Java- Apple Inc 1.5.0_24. It's selected in the preferences section of OO
Open Office is 3.2.1 and I'm on a MacBook 10.5.8

The other parts of OpenOffice work fine. Suggestions?
Last edited by vivianarend on Fri Oct 22, 2010 4:40 pm, edited 2 times in total.
Viv OO 3.2.1 MacBook 10.5.8
vivianarend
 
Posts: 5
Joined: Sat Oct 09, 2010 10:09 pm

Re: Java (JRE) issues using Database

Postby RoryOF » Sat Oct 09, 2010 11:47 pm

After the Java update have you a) restarted your computer, b) gone to Tools / Options / OpenOffice.org / Java [windows/Ubuntu path]and told it to use your installed Java? For a Mac the path differs; I think it is OpenOffice.org/Preferences/ something
Last edited by RoryOF on Sun Oct 10, 2010 12:14 am, edited 1 time in total.
Apache OpenOffice 4.0.1 on Xubuntu 14.04 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14373
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Java (JRE) issues using Database

Postby vivianarend » Sat Oct 09, 2010 11:57 pm

Yes to both- restarted, and when I go through Preferences/Java/ the Apple Inc shows up and I've got the box checked for it to be used.
??
Is there an alternative Java I can upload?
Viv OO 3.2.1 MacBook 10.5.8
vivianarend
 
Posts: 5
Joined: Sat Oct 09, 2010 10:09 pm

Re: Java (JRE) issues using Database

Postby RoryOF » Sun Oct 10, 2010 12:15 am

You could visit www.java.com and see if it has a mac version of Java.
Apache OpenOffice 4.0.1 on Xubuntu 14.04 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14373
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Java (JRE) issues using Database

Postby lgusaas » Sun Oct 10, 2010 2:41 am

You could try reinstalling Java. Go to http://support.apple.com/kb/HT4140 to download it.

Or try using Java SE 6 (6.0_20) if you have a 64bit (Core2) processor (MacBook 2.1 or newer). Use the 'Add' feature in the Preference file. The location will be similar to the location path given at the bottom of the Preference settings for Java.
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Java (JRE) issues using Database

Postby terry_nyorks » Thu Oct 21, 2010 2:18 am

Hello

I've the same problem with the similar error message - attached. Now I can do nothing with Open Office dbase. Mac OS X V10.6.4; 2.26GHZ Core2 Duo; Open office v3.2.1 (OOO320m18 (Build:9502)). All this started after loading Report Builder Extension, and then trying to install the Java JRE software, as per the OO help page.

However, the Help page is misleading since it insists on " Tools (I read that literally, i.s. as meaning a TOP menu bar item) - Options - Open Office.org - Java " the drop downs therefore don't exist! However, advice above has led me to ' OpenOffice.org ' (TOP menu bar, first) - Preferences - Java ' (there is NO MENU ITEM "OPTIONS"). Now I do not know what item to point to for the Add button data.

Java Preferences App says JAVA SE 6 BOTH 64-bit, and 32-bit v1.6.0_22-b04-307 are loaded.

As I haven't a clue where the RTE is, nor the file name, Could someone tell me what to input for the Add button data?

(Apologies for a degree of repetition, but this is the nearest discussion topic I can find, short of starting a new thread). Many thanks.
Attachments
open office - java error.tiff
open office - java error.tiff (34.92 KiB) Viewed 16510 times
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: Java (JRE) issues using Database

Postby lgusaas » Thu Oct 21, 2010 4:31 am

However, the Help page is misleading since it insists on " Tools (I read that literally, i.s. as meaning a TOP menu bar item) - Options - Open Office.org - Java " the drop downs therefore don't exist! However, advice above has led me to ' OpenOffice.org ' (TOP menu bar, first) - Preferences - Java ' (there is NO MENU ITEM "OPTIONS"). Now I do not know what item to point to for the Add button data.

Unfortunately, not all of the Help files have been translated to the proper Mac terminology. 'OpenOffice.org/Preferences' is the Mac equivalent of 'Tools/Options'.

To install Java click the Add button. Then navigate to:
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
Then click on the Home button.

java location.jpg

Make sure there is a dot in the circle beside Apple Inc. in the preferences window. I've attached a screenshot of my setup.

java.jpg
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Java (JRE) issues using Database

Postby rbremer » Thu Oct 21, 2010 9:47 am

Unfortunately, this approach does not work with OO 3.2.1 (release version). Since the Java update from Apple even manually specifying the path brings up the same error message, in fact, it won't even register in the dialog. The Java version has been bumped to 1.6.0_22, maybe there is a library missing in this build or it has changed architecture?

Is there any way to debug the Java loading process in OO?

Ronny
OpenOffice 3.2.1 on MacOS 10.6.4 / OpenOffice 3.2.1 on SLED 11 SP1 / OpenOffice 3.2.1 on OpenSUSE 11.3
rbremer
 
Posts: 7
Joined: Thu Oct 21, 2010 9:35 am

Re: Java (JRE) issues using Database

Postby lgusaas » Thu Oct 21, 2010 10:04 am

rbremer wrote:Unfortunately, this approach does not work with OO 3.2.1 (release version). Since the Java update from Apple even manually specifying the path brings up the same error message, in fact, it won't even register in the dialog. The Java version has been bumped to 1.6.0_22, maybe there is a library missing in this build or it has changed architecture?

Is there any way to debug the Java loading process in OO?

Ronny

Oops! I updated Java after my previous post. Java no longer works for me in OOo 3.3.0 RC1. Doesn't work in LibreOffice Beta2 either.

I'll make some inquiries when I have time.
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Java (JRE) issues using Database

Postby rbremer » Thu Oct 21, 2010 12:30 pm

Thanks Larry.
OpenOffice 3.2.1 on MacOS 10.6.4 / OpenOffice 3.2.1 on SLED 11 SP1 / OpenOffice 3.2.1 on OpenSUSE 11.3
rbremer
 
Posts: 7
Joined: Thu Oct 21, 2010 9:35 am

Re: Java (JRE) issues using Database

Postby terry_nyorks » Thu Oct 21, 2010 2:17 pm

Sorry Larry, but:

To install Java click the Add button. Then navigate to:
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
Then click on the Home button.



The folder "Home" goes deeper, and recurses even deeper (to infinity?)! All I get is a further error, see attachment.

Do I read after helping me your OO / Java now no longer works? Sorry to cause that; but given the intervening messages, it seems there is clearly something wrong.
Attachments
oo_parms_jave rte error.tiff
oo_parms_jave rte error.tiff (21.56 KiB) Viewed 16462 times
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: Java (JRE) issues using Database

Postby floris v » Thu Oct 21, 2010 2:29 pm

You need to say that you want to use Java, and you have to select a JRE from the list.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3029
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Java (JRE) issues using Database

Postby terry_nyorks » Thu Oct 21, 2010 2:42 pm

To continue:
Interestingly Java RTE would appear to be running, so why can't Open Office | Preferences | Java find it:

Last login: Thu Oct 21 13:36:39 on ttys000
T...$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)
T...'s-MacBook:~ T...$
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: Java (JRE) issues using Database

Postby rbremer » Thu Oct 21, 2010 2:49 pm

floris v wrote:You need to say that you want to use Java, and you have to select a JRE from the list.


We are aware of that, but OO doesn't automatically find Java on a Mac after the latest Java update from October 20th. So there is no JVM to choose from.

Ronny
OpenOffice 3.2.1 on MacOS 10.6.4 / OpenOffice 3.2.1 on SLED 11 SP1 / OpenOffice 3.2.1 on OpenSUSE 11.3
rbremer
 
Posts: 7
Joined: Thu Oct 21, 2010 9:35 am

Re: Java (JRE) issues using Database

Postby floris v » Thu Oct 21, 2010 2:53 pm

No problem, it just happens that it's easily overlooked and pointing it out has helped some people in the past.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3029
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Java (JRE) issues using Database

Postby lgusaas » Thu Oct 21, 2010 5:49 pm

terry_nyorks wrote:To continue:
Interestingly Java RTE would appear to be running, so why can't Open Office | Preferences | Java find it:

It has been reported as a bug and been named a showstopper for the release of OOo 3.3. See:
http://www.openoffice.org/issues/show_bug.cgi?id=115180

The bug report also includes a workaround. (requires using 'Terminal' to implement)
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Java (JRE) issues using Database

Postby JohnBuell » Thu Oct 21, 2010 7:29 pm

Larry, that was a perfect fix. Thanks for posting it!
OpenOffice 3.2.1 on Mac OS X 10.6.4
JohnBuell
 
Posts: 1
Joined: Thu Oct 21, 2010 7:27 pm

Re: Java (JRE) issues using Database

Postby vivianarend » Thu Oct 21, 2010 9:48 pm

lgusaas wrote:
terry_nyorks wrote:To continue:
Interestingly Java RTE would appear to be running, so why can't Open Office | Preferences | Java find it:

It has been reported as a bug and been named a showstopper for the release of OOo 3.3. See:
http://www.openoffice.org/issues/show_bug.cgi?id=115180

The bug report also includes a workaround. (requires using 'Terminal' to implement)


So I'll have to wait for the new de-bugged version then? ;)

Because all of the other suggestions here have failed me thus far.
Viv OO 3.2.1 MacBook 10.5.8
vivianarend
 
Posts: 5
Joined: Sat Oct 09, 2010 10:09 pm

Re: Java (JRE) issues using Database

Postby lgusaas » Thu Oct 21, 2010 10:12 pm

So I'll have to wait for the new de-bugged version then? ;)

Unless you use the workaround listed in the bug report. You would have to work from the command line in Terminal to implement it.
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Java (JRE) issues using Database

Postby amaloney » Thu Oct 21, 2010 10:51 pm

Larry
I'm using OOo-Dev_DEV300m90_MacOS_x86_install_en-US
After applying the workaround, when opening a presentation document I get a crash.
When I attempt to recover the document, OOo crashes immediately.
If I disable RTE in the preferences, I can open the document.

On the other hand, NeoOffice 3.1.2 recognizes the RTE without the workaround.
------------
Al Maloney
Using OOo_Dev_DEV300 and LO 3.4.1 on Mac OS X 10.6.8
"Velox Versutus Vigilans"
amaloney
 
Posts: 30
Joined: Thu Dec 27, 2007 3:54 am

Re: Java (JRE) issues using Database

Postby rbremer » Thu Oct 21, 2010 11:12 pm

Thanks Larry! OO now detects the JRE.

Unfortunately, I am running into the same issue as Al. OO crashes when I open a template. So not much use.

Ronny
OpenOffice 3.2.1 on MacOS 10.6.4 / OpenOffice 3.2.1 on SLED 11 SP1 / OpenOffice 3.2.1 on OpenSUSE 11.3
rbremer
 
Posts: 7
Joined: Thu Oct 21, 2010 9:35 am

Re: Java (JRE) issues using Database

Postby terry_nyorks » Fri Oct 22, 2010 12:40 am

After running patch via Terminal, from http://www.openoffice.org/issues/show_bug.cgi?id=115180:

OO also detects RTE. However DBase still crashes (several tries, eaxh time) as per report attached.

Is anyone from OO/Oracle/Apple watching this, or can someone report the feedback.

I have to do a review of OO Base, and can't work - my deadline is fast approaching. Help!
Attachments
after patch crash.doc
(125 KiB) Downloaded 203 times
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: Java (JRE) issues using Database

Postby vivianarend » Fri Oct 22, 2010 12:45 am

I just installed NeoOffice and I'm able to access my database now. So that fix worked. Thank you!!
Viv OO 3.2.1 MacBook 10.5.8
vivianarend
 
Posts: 5
Joined: Sat Oct 09, 2010 10:09 pm

Re: [Solved] Java (JRE) issues using Database

Postby amaloney » Fri Oct 22, 2010 10:12 am

I notice that [Solved] has been added to the heading.
However, the basic problem in OOo persists and has not been corrected.
------------
Al Maloney
Using OOo_Dev_DEV300 and LO 3.4.1 on Mac OS X 10.6.8
"Velox Versutus Vigilans"
amaloney
 
Posts: 30
Joined: Thu Dec 27, 2007 3:54 am

Re: [Solved] Java (JRE) issues using Database

Postby floris v » Fri Oct 22, 2010 10:22 am

+1 - It'd be better to mark this topic as an issue and to mention a workaround in the first post, clearly marked as an edit.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3029
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: [Solved] Java (JRE) issues using Database

Postby terry_nyorks » Fri Oct 22, 2010 10:40 am

Please place all further posts on:

viewtopic.php?f=17&t=35194

as this has been closed off prematurely. There are still issues outstanding, e.g. OO DBase still doesn't work after the fix, and actually crashes. (post 11.40pm BST, 21 Oct)
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: [Solved] Java (JRE) issues using Database

Postby terry_nyorks » Fri Oct 22, 2010 10:41 am

Oops, sorry. Wrong link, should be:

viewtopic.php?f=17&t=35194
Open Office 3.2.0 and/or 3.2.1; Mac OS X 10.6.4
terry_nyorks
 
Posts: 10
Joined: Tue Aug 24, 2010 5:25 pm

Re: Java (JRE) issues using Database

Postby vivianarend » Fri Oct 22, 2010 4:42 pm

I've edited the first post- but whether that puts this back into circulation or not- I'm unsure.

I agree- just because I found a work around, I still want the proper solution.
Viv OO 3.2.1 MacBook 10.5.8
vivianarend
 
Posts: 5
Joined: Sat Oct 09, 2010 10:09 pm

Re: [Issue] Java (JRE) issues using Database

Postby amaloney » Sat Oct 23, 2010 4:05 pm

Larry

How do I undo

Code: Select all   Expand viewCollapse view
sudo ln-s .. / .. / Frameworks / JavaVM.framework / JavaVM JavaVM


and restore the previous state of JavaVM?
------------
Al Maloney
Using OOo_Dev_DEV300 and LO 3.4.1 on Mac OS X 10.6.8
"Velox Versutus Vigilans"
amaloney
 
Posts: 30
Joined: Thu Dec 27, 2007 3:54 am

Re: [Issue] Java (JRE) issues using Database

Postby lgusaas » Sat Oct 23, 2010 6:31 pm

amaloney wrote:Larry

How do I undo

Code: Select all   Expand viewCollapse view
sudo ln-s .. / .. / Frameworks / JavaVM.framework / JavaVM JavaVM


and restore the previous state of JavaVM?

I'd suggest asking on the bug report. I don't know the Unix command line.
http://www.openoffice.org/issues/show_bug.cgi?id=115180


Note: I just asked on the Mac Porting mailing list how to do this.

Update: Undo instructions have been posted on the issue report.
Last edited by lgusaas on Mon Oct 25, 2010 8:57 am, edited 1 time in total.
Larry I. Gusaas
Moose Jaw, Sask. Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." — Edgard Varese
Apache OpenOffice 4.1.0 — MacBook Pro — OS X Mavericks (10.9.2)
lgusaas
Volunteer
 
Posts: 1236
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Next

Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 3 guests