[Issue] Zoom issue

Issues installing under the Mac OSX - X11 - Aqua

[Issue] Zoom issue

Postby ellenb » Sat Jun 13, 2009 8:22 am

Since installing OO 3.1, I can't get the page to stay at 100%. In other words, every time I inadvertently move my fingers the wrong way, the page gets bigger or smaller. I did not have this problem with previous versions of OO. Is there anyway to fix this? I reset the zoom at 100%, only to have it change the moment I touch the trackpad the wrong way.

Is there a fix for this? It's so annoying, I don't want to use Open Office any more until it's fixed.
Last edited by Hagar Delest on Thu Nov 05, 2009 1:44 pm, edited 1 time in total.
Reason: tagged the thread as Issue (link to a bug report).
ellenb
 
Posts: 4
Joined: Sat Jun 13, 2009 8:08 am

Re: Zoom issue

Postby TheGurkha » Mon Jun 15, 2009 4:52 pm

Hi and welcome to the forums.

It sounds like the touchpad is somehow causing the zoom slider to change position. But that shouldn't happen unless it is selected. Do you have access to a keyboard that you could plug in as a test, and see if it still happens when you use the real keyboard (which willmake sure your fingers are no where near the touchpad)?
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: Zoom issue

Postby ellenb » Mon Jun 15, 2009 6:29 pm

Not unless I unplug the keyboard from my PC but I suppose I could try... Not home right now so will try it later in the week.

The reason I'm thinking it's not me or my touchpad is because this never happened until I installed 3.1.
OOo 3.1.X on Mac OSx Leopard
ellenb
 
Posts: 4
Joined: Sat Jun 13, 2009 8:08 am

Re: Zoom issue

Postby TheGurkha » Tue Jun 16, 2009 9:34 am

I think the slider was new in 3.0, so if you had 3.0 before 3.1 then yes, this might be a red herring.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
User avatar
TheGurkha
Volunteer
 
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: Zoom issue

Postby ellenb » Sun Jun 21, 2009 11:54 pm

Yes, I had 3.0 before but this never happened.
OOo 3.1.X on Mac OSx Leopard
ellenb
 
Posts: 4
Joined: Sat Jun 13, 2009 8:08 am

Re: Zoom issue

Postby piantadosi » Mon Aug 10, 2009 11:10 pm

New to OO Writer, and I'm having this same problem, I believe. I do nothing except I'm moving the mouse with the trackpad/touchpad on the MacBook Pro and all of a sudden, the zoom level changes dramatically. Sometimes it zooms in, sometimes it zooms out and sometimes it moves both ways. It's very disconcerting. I have not clicked on the zoom slider before this happens — in fact I haven't clicked on anything. It seems to be related to the movement of the mouse, when all I'm doing is just moving it up to click on a button in the tool bar or insert characters somewhere in the document.

Is there some kind of zoom keyboard shortcuts that I don't know about? I may have typed a certain combination of characters to make this happen? Otherwise it just seems like a bug.

Thanks for any assistance,
Roger
OpenOffice 3.1.0 on MacOS 10.5.7
piantadosi
 
Posts: 1
Joined: Mon Aug 10, 2009 10:59 pm

Re: Zoom issue

Postby mrj10 » Mon Sep 14, 2009 11:53 am

I think this may be a trackpad issue.

I was having a similar problem with apparently random zooming (which made the Open Office help text very large and I could find no way to reverse this - there being no view menu in help mode).

I managed to get the text size back to normal again using the trackpad zoom function.

See "Making the screen image larger using your trackpad" and "Changing the way your trackpad works" under Mac Help for further information (search for zoom in Mac Help)
OpenOffice 3.1.1 on Mac OSX10.5.8
mrj10
 
Posts: 1
Joined: Mon Sep 14, 2009 11:34 am

Re: Zoom issue

Postby ellenb » Tue Sep 15, 2009 11:48 am

Thanks very much for the suggestion but I don't think it's a track pad issue. For one thing, it never happened until the 3.1 upgrade of Open Office. I did not change any trackpad settings. Also, the problem only seems to happen with Open Office. I tried to adjust trackpad settings as you suggested but could not find any that made a difference. So if it is a trackpad setting, I could not figure out the right setting for this problem.

I finally bought Word because I could not stand it any more. I don't have the problem with Word.

I actually like Open Office better so if there is a solution, I'd still love to know what it is.
OOo 3.1.X on Mac OSx Leopard
ellenb
 
Posts: 4
Joined: Sat Jun 13, 2009 8:08 am

Re: Zoom issue

Postby exegete77 » Wed Sep 16, 2009 12:08 am

I’m curious, did you try it on NeoOffice and have the same problem?
Mac OS X 10.7.3 Lion
LibreOffice 3.5 / Symphony 3
Scrivener 2.2 / Tinderbox 5.10
exegete77
Volunteer
 
Posts: 230
Joined: Tue May 06, 2008 3:45 pm

Re: Zoom issue

Postby lgusaas » Wed Sep 16, 2009 12:16 am

I actually like Open Office better so if there is a solution, I'd still love to know what it is.

Why don't you file a bug report with complete details of your problem so the developers can have a look at it. See:
viewtopic.php?f=74&t=13490
Larry I. Gusaas
Moose Jaw, SK Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." Edgard Varese
Apache OpenOffice 4.1.7 — MacBook Pro(Retina)—macOS Ver.10.15.7 Catalina
lgusaas
Volunteer
 
Posts: 1561
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Zoom issue

Postby nuke » Wed Oct 07, 2009 5:14 pm

exegete77 wrote:I’m curious, did you try it on NeoOffice and have the same problem?

I'm a bit late to this issue but have been so frustrated with the sensitivity on the zoom that I came looking for a solution today.

In researching this issue, I have noticed that the behaviour occurs in OOWriter and Firefox, amongst others. In NeoOffice, the developers have added a preference that can be selected that stops the zoom sensitivity behaviour. I think it should be added to the Mac codebase for OO too.

Did anyone mark this as a bug so the developers can look into it?
nuke
 
Posts: 9
Joined: Thu Jan 29, 2009 4:48 pm

Re: Zoom issue

Postby Baker555 » Fri Oct 16, 2009 2:09 am

I just wanted to say that I've also had this problem, and it's bad enough to make the program all but unusable.

I do believe it's tied to the touchpad. What I find is that if I place two fingers on the touchpad and move one without moving the other, it triggers a zoom in or zoom out. But since using two fingers on the pad is a vital tool for scrolling through the document, it's a huge pain. The main thing to me is that it seems to be INCREDIBLY sensitive compared to other programs that have the same functionality. Generally I have to make a conscious effort to zoom in or out. With OpenOffice, I have to be incredibly careful NOT to zoom. I could change my touchpad settings, but I like the way it works in every other program I use; it's the oversensitivity of OO that's the problem.
OpenOffice 3.1.1, MacOS 10
Baker555
 
Posts: 1
Joined: Fri Oct 16, 2009 2:04 am

Re: Zoom issue

Postby fk23 » Tue Nov 03, 2009 6:40 pm

Sorry to drag out a slightly old topic but I am having this issue too.

First time user of OO and using it for NaNoWriMo. It might be my fumbly hands but the pinch zoom thing is putting me right off Writer. It's very very easy to accidentally zoom in. And when you zoom back again, it puts the cursor right at the start of the first page again. Very annoying. The zoom is very sensitive too so not always easy to get back to your normal zoomed in state on first go.

If anyone finds a way of turning it off please let me know, it's really distracting from my typing flow! Alternatively, lovely developer sorts, please give us an option to turn it off, it's literally driving me mad.

Ta.
OpenOffice 3.1.1 on Snow Leopard
fk23
 
Posts: 2
Joined: Tue Nov 03, 2009 6:36 pm

Re: Zoom issue

Postby lgusaas » Tue Nov 03, 2009 7:06 pm

fk23 wrote:Alternatively, lovely developer sorts, please give us an option to turn it off, it's literally driving me mad.

No developers here. We are just users, like you, trying to help fellow users. To inform the developers of the problem you need to file a bug report. See this tutorial for instructions on how to do so. viewtopic.php?f=74&t=13490
Larry I. Gusaas
Moose Jaw, SK Canada
Website: http://larry-gusaas.com
"An artist is never ahead of his time but most people are far behind theirs." Edgard Varese
Apache OpenOffice 4.1.7 — MacBook Pro(Retina)—macOS Ver.10.15.7 Catalina
lgusaas
Volunteer
 
Posts: 1561
Joined: Sun Mar 30, 2008 8:32 pm
Location: Moose Jaw, SK Canada

Re: Zoom issue

Postby nuke » Tue Nov 03, 2009 10:38 pm

It looks like this has been logged as a bug.

http://qa.openoffice.org/issues/show_bug.cgi?id=102807

I suggest voting for this to try and get some momentum behind it.
nuke
 
Posts: 9
Joined: Thu Jan 29, 2009 4:48 pm

Re: Zoom issue

Postby fk23 » Tue Nov 03, 2009 10:59 pm

nuke wrote:It looks like this has been logged as a bug.

http://qa.openoffice.org/issues/show_bug.cgi?id=102807

I suggest voting for this to try and get some momentum behind it.


Done and done, thanks for that.
OpenOffice 3.1.1 on Snow Leopard
fk23
 
Posts: 2
Joined: Tue Nov 03, 2009 6:36 pm

Re: [Issue] Zoom issue

Postby chrisjperry » Sat Jan 23, 2010 12:23 pm

On a Mac, go to system preferences/trackpad and de-select "pinch open and close".

CJP
Open Office 3.1 on MacOS10.6
chrisjperry
 
Posts: 1
Joined: Sat Jan 23, 2010 12:18 pm

Re: [Issue] Zoom issue

Postby mgv » Thu Mar 25, 2010 8:41 am

chrisjperry wrote:On a Mac, go to system preferences/trackpad and de-select "pinch open and close".

CJP



I can't turn that option off on my system preferences. Not that I would want to anyway, but its always on. At least on my MacBook Pro

And I do agree that the zoom makes the whole thing unusuable. I've had to start using Excel because of it.

Michael
OpenOffice 3.2 on MacOS 10.5
mgv
 
Posts: 1
Joined: Thu Mar 25, 2010 8:39 am

Re: [Issue] Zoom issue

Postby mcclard.megan » Tue Apr 06, 2010 4:10 pm

On my MacBook Pro, system prefs, in addition to turning of the pinch, under Zoom "options," I
chose to use the command button when I feel like zooming. So far that seems to stop the
very annoying spontaneous zooms.
OpenOffice 3.1.1
mcclard.megan
 
Posts: 1
Joined: Tue Apr 06, 2010 3:53 pm

JUST LOWER THE SENSIBILITY

Postby sergiozambrano » Sat Aug 14, 2010 12:05 pm

JUST DIVIDE BY 3 THE PINCH / MOUSE WHEEL OR WHATEVER ACTIVATES IT.

It's not that bad that it activates by hovering your hands over the touchpad (depending on you being "grounded", static, humidity, etc, touchpad gets very sensible at the point of not needing a finger touching it to get two gesture points detected) but it's REALLY bad that the zoom takes the WHOLE slider run into consideration and makes a 20% INCREMENT for each Pixel (or touchpad unit) !!

The MINIMUM pinch-able zoom change I get is 20%.
E.g. I take the zoom slider to, let's say 53% (away from the "fit to screen" markers, because the pointer is constrained to them there) and the NEXT PERCENTAGE I GET WHEN PINCHING IS 33% ! ! ! THAT'S NUTS.
Mac user since MacPlus. Web/Wordpress plugin/custom theme dev/designer.
Former print designer, DTP/pre-press expert 23+ ys exp. digital Illustration, photography and DTP apps Mac/PC.
http://socialblogsitewebdesign.com Official web of Blogsites.
Oo321
sergiozambrano
 
Posts: 30
Joined: Sat Jun 06, 2009 9:44 am

Re: [Issue] Zoom issue

Postby dim3wit » Sun Aug 22, 2010 2:46 am

It's definitely the pinch-to-zoom feature — if you can't turn it off, you need to run software update.

I like the idea of the feature, myself — there really aren't enough third-party apps that support the gestures on install — but I find it to be waaaaaaaaaay to sensitive, jumpy, and discrete. It moves so fast that it's practically useless. I can't actually reach the zoom I want, but in an instant, I can zoom in on three pixels of my Impress slide or make my writer document appear to be one inch across. :bravo:
OpenOffice.org 3.2.1
Mac OSX 10.6.4 Snow Leopard
Ubuntu 10.04 (rarely used)
User avatar
dim3wit
 
Posts: 13
Joined: Sun Sep 13, 2009 4:07 am

Re: [Issue] Zoom issue

Postby songfellow » Wed Jul 20, 2011 4:12 pm

I finally got disgusted with the zoom issues and deleted OpenOffice from my desktop pc yesterday.

Then I installed Gnumeric spreadsheet software. It exhibited the exact same zoom craziness as OpenOffice.

I have a Logitech MX3200 wireless keyboard and mouse. I do NOT have a touch pad.

I went to the Logitech webpage and updated all of the drivers. Then I pried the SHIFT and CTRL keys off the keyboard using a butter knife and swabbed the keys and the exposed keyboard area with a cotton swab and alcohol.

I have used Gnumeric for over an hour this morning with NO issues at all. Before I did the "maintenance" I couldn't use it for more than 2 minutes without problems. OpenOffice was just as bad or worse.

Maybe I'm being a bit premature but perhaps this is a part of the crazy zoom control problem with Firefox, OpenOffice and Gnumeric.

I've looked on the Internet but can't find anything about the Control or Shift keys being tied too the zoom feature on either piece of software. Nevertheless, I'm hopefully optimistic that this will prove to be a fix.

Steve
Windows XP, Openoffice 3.3.0
songfellow
 
Posts: 1
Joined: Wed Jul 20, 2011 3:58 pm


Return to Mac OSX

Who is online

Users browsing this forum: No registered users and 3 guests