Page 1 of 2

[Solved] Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 7:33 pm
by digitaldave
I have a same problem with Bullet points in Writer - bullet points on an imported Word doc use an odd character (it looks like a square with a spider inside). If I remove the bullet points, and the reinsert them, all appears well until I reopen the file, and it's back to the odd characters again . Does anyone have a solution that will change all bullet points to the correct character? I'm also on Mac OS X 10.5.5 and OO.o v3 final release.

Thanks ,

Dave.

Re: Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 8:07 pm
by kabing
It might be a font issue. The font specified may not contain the character being used, and OpenOffice.org may be substituting a different font when you reset the bullets and numbering, but somehow that substitution isn't carrying over when the document is closed and reopened.

What happens if you try a different font?

What happens if you save the document in odt format? (It may also be a .doc translator issue)

Is the Word document in .doc or .docx format?

kabing

Re: Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 8:39 pm
by digitaldave
OK, I've had a look and found a few things that might help diagnose this :). It's definitely something to do with the conversion. I can create a new document with a short list, and mark them as bullet points, and if I save it as .odt, it opens up again fine, but if I save as Word 97/2000/XP, it re-opens with the odd characters. I also have problems if I save in any of the other Word formats, but that just appears to be incorrect spacing, but with the right characters.

So, how do I go about logging this as a bug so it ca be fixed? :).

Dave.

Re: Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 9:36 pm
by Hagar Delest
Perhaps the same issue as here: Can't see symbols in docs from M$ office (on oooforum).

Re: Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 9:50 pm
by digitaldave
Hagar,

Thanks for the reply. That looks to be exactly the problem I have (although I haven't tried any Greek characters). I guess I'm stuck with it for now then :(. If I can find a legitimate way to get the MS Symbol font on my Mac, would that solve the problem?

Dave.

Re: Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 10:18 pm
by Hagar Delest
I don't think so. If you read the sources I've linked, you'll see that the problem lies in the font encoding of that Word version on the Mac systems. Perhaps it will work if you change the characters used for bullets and change the font to another one.

For the record, here are the links:
- Unicode Issues in Word 97/2000/2002 – FAQ
- Problems with the Symbol font, Greek text, or bullets in Word documents
- Issue 16337 - Symbol font unusable -> Issue 92011 - Aqua: Bullets imported from MS Word use ambigous symbol font

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 10:43 pm
by digitaldave
Hagar,

Thanks for the reply. I'll have a read through the links you posted.

Dave.

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Fri Oct 17, 2008 10:48 pm
by kabing
If you can find it, it might be worth a try, but I'm guessing it won't help. The following is from an article in the Neowiki (a wiki for the NeoOffice port/fork of OpenOffice.org) regarding the bullets issue.

This is because these characters were entered with non-Unicode values in Word, and the OpenOffice.org import filters do not convert the characters to Unicode ones. This seems to be Mac-only OOo bug (or a bug that is only manifest on the Mac, since OOo on Windows has access to Microsoft fonts and Windows methods of mapping characters).


Unfortunately it's been around for several years and does not yet have an assigned target version for a fix.

kabing

Edit: and Hagar beat me to it! Thanks, Hagar!

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Sat Oct 18, 2008 2:05 am
by akhrissanov
Hi,

Thanks , guys, for your replies.
It's sort of understandable that the symbol is just being displayed incorrectly, the problem is that it's impossible to get correct hardcopy of "doc" document if it has bullet points unless you go and fix all of them. It makes OO much less usable on Mac, I don't know why its developers bother to support OO on MacOs when they don't fix really annoying and highly visible bugs for years.
ODT files work fine, the problem only manifests itself if you close document and open it again, and it has to be "doc" document.
non default bullets in OO on MacOs are quite ugly. And, because they are non-default, you still have the same problem when you open document coming from MS Office.

A while back, I found a little note from a guy who managed to substitute Symbol font used by OOffice by default with something called "usyr.pbf" ( I think), which comes as part of TeX & Ghostscript. Guess what, lots of versions changed since then and solution the guy was proposing did not work, at least not on 2.4, 3.0.

It is possible to get TrueType fonts from Microsoft Office, the question is how to incorporate (copy) them into OO without screwing everything else.
Is there somebody knowledgeable who had actually done it? I can imagine that the fonts have to be registered somewhere, conflicts resolved, etc.
I doubt if simple font substitution within OO will work ( I actually tried that, maybe it was a bit naive attempt). Bullet points are system things, there has to be some other mapping within OO...

Are there any OO developers around? I'm sure that every MacOS user saw this problem, what about Linux/Solaris? Had anybody seen it?
For business applications, it simply makes OO unusable on MacOs.

Alex.

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Sat Oct 18, 2008 8:49 am
by Hagar Delest
akhrissanov wrote:Are there any OO developers around?

Not here, post a comment in the issue tracker (I've given the link to the report above).

akhrissanov wrote:I'm sure that every MacOS user saw this problem, what about Linux/Solaris? Had anybody seen it?

It's a MacOS specific issue.

Anyway, .doc format is dead IMHO. Once people will get the advantages of open standards like ODF, they won't use any further a binary format. Even Microsoft has created new file formats (for Office 2007) that are not binary (even if not really 'open').

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Thu Nov 13, 2008 10:50 pm
by phatpmg
Folks,

I hope that someone knowledgeable will find a fix for this very annoying problem,
just in case the .doc agony is protracted (hopefully not).
In the meantime: I found out that the bigger size of the round black bullets causes less (or no) problem when converting to and from .doc


digitaldave wrote:odd character (it looks like a square with a spider inside)

I attach a ZOOM of that character. Maybe, this is of help to the developer?

Thanks

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Sat Dec 13, 2008 7:07 am
by Rob.Crestani
I've had success using the Font Replacement Table, located in the Tools -> Options -> OpenOffice.org ->Fonts
Enable "Apply replacement table", select "Symbol" in the lefthand FONT drop down, select "OpenSymbol" in the righthand "Replace with" dropdown. Press the checkmark to the right to add the substitution to the table. Make sure you check the Always box.

Once this is set up, opening and saving in MSWord 97/XP format preserves the bullet characters in both directions.

Hope this helps.

Rob

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Sun Dec 21, 2008 6:41 pm
by digitaldave
Rob.Crestani wrote:I've had success using the Font Replacement Table, located in the Tools -> Options -> OpenOffice.org ->Fonts
Enable "Apply replacement table", select "Symbol" in the lefthand FONT drop down, select "OpenSymbol" in the righthand "Replace with" dropdown. Press the checkmark to the right to add the substitution to the table. Make sure you check the Always box.

Once this is set up, opening and saving in MSWord 97/XP format preserves the bullet characters in both directions.

Hope this helps.

Rob


Rob,

Thanks very much for this tip - it looks, at least initially, to have solved my problem :).

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Jan 01, 2009 8:03 am
by hedrick
replacing symbol with opensymbol fixes the bullet. But it does not fix files that use other characters from the symbol font. OpenOffice seems to assume that the Microsoft symbol font is available. The simplest solution is to put symbol.ttf in OpenOffice.org.app/Contents/basis-link/share/fonts/truetype. symbol.ttf could be taken from Windows if you don't have licensing issues. To avoid such issues I've generated an appropriate font from the URW symbol font included with Ghostscript, http://techdir.rutgers.edu/symbol.ttf

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Jan 01, 2009 9:55 pm
by digitaldave
Doesn't replacing the symbol font with opensymbol affect all characters in the symbol font?

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Mon Jan 12, 2009 5:18 pm
by UweAltmann
akhrissanov wrote: It makes OO much less usable on Mac, I don't know why its developers bother to support OO on MacOs when they don't fix really annoying and highly visible bugs for years.
Alex.

Yes, you're totally right!
As far as I understood what was said here, the problem comes from inproper character encoding done by some versions of MS Word. So you filed an issue at Microsoft, didn't you? And you got an answer? Would you please be so kind to let us know what the programmers of that bug did say about fixing it for you?

Re: Bullet Point Characters Incorrect

PostPosted: Mon Mar 09, 2009 4:50 pm
by rodolfogomez
kabing wrote:It might be a font issue. The font specified may not contain the character being used, and OpenOffice.org may be substituting a different font when you reset the bullets and numbering, but somehow that substitution isn't carrying over when the document is closed and reopened.

What happens if you try a different font?

What happens if you save the document in odt format? (It may also be a .doc translator issue)

Is the Word document in .doc or .docx format?

kabing


I was saving the document as a .doc. I tried saving the document as .odt and it works ! Thanks!

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Mon Mar 09, 2009 4:54 pm
by rodolfogomez
digitaldave wrote:
Rob.Crestani wrote:I've had success using the Font Replacement Table, located in the Tools -> Options -> OpenOffice.org ->Fonts
Enable "Apply replacement table", select "Symbol" in the lefthand FONT drop down, select "OpenSymbol" in the righthand "Replace with" dropdown. Press the checkmark to the right to add the substitution to the table. Make sure you check the Always box.

Once this is set up, opening and saving in MSWord 97/XP format preserves the bullet characters in both directions.

Hope this helps.

Rob


Rob,

Thanks very much for this tip - it looks, at least initially, to have solved my problem :).


Sorry but it didn't work for me. If one keeps the document as a .odt works without problem.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Wed Jan 13, 2010 10:21 pm
by anne123123
Go to Format -> Bullets and Numbering
- Under "Bullets" select one (I always choose the first one)
- Under "Options" -> Numbering choose Bullet, Character Style choose Bullets, Character choose your Font and find the character you want to use. (I use Times New Roman -> punctuation and choose the small dot)

Then go to your doc and make your bullets.

This workaround has one problem - if you close the doc and then want to do more bullet points you have to redo the settings (The bullets you already did will be ok but new ones will revert to boxes even if it looks like your settings are correct). If someone can tell me how to make the settings stick it would be great.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Tue Feb 16, 2010 9:47 pm
by acodring
Thanks @hedrick. Your approach seems to work great.

    Created test file with some bulleted lists in OoO
    Save and close file
    Opened file in OoO, observed carets instead of expected bullets
    Closed file
    Placed your symbol.ttf font in directory indicated,
    Restarted OoO
    Opened file in OoO
    Observed expected bullets
    Started Windows 7 virtual machine in Fusion
    Opened test file in Word 2007
    Observed expected bullet lists
    Added a new bulleted list
    Saved and closed file in Word 2007
    Re-opened file in OoO
    Observed all bullets as expected.

For anyone confused by the directory location @hedrick gave above, go to your Application folder, right click on 'OpenOffice.org.app' and select "Show Package Contents". Then you can drill down into the folders he gave and copy/paste the file he has provided.

It is ugly to have to download and install a font file from someone I don't know just to solve this problem, but for me it is pretty much the only interop problem remaining between Word and OoO. Until now I've tried hard to ignore it, knowing the files appear OK when I send them to Word users. I have to admit it is very nice now to have the proper bullets appear.

@all: Please let me know if @hedrick's file is actually a trojan. :-)

Thanks again.
Andrew

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Feb 18, 2010 10:16 pm
by acodring
Back again. While yesterday adding in the provided symbol.ttf font seemed to work really well today it isn't. I was back to carets. Baffled.

Instead I've tried the font replacement approach described above and, for now, it is working.
It wasn't specified above, but I selected 'Screen Only'.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Mar 18, 2010 3:17 am
by rforster
Hi everyone,

Was searching on a fix for bullets changing to carets and found this thread. I saw the post for using the font replacement manager. I have a Mac w 10.4 but i can't seem to find this. And the post by hedrick, I don't have a path like that, or that I can find anyway.

I was looking for a way that I could modify, or create a new template with my standard margins, font and size, bullets. Then on opening a doc file if i get the carets I could select all and apply the template. Seems like a reasonable solution, just haven't figured out how.

Thx for any help!

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Mar 18, 2010 3:39 am
by rforster
So I followed one of the other posts and fixed all the bullets. I then saved as Word95 version and when I opened the doc had some form of bullets but no spacing(position width). Did a right click and adjusted the spacing and had regular bullets. Now upon opening there is an ,25 position from the margin as i put, but it didn't save the position from the bullet to the text. Strange.
Does anyone know how to select all and apply a style to the bullets?

Re: Font Replacement Table for OO on MacOS X

PostPosted: Mon Aug 16, 2010 9:13 pm
by tfernsle
To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Aug 19, 2010 10:17 am
by multilingual
I'm having the same exact problem. The bullet point sounds like what digitaldave described nearly 2 yours ago and looks exactly like the image that phatpmg shortly thereafter posted.

I've been able to change the bullet points, but once the file is saved, closed and reopened, this image reappears as the default bullet point.

The character style specified under the options tab in Format -> Bullets and Numbering is WW8Num9z0. My solution has been to save the doc a .odt but I think I'll try saving it as a Windows Office 95 .doc.

Re: Font Replacement Table for OO on MacOS X

PostPosted: Thu Sep 09, 2010 3:19 pm
by dim3wit
tfernsle wrote:To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god


[I hope I'm not necroposting, half a month doesn't seem like too long.]

I was having trouble seeing the π (pi) symbols in my Organic Chemistry powerpoints, and this worked perfectly, thank you very much! I wonder why this isn't the default setting...

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Fri Mar 11, 2011 10:19 am
by parksy
I had to create an account on this community forum just so that I can say Thank You.

This totally works!!!!!!!!!!!!!!!!!!!


OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god

Re: Font Replacement Table for OO on MacOS X

PostPosted: Thu Mar 31, 2011 7:29 pm
by LoopDit
tfernsle wrote:To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god



Thank you!!! This worked for me also.

Re: Font Replacement Table for OO on MacOS X

PostPosted: Sat Apr 09, 2011 7:56 pm
by Ridwan
LoopDit wrote:
tfernsle wrote:To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god


there is no "OpenSymbol" it does NOT exist fir me !!!

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Jul 14, 2011 8:22 pm
by coebruce
OO 3.3, Win7

I would add that you have to change all the wingding and symbol fonts to point to the open symbol font. I was getting a weird three pointed star that residing in the wingding 2 character set. I now have symbol, Wingdings,Wingdings2 and Wingdings 3 pointing to OpenSymbol. Works now.