Page 2 of 2

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Mon Sep 26, 2011 2:39 pm
by crickladian
Thanks to all who contributed to this. The font susbtitution trick worked for me too as long as I mapped all the Wingding fonts as well as the Symbol font to the OpenSymbol font, as suggested above by coebruce. This had been driving me crazy.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Sat Oct 22, 2011 3:51 am
by Phasma Felis
parksy wrote:I had to create an account on this community forum just so that I can say Thank You.

This totally works!!!!!!!!!!!!!!!!!!!


OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god

Thank you for this, but it fails in a pretty insidious way. Affected files now appear properly in OpenOffice on Mac, but if you use OpenOffice to save a file in .doc/.docx format and then load it in MS Word on Windows, the bullet points are corrupted again. This means that files which appear correct to you look wrong when you send them to others. In a way, it's worse than before, because you don't even know it's wrong.

I've been playing with it for a while, and still haven't found any way to fix this other than loading the file in MS Word, manually correcting it, and resaving. I don't know why I keep trying to use OpenOffice.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Tue Nov 08, 2011 9:33 pm
by Mateng
coebruce wrote:OO 3.3, Win7
I would add that you have to change all the wingding and symbol fonts to point to the open symbol font. I was getting a weird three pointed star that residing in the wingding 2 character set. I now have symbol, Wingdings,Wingdings2 and Wingdings 3 pointing to OpenSymbol. Works now.


Thanks - The Windings2 soluton worked for me in Libreoffice Portable 3.4.3 on Win7 64b.

Re: Font Replacement Table for OO on MacOS X

PostPosted: Sat Feb 25, 2012 9:07 pm
by AlinaH
tfernsle wrote:To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god


I apologize for necroposting. This worked for me as well, I just wanted to thank you, thank you, thank you. I got so frustrated but this little thing (was working on my resume!), I almost went out and bought Office for Mac

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Wed Jul 25, 2012 6:23 pm
by levz9
Thank you for this, but it fails in a pretty insidious way. Affected files now appear properly in OpenOffice on Mac, but if you use OpenOffice to save a file in .doc/.docx format and then load it in MS Word on Windows, the bullet points are corrupted again. This means that files which appear correct to you look wrong when you send them to others. In a way, it's worse than before, because you don't even know it's wrong.

I've been playing with it for a while, and still haven't found any way to fix this other than loading the file in MS Word, manually correcting it, and resaving. I don't know why I keep trying to use OpenOffice.


What if you just send people a pdf? PDFs work for everyone and you always know what it looks like. You just need to set up the info in openoffice then create a pdf out of it.

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Oct 25, 2012 6:51 pm
by zahirah
AAAAAHHHHH...I worship you! This has been driving me CRAZY. I made the changes, and it's working perfectly. Thanks so much!!!

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Fri Nov 02, 2012 4:42 pm
by stanzukowski
coebruce wrote:I would add that you have to change all the wingding and symbol fonts to point to the open symbol font... I now have symbol, Wingdings,Wingdings2 and Wingdings 3 pointing to OpenSymbol. Works now.


Finally! I tried every single thing in this thread and this is the one that worked for me. Thanks!

Re: [Issue] Bullet Point Characters Incorrect

PostPosted: Fri May 31, 2013 11:16 am
by Tish
Rob.Crestani wrote:I've had success using the Font Replacement Table, located in the Tools -> Options -> OpenOffice.org ->Fonts
Enable "Apply replacement table", select "Symbol" in the lefthand FONT drop down, select "OpenSymbol" in the righthand "Replace with" dropdown. Press the checkmark to the right to add the substitution to the table. Make sure you check the Always box.

Once this is set up, opening and saving in MSWord 97/XP format preserves the bullet characters in both directions.

Hope this helps.

Rob


Hi Rob, and sorry for this - very - late reaction, but I've not been able to try out your solution before yesterday: it works !!
Thanks a lot!
Tish

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Wed May 07, 2014 7:54 pm
by tom2323
thanks so much rid wan

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Tue Apr 07, 2015 4:00 pm
by sidra0
tfernsle wrote:
To get to the Font Replacement Table using Open Office on a Mac, and fix symbols;
OpenOffice.org -> Preferences -> OpenOffice.org -> Fonts
1) check "apply replacement table"
2) under the "Font" drop-down select "Symbol"
3) under the "Replace With" crop-down select "OpenSymbol"
4) check the green checkmark to the left, your mapping should show up in the replacement table
5) check "always" next to the symbol mapping
6) hit "ok"
7) rest like a god


I apologize for reviving an old dead thread. I thought others would want to know the above worked for me in OOo 4.1.1 to get some old documents working. After reading through this thread, I've decided to convert any doc files I use in the future to the .odt format to get around Microsloth's failure to use a sane document saving system. Only took them about a decade...

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Thu Oct 15, 2015 6:57 am
by sascia
The solution posted above by tfernsle on Mon Aug 16, 2010 worked for me today. Thank you very much. :D

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Tue Sep 05, 2017 11:21 pm
by rajanski
replacing symbol with opensymbol fixes the bullet. But for me it worked only after manually installing the Symbol.ttf font (I am on Ubuntu 16.04). OpenOffice seems to assume that the Microsoft symbol font is available. The simplest solution is to put symbol.ttf in OpenOffice.org.app/Contents/basis-link/share/fonts/truetype. symbol.ttf could be taken from Windows if you don't have licensing issues. To avoid such issues I've generated an appropriate font from the URW symbol font included with Ghostscript, techdir.rutgers.edu/symbol.ttf

Re: [Solved] Bullet Point Characters Incorrect

PostPosted: Wed Sep 06, 2017 4:17 pm
by John_Ha