AOO won't use native GUI elements on Fedora 23

Issues with installing under all Linux Distributions

AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 1:02 am

All versions of AOO up to 4.1.2 worked fine on my system, under Fedora 21.

When I upgraded Fedora to the 23 release, all AOO versions will not use the native Gnome UI elements but instead fall back to (what I assume is) a GUI toolkit bundled with AOO. It works well enough except for two things: the UI elements are uncomfortably small and hard to see/read, and AOO seems to crash a lot more (I'm guessing this has to do with the GUI toolkit, as AOO has been very stable for me before this).

Does anyone have any idea how I might go about trying to debug this? I've not asked the Fedora people since they support LibO and that works just fine.

BTW: It's not a profile issue (first thing I tried).
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 6:41 am

Have you tried the old trick of starting OO from a terminal to observe any error messages? In a terminal type "openoffice4" (no quotes).
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 7:44 am

Good idea. Unfortunately, no messages.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 7:52 am

I found this, but I am now beyond my knowledge - I only used a version of Fedora very briefly some years ago, on my path to choosing Xubuntu.
https://ask.fedoraproject.org/en/question/84953/how-to-install-gnome-320-of-fedora-23/
 Edit: added URL 
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 2:25 pm

Interesting. Thanks for looking.

Is there somewhere else I should ask? Are there developer-types on the Apache mailing list? Which would be best?
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 2:33 pm

I'm brooding on your question. What is missing? It may be possible to hand install it.

The quick glance I had at Fedora 23 comments didn''t impress me.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 5:35 pm

I haven't tried tracing system calls. I've tried that before and found it like looking for a needle in a haystack but it might give me a clue as to what it's looking for.

I guess I was hoping to find someone who can tell me what it means when OO switches to this other UI. It could be a simple configuration problem. But I don't know where/who to ask.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 6:19 pm

I found this
https://fedoraproject.org/wiki/Changes/ApacheOpenOffice

The author is a major developer of OO, so you might contact him.

PM me if necessary
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 7:48 pm

Good idea!

I finally thought to check if anyone else has reported it, but nothing in the Apache or Fedora bugzillas.

Tried installing a snapshot build from May 2; no better. Maybe I should try a 4.2 dev build.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 7:58 pm

PS: I forgot to mention ...

I noticed this odd thing: if I start a new text document and insert a comment, the font box in the formatting toobar shows this (verbaitm, copy/paste):
Andale Sans UI;Arial Unicode MS;Lucida Sans Unicode;Tahoma;DejaVu Sans;Albany AMT;Albany;Arial;Nimbus Sans L;Bitstream Vera Sans;Interface User;WarpSans;Geneva;Tahoma;MS Sans Serif;Helv;Dialog;Lucida;Helvetica;Charcoal;Chicago;Helmet;Interface System;Sans Serif

Which doesn't look like a setting that OO would include, that maybe OO is getting a font spec from the system that it doesn't understand, and that throws off the whole UI configuration.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 8:19 pm

In OO, a normal comment seems to allow exactly all the fonts that are available to a document.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 9:15 pm

That makes sense, but a) that's a tiny subset of the hundreds of fonts that appear in the OO font selector, and I don't see a pattern to what's there. And b) OO Writer doesn't support a font setting like that. At least when I've tried to use something like font1;font2, I just end up with a generic substituted font.

What do other people see as the comment font? Libreoffice just shows the same (default) font as in the main document window, but I'm not sure how comparable LibO and AOO are at this point.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 9:22 pm

I've just made a very quick test. In a document using Times New Roman and Georgia, an inserted comment uses DejaVu Sans.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 9:55 pm

An outside chance: have you rebuilt the font cache? In Debian based systems this is done by
Code: Select all   Expand viewCollapse view
sudo fc-cache -f -v


The command line should be the same; change only the superuser invocation to suit Fedora.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Fri May 27, 2016 10:29 pm

Ooh, good idea!

There were some old (two years) files in the cache, but removing them and rebuilding (fc-cache -r) hasn't changed anything. Restarted the desktop just to be sure.

I guess my idea about the font list coming from the system isn't right: at least some of the font names there are not present anywhere on the system, nor are thy mentioned in the font server config files.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: AOO won't use native GUI elements on Fedora 23

Postby RoryOF » Fri May 27, 2016 11:03 pm

I was thinking of a problem that has been reported on Forum on Macs, which are using a linux derived system. That problem is cured by rebuilding the font cache.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29478
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: AOO won't use native GUI elements on Fedora 23

Postby acknak » Mon Jun 06, 2016 9:08 pm

Just for the record, as RoryOF suggested, here:
viewtopic.php?p=388213#p388213

I tried the env variables, like so:
SAL_USE_VCLPLUGIN=gtk /path/to/soffice
SAL_USE_VCLPLUGIN=gtk3 /path/to/soffice
OOO_FORCE_DESKTOP=gnome SAL_USE_VCLPLUGIN=gtk /path/to/soffice

No effect.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest