/opt/openoffice4/program/soffice.bin X11 error: Can't open d

Issues with installing under all Linux Distributions

/opt/openoffice4/program/soffice.bin X11 error: Can't open d

Postby chinacvic » Mon Nov 02, 2015 4:25 am

log on via ssh,
centos 7 with openoffice 4.1.2

[root@iZ23iezikfpZ program]# ./soffice --headless --accept="Socket,host=127.0.0.1,port=8100;urp;" --nofirstwizard
/opt/openoffice4/program/soffice.bin X11 error: Can't open display:
Set DISPLAY environment variable, use -display option
or check permissions of your X-Server
(See "man X" resp. "man xhost" for details)
centos7
openoffice 4.1.2
chinacvic
 
Posts: 1
Joined: Mon Nov 02, 2015 4:20 am

Re: /opt/openoffice4/program/soffice.bin X11 error: Can't op

Postby Villeroy » Mon Nov 02, 2015 8:29 am

You have the exact same problem with any other GUI application. This is not related to OpenOffice.
man ssh and read about X11 forwarding.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27107
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests