Unable to install on Ubuntu 15.04

Issues with installing under all Linux Distributions

Unable to install on Ubuntu 15.04

Postby wilfy100 » Thu Aug 20, 2015 5:21 pm

I have tried several times to install open office on my computer running Ubuntu 15.04. I have very carefully copied the commands into the terminal but it always fails to work. It says it cannot find the needed files in the Temporary folder.
I would like to ask in general terms why it is necessary to go through all this terminal mumbo jumbo to install a program. Why is the average Joe soap expected to be a command line wizard just to install a program. The Ubuntu software centre is excellent (the way things should be) but OpenOffice does not seem to be available through this. As an aside the installed as standard Libre Office writer locks my computer up to the point of having to hit the reset button. The Open office install procedure deleted the the libre office package so now I am looking for a text editor to allow me to get things done. I apologise for the Winge but any help would be appreciated.
OpenOffice 2.4 on Ubuntu 9.04
wilfy100
 
Posts: 1
Joined: Tue Aug 18, 2015 3:39 pm

Re: Unable to install on Ubuntu 15.04

Postby Villeroy » Thu Aug 20, 2015 5:46 pm

Ubuntu comes with LibreOffice which is almost identical to OpenOffice.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 27105
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Unable to install on Ubuntu 15.04

Postby RoryOF » Thu Aug 20, 2015 6:07 pm

OpenOffice installs perfectly on Ubuntu - I've used it on Ubuntu and Ubuntu derivatives from 8.04 on.

As to why "it is necessary to go through all this terminal mumbo jumbo to install a program", that's the way linux is; if you use linux, you should be prepared for it.

How to install OO in Ubuntu:
In a terminal type
Code: Select all   Expand viewCollapse view
sudo apt-get purge libreoffice*


Note that the the trailing * is important.

Download the correct version of OpenOffice for the bitness of your Ubuntu. To find this out, in a terminal type

Code: Select all   Expand viewCollapse view
uname -i


if your answer is

Code: Select all   Expand viewCollapse view
x86_64


then you are running 64 bit Ubuntu. If it is i386, then 32 bit Ubuntu.
Best to match the bits of your OpenOffice with the bits of your Ubuntu

When the file is downloaded, double click on it and the system archive manager should start up. Tell it to extract the files - these are normally extracted to a sub directory of the Downloads folder, in my case called en-GB (as I use the GB version). If you use the US version, this folder might be en-US.

Now, in a terminal manoeuvre to that sub folder. In my case this is by the following commands; in your case rory will be replaced by your logon name and en-GB may be changed, as I mentioned.

Code: Select all   Expand viewCollapse view
cd /home/rory/Downloads/en-GB
cd DEBS
sudo dpkg -i *.deb


When that has completed, do this

Code: Select all   Expand viewCollapse view
cd desktop-integration
sudo dpkg -i *.deb


Do not omit this last change of directory and repeat of the installation command, as this puts links for OpenOffice into your Office group.
Also note that in linux caps/lowercase are important

It takes longer to write out all this than it actually takes to do!
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29448
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unable to install on Ubuntu 15.04

Postby MikeytheMagnificent » Wed Sep 23, 2015 12:45 am

afaik My Ubuntu 15 from Linux Format came with LO 4.? but without Base which I had to add later. Just a silly annoyance. Possibly other minor components omitted also. I can't say for sure that machine's elsewhere
Many opportunities to add short Tutorials or faq's are missed

1. Must have obvious title to be found easily
2. Keep to objectives
3. Use very clear language
4. Difficult to get right
5. Rewards are few
User avatar
MikeytheMagnificent
 
Posts: 137
Joined: Fri Apr 11, 2008 12:06 am
Location: W. Yorks UK

Re: Unable to install on Ubuntu 15.04

Postby madman1978@gmail.com » Thu Jan 07, 2016 8:36 pm

I have tried in my attempt to install open office and this is not working either But I am using Ubuntu 14.04

This is the error I keep getting

Errors were encountered while processing:
openoffice4.0-debian-menus*.deb
OpenOffice 4.1.2
Ubuntu 14.04
madman1978@gmail.com
 
Posts: 2
Joined: Thu Jan 07, 2016 8:30 pm

Re: Unable to install on Ubuntu 15.04

Postby RoryOF » Thu Jan 07, 2016 9:14 pm

From memory, that usually means that all LibreOffice hasn't been removed. Use
Code: Select all   Expand viewCollapse view
sudo apt-get purge libreoffice*

Do not omit the trailing *
and then install OpenOffice again.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29448
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Unable to install on Ubuntu 15.04

Postby RoryOF » Thu Jan 07, 2016 9:32 pm

All I can suggest is that you verify the downloaded installation file by the methods described in
Apache OpenOffice - How to verify the integrity of the downloaded file?
If it doesn't pass, try a new download and verify that. Then restart your computer and reinstall using the method I outlined above. For new ?ubuntu installs I just do this automatically.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29448
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests