Calc: paste using middle mouse button

Issues with installing under all Linux Distributions

Calc: paste using middle mouse button

Postby acknak » Sun May 31, 2015 3:59 am

To copy/paste using OO Calc on Linux, I can select something and click the middle mouse button to paste it--no keys needed. It's an odd feature but it's handy and I use it a lot, especially in Calc.

The problem is that Calc seems to have two modes: sometimes the paste replaces whatever is in the cell I click on; other times, Calc inserts new cells to make room and the cells below are pushed down. The second mode (insert) often disrupts my sheets where they contain data in rows: shifting one column down destroys the row integrity.

The mode switch seems to happen randomly while I'm working with Calc: all of a sudden a paste starts shifting cells. I don't know what's causing it to switch but I'd very much like to avoid it or somehow switch back to replace mode.

I've tried Paste Special and ticked the "move cells down" option--that doesn't seem to trigger the mode switch. Same for Insert > Cells ...

Any other ideas? Some other setting that might affect this behavior?

 Edit: PS: 
I just noticed that the mode resets if I close and restart Calc. So maybe it's just a bug. No idea why I never tried that before.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Calc: paste using middle mouse button

Postby Hagar Delest » Sun May 31, 2015 12:44 pm

I often use this middle-click feature and I've never experienced the insertion of cells. It always replaced the content of the cell where I paste.
LO 6.4.6 on Xubuntu 20.04 and Windows 10.
User avatar
Hagar Delest
Moderator
 
Posts: 29079
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Linux

Who is online

Users browsing this forum: No registered users and 5 guests