Page 1 of 1

[Solved] Deb dependency issue OOo-Dev 3.0 build DEV300_m23

PostPosted: Wed Jul 09, 2008 6:14 am
by sak102010
Hey everybody,

Hopefully someone can give me a little guidance. I'm trying to install the debs for OOo 3 development snapshot that are available from here...

http://download.openoffice.org/680/?intcmp=1235

The problem I'm running into is that the following list of packages claim that a dependency is not being met

Error: Dependency is not satisfiable: ooobasis-dev3.0-en-US

Code: Select all   Expand viewCollapse view
ooobasis-dev3.0-en-us-base_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-binfilter_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-calc_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-draw_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-help_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-impress_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-math_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-onlineupd_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-res_3.0.0-23_i386.deb
ooobasis-dev3.0-en-us-writer_3.0.0-23_i386.deb


There is a package with this name that is available, and installed:

Code: Select all   Expand viewCollapse view
ooobasis-dev3.0-en-us_3.0.0-23_i386.deb


However, in dpkg, it identifies itself as...

ooobasis-dev3.0-en-us

...note the lowercase us as opposed to the uppercase US that the other packages claim are a dependency.

Anyway, I'm not sure who to contact about this issue, or if someone else may have encountered it and could possibly offer me a suggestion as to how to fix.

Thanks,
Sak.

Re: Deb dependency issue OOo-Dev 3.0 (build DEV300_m23)

PostPosted: Wed Jul 09, 2008 8:33 am
by Hagar Delest

Re: Deb dependency issue OOo-Dev 3.0 (build DEV300_m23)

PostPosted: Wed Jul 09, 2008 8:49 am
by sak102010

Re: [Issue] Deb dependency issue OOo-Dev 3.0 (build DEV300_m23)

PostPosted: Fri Aug 01, 2008 6:23 am
by sak102010
Problem resolved in later packages.

Re: [Solved] Deb dependency issue OOo-Dev 3.0 build DEV300_

PostPosted: Tue Mar 19, 2013 2:47 am
by naishoya
And the same problem rears its head in the latest 3.4 packages.

If someone will just build a proper ubuntu / debial monolithic .deb and get the small-case large-case issue sorted out the world will make more sense and just function.

Re: [Solved] Deb dependency issue OOo-Dev 3.0 build DEV300_

PostPosted: Wed Mar 20, 2013 12:54 am
by Hagar Delest

Re: [Solved] Deb dependency issue OOo-Dev 3.0 build DEV300_

PostPosted: Wed Mar 20, 2013 8:25 am
by RoryOF
If the problem is not fixed, as naishoya claims, why is AOO 3.4.1 running on my Ubuntu 12.04 systems and Hagar's Ubuntu 12.10 systems?

Usually any problem with installing an Apache (or earlier Oracle) version of OpenOffice on an operating system which comes with preinstalled OpenOffice or LibreOffice boils down to incomplete removal of the existing installation before installing the other version. How this is done depends on the computer skills and ability of the user, which is a matter over which the Forum has no control.