[Solved] In Ubuntu 32 bit 14.10 OpenOffice not working

Issues with installing under all Linux Distributions

[Solved] In Ubuntu 32 bit 14.10 OpenOffice not working

Postby mani895m » Fri Feb 20, 2015 9:48 am

Hi,


I have installed open office 4.1.1 in ubuntu 32 bit 14.10 version.

i followed all the steps mentioned in forum to install(1.all debs file, 2.desktop integration). There is no issue in installation. But open office not display anywhere in ubuntu. Also i removed the libreoffice from ubuntu.

i have to use starting openoffice in terminal by typing below command,
cd /opt/openoffice4/program/
./soffice.bin

But once i closed openoffice i can't reopen that anywhere in ubuntu. everytime i have to use that command for open.

What is the issue in that... plz solve this issue...
Last edited by RoryOF on Fri Feb 20, 2015 12:22 pm, edited 2 times in total.
Reason: Added green tick. [RoryOF, Moderator]
Open office 4.0
ubuntu 14.10
mani895m
 
Posts: 5
Joined: Fri Feb 20, 2015 9:38 am

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby RoryOF » Fri Feb 20, 2015 9:57 am

Did you run the desktop-integration section of the install file? If so, OpenOffice should show up in the Office section. OO4.1.1 runs well for me on Xubuntu 14.10. In a terminal, my OpenOffice will start by openoffice4, without needing to specify a path.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby mani895m » Fri Feb 20, 2015 10:10 am

yes i did desktop-integration also...but not showing on anywhere.. i have tried in another system also... same issue on there... but my installation is ubuntu not xubuntu
Open office 4.0
ubuntu 14.10
mani895m
 
Posts: 5
Joined: Fri Feb 20, 2015 9:38 am

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby RoryOF » Fri Feb 20, 2015 10:13 am

On every installation of OpenOffice I have ever carried out (both 32 and 64 bit), desktop-integration step placed the OO components in the Office group.

Will openoffice4 in a terminal (no path specified) start OpenOffice?
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby mani895m » Fri Feb 20, 2015 10:28 am

it showing error like command not found.
Open office 4.0
ubuntu 14.10
mani895m
 
Posts: 5
Joined: Fri Feb 20, 2015 9:38 am

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby RoryOF » Fri Feb 20, 2015 10:38 am

In that case, I'd suggest using a terminal and re-entering the uncompressed OpenOffice installation files as far as to the desktop-integration folder (on my system, these are at /home/rory/Downloads/en-GB/DEBS/desktop-integration) and re-running the desktop-integration step. In my case this is done by the following code (you will need to change the path to suit your setup, which may also need en-GB changed to en-US or as appropriate).

Code: Select all   Expand viewCollapse view
cd /home/rory/Downloads/en-GB/DEBS/desktop-integration
sudo dpkg -i *.deb


Keep a careful lookout for any errors in that process - they may be in course of execution, not flagged at the end.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby mani895m » Fri Feb 20, 2015 11:54 am

sorry i didn't notice that... i got error like below when desktop integration command process end:
Errors were encountered while processing:
openoffice4.1-debian-menus_4.1.1-9775_all.deb
Open office 4.0
ubuntu 14.10
mani895m
 
Posts: 5
Joined: Fri Feb 20, 2015 9:38 am

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby RoryOF » Fri Feb 20, 2015 12:02 pm

Without detailed knowledge of the exact error I can only guess. My own experience was that this resulted from incomplete removal of LibreOffice. I'd suggest using a terminal and typing
Code: Select all   Expand viewCollapse view
sudo apt-get purge libreoffice*

Note the * in the code line - it is important.

Then reinstall OpenOffice - best to do it all, just in case something is missing.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31738
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: In Ubuntu 32 bit 14.10 OpenOffice not working

Postby mani895m » Fri Feb 20, 2015 12:14 pm

ok thanks for your support... its working now...grt...
Open office 4.0
ubuntu 14.10
mani895m
 
Posts: 5
Joined: Fri Feb 20, 2015 9:38 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 3 guests